summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-07 11:47:58 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-07 13:00:00 +0100
commit0ea90f38bbcd7a9bce3c4a8a204e49a8c4657e94 (patch)
tree28c71341673bece7e84f4dd7f1d044d9aa327d1c /dev-python/pycurl
parentdev-python/nose-show-skipped: Keyword under ALLARCHES policy (diff)
downloadgentoo-0ea90f38bbcd7a9bce3c4a8a204e49a8c4657e94.tar.gz
gentoo-0ea90f38bbcd7a9bce3c4a8a204e49a8c4657e94.tar.bz2
gentoo-0ea90f38bbcd7a9bce3c4a8a204e49a8c4657e94.zip
dev-python/pycurl: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pycurl')
-rw-r--r--dev-python/pycurl/Manifest1
-rw-r--r--dev-python/pycurl/pycurl-7.43.0.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/pycurl/Manifest b/dev-python/pycurl/Manifest
index df875b16eaa3..2b337faa1419 100644
--- a/dev-python/pycurl/Manifest
+++ b/dev-python/pycurl/Manifest
@@ -2,3 +2,4 @@ DIST pycurl-7.19.3.1.tar.gz 116687 SHA256 c0d673fe99a9de07239eabe77c798f1b043f60
DIST pycurl-7.19.5.1.tar.gz 142140 SHA256 6e9770f80459757f73bd71af82fbb29cd398b38388cdf1beab31ea91a331bc6c SHA512 89a474d7285cb040099dc6107a238f326dcb22cdb2c2325139f0d7ebea56f0860869d20b6e8e3bb43882048a261a8ff5734c7fc3e790fde8a96de3fffd04894f WHIRLPOOL 87eac50707acb4d764941e334a490d1c72c28433e8ff72caa7811f23d3f8ab2c6949a25ba8edd0cdacb27e498e60e728745c787a05853f1428ede8d91294a5cc
DIST pycurl-7.19.5.3.tar.gz 154800 SHA256 24f6c4016b1dd2a5e29d1b025ac2ad61f80c17adfdcf8a7f47aefab63ace78d7 SHA512 f7e65e0c6f7d1666ed3bebc4fabb41205f6dadd96d80fb5d1985c13ab28d35effef2966e961383e01881648fca4a4d500e9692d712888313dbe164b2c651530c WHIRLPOOL c5fe1cc232bae07dfc63e1a8a3b0929b3c1bbf7adf29c2b6085e5bc1e97656d6f5afc236974bfc3febdd2ab4fe1b7cce08c96d4a8eba5ba870505c7c423badeb
DIST pycurl-7.21.5.tar.gz 170962 SHA256 8a1e0eb55573388275a1d6c2534ca4cfca5d7fa772b99b505c08fa149b27aed0 SHA512 0f07b9e2256e4e019bf0ac85d9ca2fff56cffd49986495f2235f91e341ed937c9895da1636548be90523404027d063d83910055899e178e653842bc5de4151c4 WHIRLPOOL 2e46b5e16181d3cc66be56b38d40f4b7fd2ff7b9574fc4214247140a43ce70c0eac71d793ceddd24ff05bf784a1e8105c315fa4a7b0460bd908901b159e6655d
+DIST pycurl-7.43.0.tar.gz 182522 SHA256 aa975c19b79b6aa6c0518c0cc2ae33528900478f0b500531dbcdbf05beec584c SHA512 7442462c74c19964b9d72976e9b92bf68bb37debc1401bc399590bea42704065da13d6de710e795eeae79a4651b9a08841d50454243cb0994c7eb1c1bab233a5 WHIRLPOOL 640ef7669273bccdf72f0d98bd5f5c9d882f35ac507d2152f8ab1e2e680298ebe2691b4960713bb39b0a405ba8d0e9a03d69617c5150bb65581efaab99304185
diff --git a/dev-python/pycurl/pycurl-7.43.0.ebuild b/dev-python/pycurl/pycurl-7.43.0.ebuild
new file mode 100644
index 000000000000..38c13db92e24
--- /dev/null
+++ b/dev-python/pycurl/pycurl-7.43.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# The selftests fail with pypy, and urlgrabber segfaults for me.
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="python binding for curl/libcurl"
+HOMEPAGE="
+ https://github.com/pycurl/pycurl
+ https://pypi.python.org/pypi/pycurl
+ http://pycurl.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="curl_ssl_gnutls curl_ssl_libressl curl_ssl_nss +curl_ssl_openssl examples ssl test"
+
+# Depend on a curl with curl_ssl_* USE flags.
+# libcurl must not be using an ssl backend we do not support.
+# If the libcurl ssl backend changes pycurl should be recompiled.
+# If curl uses gnutls, depend on at least gnutls 2.11.0 so that pycurl
+# does not need to initialize gcrypt threading and we do not need to
+# explicitly link to libgcrypt.
+RDEPEND="
+ >=net-misc/curl-7.25.0-r1[ssl=]
+ ssl? (
+ net-misc/curl[curl_ssl_gnutls(-)=,curl_ssl_libressl(-)=,curl_ssl_nss(-)=,curl_ssl_openssl(-)=,-curl_ssl_axtls(-),-curl_ssl_cyassl(-),-curl_ssl_polarssl(-)]
+ curl_ssl_gnutls? ( >=net-libs/gnutls-2.11.0 )
+ )"
+
+# bottle-0.12.7: https://github.com/pycurl/pycurl/issues/180
+# bottle-0.12.7: https://github.com/defnull/bottle/commit/f35197e2a18de1672831a70a163fcfd38327a802
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/bottle[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/nose-show-skipped[${PYTHON_USEDEP}]
+ net-misc/curl[curl_ssl_gnutls(-)=,curl_ssl_libressl(-)=,curl_ssl_nss(-)=,curl_ssl_openssl(-)=,-curl_ssl_axtls(-),-curl_ssl_cyassl(-),-curl_ssl_polarssl(-),kerberos]
+ >=dev-python/bottle-0.12.7[${PYTHON_USEDEP}]
+ )"
+# Needed for individual runs of testsuite by python impls.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ sed -e "/setup_args\['data_files'\] = /d" -i setup.py || die
+ sed -e '/pyflakes/d' -i Makefile || die
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ # Override faulty detection in setup.py, bug 510974.
+ export PYCURL_SSL_LIBRARY=${CURL_SSL/libressl/openssl}
+}
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}
+
+python_test() {
+ emake -j1 do-test
+}
+
+python_install_all() {
+ local HTML_DOCS=( doc/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}