summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-03 11:20:35 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-03 11:24:40 +0100
commit53adeabf00399dbfe3fe41cef04490d93cb8268f (patch)
tree9a27466f7d5ccf20cfd6d03f7489b58104671eb1 /dev-python/pycurl
parentdev-python/numexpr: Version Bump (diff)
downloadgentoo-53adeabf00399dbfe3fe41cef04490d93cb8268f.tar.gz
gentoo-53adeabf00399dbfe3fe41cef04490d93cb8268f.tar.bz2
gentoo-53adeabf00399dbfe3fe41cef04490d93cb8268f.zip
dev-python/pycurl: Verison Bump
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pycurl')
-rw-r--r--dev-python/pycurl/Manifest1
-rw-r--r--dev-python/pycurl/pycurl-7.19.5.2.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/pycurl/Manifest b/dev-python/pycurl/Manifest
index 28e772b26e45..a83c1e0f0849 100644
--- a/dev-python/pycurl/Manifest
+++ b/dev-python/pycurl/Manifest
@@ -1,2 +1,3 @@
DIST pycurl-7.19.3.1.tar.gz 116687 SHA256 c0d673fe99a9de07239eabe77c798f1b043f60c02afaec1430ceaf59d7501a4f SHA512 65ccb07638c663bc2a723664f1ade50f08eafa70bbcdc492cc99362a91873f453b63336a6b393d9f6591308f1450dadc64ce729b29990f37b170dda0eae0b23f WHIRLPOOL bf25bbb959e30140a261b9bede2e1a3675ec99c8f6c36f8afc8ca73288aa7f7cea6fa1d28385ca808872b251a676aebf8d77d203aed60619dab8852cac17b296
DIST pycurl-7.19.5.1.tar.gz 142140 SHA256 6e9770f80459757f73bd71af82fbb29cd398b38388cdf1beab31ea91a331bc6c SHA512 89a474d7285cb040099dc6107a238f326dcb22cdb2c2325139f0d7ebea56f0860869d20b6e8e3bb43882048a261a8ff5734c7fc3e790fde8a96de3fffd04894f WHIRLPOOL 87eac50707acb4d764941e334a490d1c72c28433e8ff72caa7811f23d3f8ab2c6949a25ba8edd0cdacb27e498e60e728745c787a05853f1428ede8d91294a5cc
+DIST pycurl-7.19.5.2.tar.gz 153347 SHA256 98cc821555d152977fac99b6e5cb0f759275aabdf14e4928890c6fcc944ab736 SHA512 4f7b8fe59ce9a5597def6356c6af3b23c2fed52e2de022c048d70cd6d3f6e384b0cce8007c656703416284c20d159a0fcb953817e2780ef324ce521349e7041a WHIRLPOOL a42851c36c807349df6c9e33f6e6f0ef8924878d58e9209bfc8d0bdea16c41f81445ac4bc2c75efaea0c77af297149850120ac4d5413fc2622703ef4c3c351c1
diff --git a/dev-python/pycurl/pycurl-7.19.5.2.ebuild b/dev-python/pycurl/pycurl-7.19.5.2.ebuild
new file mode 100644
index 000000000000..9bc9ff802485
--- /dev/null
+++ b/dev-python/pycurl/pycurl-7.19.5.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# The selftests fail with pypy, and urlgrabber segfaults for me.
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="python binding for curl/libcurl"
+HOMEPAGE="https://github.com/pycurl/pycurl https://pypi.python.org/pypi/pycurl"
+SRC_URI="http://pycurl.sourceforge.net/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="curl_ssl_gnutls curl_ssl_libressl curl_ssl_nss +curl_ssl_openssl examples ssl test"
+
+# Depend on a curl with curl_ssl_* USE flags.
+# libcurl must not be using an ssl backend we do not support.
+# If the libcurl ssl backend changes pycurl should be recompiled.
+# If curl uses gnutls, depend on at least gnutls 2.11.0 so that pycurl
+# does not need to initialize gcrypt threading and we do not need to
+# explicitly link to libgcrypt.
+RDEPEND="
+ >=net-misc/curl-7.25.0-r1[ssl=]
+ ssl? (
+ net-misc/curl[curl_ssl_gnutls(-)=,curl_ssl_libressl(-)=,curl_ssl_nss(-)=,curl_ssl_openssl(-)=,-curl_ssl_axtls(-),-curl_ssl_cyassl(-),-curl_ssl_polarssl(-)]
+ curl_ssl_gnutls? ( >=net-libs/gnutls-2.11.0 )
+ )"
+
+# bottle-0.12.7: https://github.com/pycurl/pycurl/issues/180
+# bottle-0.12.7: https://github.com/defnull/bottle/commit/f35197e2a18de1672831a70a163fcfd38327a802
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/bottle-0.12.7[${PYTHON_USEDEP}]
+ )"
+# Needed for individual runs of testsuite by python impls.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+# https://github.com/pycurl/pycurl/issues/299
+RESTRICT=test
+
+python_prepare_all() {
+ sed -e "/setup_args\['data_files'\] = /d" -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ # Override faulty detection in setup.py, bug 510974.
+ export PYCURL_SSL_LIBRARY=${CURL_SSL/libressl/openssl}
+}
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}
+
+python_test() {
+ emake -j1 do-test
+}
+
+python_install_all() {
+ local HTML_DOCS=( doc/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}