summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-10-13 21:18:59 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-10-13 22:02:09 +0300
commit0a3ef4405ad52cc651470ebd369a26d91f046ea4 (patch)
tree689f2092ab3b9bc8985a5c67f5c1604697c8b54c /dev-python/pydevd
parentdev-python/python-fcl: enable py3.10, add missing cython bdep (diff)
downloadgentoo-0a3ef4405ad52cc651470ebd369a26d91f046ea4.tar.gz
gentoo-0a3ef4405ad52cc651470ebd369a26d91f046ea4.tar.bz2
gentoo-0a3ef4405ad52cc651470ebd369a26d91f046ea4.zip
dev-python/pydevd: add 2.6.0, enable py3.10
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pydevd')
-rw-r--r--dev-python/pydevd/Manifest1
-rw-r--r--dev-python/pydevd/pydevd-2.6.0.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/dev-python/pydevd/Manifest b/dev-python/pydevd/Manifest
index 70b8a69447da..83d76a204383 100644
--- a/dev-python/pydevd/Manifest
+++ b/dev-python/pydevd/Manifest
@@ -1 +1,2 @@
DIST pydev_debugger_2_5_0.tar.gz 4140556 BLAKE2B 8630fc35138b3bb768b8a62a2f1388a1144baa9207aec49717c3c04843a393b130dfaef3266ad8fce5a5aa3af4e25d4441b075da0aa36ec1a8716db5ba5ac56c SHA512 7ebf1a5405a376fb19fb4bab0f4874e6be273d3c095338d8a2bfad433b0ec306918b2c650bd20dc5ffd835dd01e7398da2b66607a66dad931f98764f572e0be8
+DIST pydev_debugger_2_6_0.tar.gz 4142790 BLAKE2B 46776e261e77a745867423488f97c6584c9497d883d8e2b19f4f82c58472f410f1b5f287ce24b8c20e9cdaa2202cbc78235ea4a7e9aa2981aa520e0b58e4fcd3 SHA512 5e7703f2eec53fe7b4d78d59894cfbb14a35a62ad20431242477f66e72344d88d5538ebe2007526e4ff250e8bcf41702acc71692239693dd9cb788ced70d7aaa
diff --git a/dev-python/pydevd/pydevd-2.6.0.ebuild b/dev-python/pydevd/pydevd-2.6.0.ebuild
new file mode 100644
index 000000000000..2682f0672a48
--- /dev/null
+++ b/dev-python/pydevd/pydevd-2.6.0.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 toolchain-funcs
+
+MY_P="pydev_debugger_${PV//./_}"
+
+DESCRIPTION="PyDev.Debugger (used in PyDev, PyCharm and VSCode Python)"
+HOMEPAGE="https://github.com/fabioz/PyDev.Debugger/"
+SRC_URI="https://github.com/fabioz/PyDev.Debugger/archive/${MY_P}.tar.gz"
+S="${WORKDIR}/PyDev.Debugger-${MY_P}"
+
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# After removing and recompiling the prebuilt lib the tests fail?
+# For some reason the test suite is executing a slightly different gdb command
+# then before, which is lacking the file name of the lib that was pre built:
+# gdb: No symbol table is loaded. Use the "file" command
+# This also happens outside of portage so it is not related to any *FLAGS
+RESTRICT="test"
+
+BDEPEND="
+ test? (
+ dev-python/untangle[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ )
+"
+
+# Block against the version of debugpy that still bundles pydevd
+RDEPEND="
+ !<dev-python/debugpy-1.4.2
+ sys-devel/gdb
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ # Drop -O3 and -flto compiler args
+ sed -i \
+ -e 's/extra_link_args = extra_compile_args\[\:\]/pass/g' \
+ -e '/extra_compile_args/d' \
+ setup.py || die
+
+ # Clean up some prebuilt files
+ rm -r third_party || die
+ cd pydevd_attach_to_process || die
+
+ # Remove these Windows files
+ rm attach_{amd64,x86}.dll || die
+ rm inject_dll_{amd64,x86}.exe || die
+ rm run_code_on_dllmain_{amd64,x86}.dll || die
+ rm -r windows winappdbg || die
+
+ # Remove these MacOS files
+ rm attach_x86_64.dylib || die
+
+ # Remove these prebuilt linux files
+ rm attach_linux_{amd64,x86}.so || die
+
+ cd linux_and_mac || die
+ rm compile_mac.sh || die
+}
+
+src_compile() {
+ pushd pydevd_attach_to_process/linux_and_mac || die
+ # recompile removed file (extracted from compile_linux.sh)
+ $(tc-getBUILD_CXX) ${CXXFLAGS} ${CFLAGS} -o "attach_linux_${ARCH}.so" \
+ -ldl ${LDFLAGS} -nostartfiles attach.cpp || die
+ mv "attach_linux_${ARCH}.so" ../ || die
+ popd || die
+ python_foreach_impl distutils-r1_python_compile
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ # Remove this duplicate that is installed directly to /usr/
+ # These files are also correctly installed to the python site-packages dir
+ rm -r "${ED}/usr/pydevd_attach_to_process" || die
+}