summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-04 05:36:29 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-04 05:39:17 +0100
commit49fca9131490ae06dbd9f60a333ef530e1444670 (patch)
tree8209dd67d2a5dbff64e8cb23cc964662f02370d2 /dev-python/pyfakefs/pyfakefs-4.0.1.ebuild
parentsys-apps/nvme-cli: keyword on ~arm64 (diff)
downloadgentoo-49fca9131490ae06dbd9f60a333ef530e1444670.tar.gz
gentoo-49fca9131490ae06dbd9f60a333ef530e1444670.tar.bz2
gentoo-49fca9131490ae06dbd9f60a333ef530e1444670.zip
dev-python/pyfakefs: Bump to 4.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyfakefs/pyfakefs-4.0.1.ebuild')
-rw-r--r--dev-python/pyfakefs/pyfakefs-4.0.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pyfakefs/pyfakefs-4.0.1.ebuild b/dev-python/pyfakefs/pyfakefs-4.0.1.ebuild
new file mode 100644
index 000000000000..6aaf2a4f55cc
--- /dev/null
+++ b/dev-python/pyfakefs/pyfakefs-4.0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+DISTUTILS_IN_SOURCE_BUILD=1
+
+inherit distutils-r1
+
+DESCRIPTION="a fake file system that mocks the Python file system modules"
+HOMEPAGE="https://github.com/jmcgeheeiv/pyfakefs/ https://pypi.org/project/pyfakefs/"
+SRC_URI="https://github.com/jmcgeheeiv/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${COMMON_DEPEND}"
+DEPEND="${COMMON_DEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ "${EPYTHON}" -m pyfakefs.tests.all_tests -v || die "tests failed under ${EPYTHON}"
+}