summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-11-22 18:31:24 +0800
committerIan Delaney <idella4@gentoo.org>2015-11-22 18:32:01 +0800
commitce41e3f54b1953c0a2d5946fa34a298cc0c8ab94 (patch)
treea64ceddabfa33890597356d93c5b4cc6d81e66b2 /dev-python/pyflakes/pyflakes-1.0.0.ebuild
parentdev-python/path-py: arm stable, bug #564588 (diff)
downloadgentoo-ce41e3f54b1953c0a2d5946fa34a298cc0c8ab94.tar.gz
gentoo-ce41e3f54b1953c0a2d5946fa34a298cc0c8ab94.tar.bz2
gentoo-ce41e3f54b1953c0a2d5946fa34a298cc0c8ab94.zip
dev-python/pyflakes: bump -> vn. 1.0.0
Re-add pypy support which never needed dropping, drop py3.3 and py3.5 support, add patch committed upstream fixing test failures under pypy. Pull request: https://github.com/pyflakes/pyflakes/pull/50 Upstream Commit: https://github.com/jayvdb/pyflakes/commit/3088ffbd6256521e0213b361bc2294c1e218e6fb Package-Manager: portage-2.2.24
Diffstat (limited to 'dev-python/pyflakes/pyflakes-1.0.0.ebuild')
-rw-r--r--dev-python/pyflakes/pyflakes-1.0.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pyflakes/pyflakes-1.0.0.ebuild b/dev-python/pyflakes/pyflakes-1.0.0.ebuild
new file mode 100644
index 000000000000..732586cc75d8
--- /dev/null
+++ b/dev-python/pyflakes/pyflakes-1.0.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Passive checker for Python programs"
+HOMEPAGE="https://launchpad.net/pyflakes https://pypi.python.org/pypi/pyflakes"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/fix-pypy-tests.patch )
+
+python_test() {
+ esetup.py test --quiet
+}