summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-09-15 23:24:24 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-15 23:24:59 +0200
commit42dc52d8d56a050cf0267b9d74cc2a95ae239967 (patch)
tree9e05b345cc75ea61236502d3d8a68e9cb32445bd /dev-python/pyflann/pyflann-1.9.1.ebuild
parentsci-libs/flann: Version bump to 1.9.1 (diff)
downloadgentoo-42dc52d8d56a050cf0267b9d74cc2a95ae239967.tar.gz
gentoo-42dc52d8d56a050cf0267b9d74cc2a95ae239967.tar.bz2
gentoo-42dc52d8d56a050cf0267b9d74cc2a95ae239967.zip
dev-python/pyflann: Version bump to 1.9.1
* EAPI=6 * Add py3.4 and py3.5 support * Remove USE=test support, as the main package already has a broken testsuite, and requires ruby dependencies. Furthermore, the testsuite downloads data files live. Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/pyflann/pyflann-1.9.1.ebuild')
-rw-r--r--dev-python/pyflann/pyflann-1.9.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pyflann/pyflann-1.9.1.ebuild b/dev-python/pyflann/pyflann-1.9.1.ebuild
new file mode 100644
index 000000000000..7e51385ab443
--- /dev/null
+++ b/dev-python/pyflann/pyflann-1.9.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for FLANN artificial neural network library"
+HOMEPAGE="http://www.cs.ubc.ca/~mariusm/index.php/FLANN/FLANN/"
+SRC_URI="https://github.com/mariusmuja/flann/archive/${PV}.tar.gz -> flann-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ ~sci-libs/flann-${PV}"
+DEPEND="${RDEPEND}"
+# TODO:
+# readd dependencies for test suite,
+# requires repackaging auto-downloaded files
+
+S="${WORKDIR}/flann-${PV}/src/python"
+
+python_prepare_all() {
+ sed -e "s/@FLANN_VERSION@/${PV}/" \
+ -e '/package_d/d' \
+ -e "s/,.*'pyflann.lib'//" \
+ setup.py.tpl >> setup.py || die
+
+ distutils-r1_python_prepare_all
+}