summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pygame/pygame-1.9.2_pre20120101-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pygame/pygame-1.9.2_pre20120101-r2.ebuild')
-rw-r--r--dev-python/pygame/pygame-1.9.2_pre20120101-r2.ebuild88
1 files changed, 88 insertions, 0 deletions
diff --git a/dev-python/pygame/pygame-1.9.2_pre20120101-r2.ebuild b/dev-python/pygame/pygame-1.9.2_pre20120101-r2.ebuild
new file mode 100644
index 000000000000..242c6d35fbc4
--- /dev/null
+++ b/dev-python/pygame/pygame-1.9.2_pre20120101-r2.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+DISTUTILS_IN_SOURCE_BUILD=1
+inherit flag-o-matic distutils-r1 virtualx
+
+DESCRIPTION="Python bindings for SDL multimedia library"
+HOMEPAGE="http://www.pygame.org/"
+if [[ "${PV}" == *_pre* ]]; then
+ SRC_URI="http://people.apache.org/~Arfrever/gentoo/${P}.tar.xz"
+else
+ SRC_URI="http://www.pygame.org/ftp/pygame-${PV}release.tar.gz"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm hppa ~ia64 ppc ~sparc x86 ~x86-fbsd"
+IUSE="doc examples X"
+
+DEPEND="dev-python/numpy[${PYTHON_USEDEP}]
+ >=media-libs/sdl-image-1.2.2[png,jpeg]
+ >=media-libs/sdl-mixer-1.2.4
+ >=media-libs/sdl-ttf-2.0.6
+ >=media-libs/smpeg-0.4.4-r1
+ X? ( >=media-libs/libsdl-1.2.5[X,video] )
+ !X? ( >=media-libs/libsdl-1.2.5 )"
+RDEPEND="${DEPEND}"
+
+if [[ "${PV}" != *_pre* ]]; then
+ S="${WORKDIR}/${P}release"
+fi
+
+PATCHES=(
+ # Workaround bug #516434
+ "${FILESDIR}"/${P}-import-bdist.patch
+)
+
+DOCS=( WHATSNEW )
+
+python_configure() {
+ "${EPYTHON}" config.py -auto
+
+ if ! use X; then
+ sed -e "s:^scrap :#&:" -i Setup || die "sed failed"
+ fi
+
+ # Disable automagic dependency on PortMidi.
+ sed -e "s:^pypm :#&:" -i Setup || die "sed failed"
+
+ sed -i -e "s/import _camera/from pygame &/g" lib/camera.py || die #415593
+}
+
+python_compile() {
+ if [[ ${EPYTHON} == python2* ]]; then
+ local CFLAGS=${CFLAGS} CXXFLAGS=${CXXFLAGS}
+
+ append-flags -fno-strict-aliasing
+ fi
+
+ distutils-r1_python_compile
+}
+
+python_test() {
+ VIRTUALX_COMMAND="${PYTHON}" virtualmake run_tests.py
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ # Bug #497720
+ rm -fr "${D}"$(python_get_sitedir)/pygame/{docs,examples,tests}/ || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use doc; then
+ dohtml -r docs/*
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/*
+ fi
+}