summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-02-22 21:45:55 +0100
committerSam James <sam@gentoo.org>2021-02-22 22:19:39 +0000
commita0f89ae825a22c2936ec98778f4a8cfc7d92f050 (patch)
treea93506dc37d0998e8294a1a446603d651436448a /dev-python/pyghmi
parentdev-python/oslotest: Port to python 3.{8,9} (diff)
downloadgentoo-a0f89ae825a22c2936ec98778f4a8cfc7d92f050.tar.gz
gentoo-a0f89ae825a22c2936ec98778f4a8cfc7d92f050.tar.bz2
gentoo-a0f89ae825a22c2936ec98778f4a8cfc7d92f050.zip
dev-python/pyghmi: Bump to 1.5.22
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pyghmi')
-rw-r--r--dev-python/pyghmi/Manifest1
-rw-r--r--dev-python/pyghmi/pyghmi-1.5.22.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pyghmi/Manifest b/dev-python/pyghmi/Manifest
index 115de33ac521..b41cbbf859e6 100644
--- a/dev-python/pyghmi/Manifest
+++ b/dev-python/pyghmi/Manifest
@@ -1 +1,2 @@
+DIST pyghmi-1.5.22.tar.gz 221963 BLAKE2B 6705e904c481ddbb241fc8f8089e6bc9bcc142bfca9aaa518b2293b5dd387113fa4bbb418e748584f69fac5e8d1049d669eb73d24463adaaec3a891cae98f928 SHA512 cc665f8b9f4a0c9c127b9e895ba62e650cdb589f5c9edae6accaa5558f347d31725e8da446fcafb4f71ffadc17121d8b293160413f4a41055cb1720e9fa1ecde
DIST pyghmi-1.5.5.tar.gz 195830 BLAKE2B de7acc04e4b33f9a623cbe1afcd0caf869dea3e635df5e7ee1c609ac223cd6bf203735da54b6fe0e9f9a98e2371077f6e2d29dea60112014d58477195e798118 SHA512 9f1e1e0f0cf88c0ff794a29e4116b20dcf5eae141c1eefb6c5b8e3fae948fe6f928cd98dc4b95248c5cddab1cea3b841818e3255ec85c11d5c039dcc2c315cbb
diff --git a/dev-python/pyghmi/pyghmi-1.5.22.ebuild b/dev-python/pyghmi/pyghmi-1.5.22.ebuild
new file mode 100644
index 000000000000..4a81c80c555a
--- /dev/null
+++ b/dev-python/pyghmi/pyghmi-1.5.22.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="A pure python implementation of IPMI protocol"
+HOMEPAGE="https://github.com/openstack/pyghmi/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-python/cryptography-2.1[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/stestr-1.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.5[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ stestr run || die "Tests failed under ${EPYTHON}"
+}