summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-05-14 12:42:43 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-05-14 12:43:51 +0200
commit1df70b79e87fedd162f72368553088c2c9e40473 (patch)
tree964055c6b12b7d33483268bf0985cbdd372fcc5f /dev-python/pygit2/pygit2-0.25.1.ebuild
parentwww-apps/prewikka: Add missed PYTHON_USEDEP (diff)
downloadgentoo-1df70b79e87fedd162f72368553088c2c9e40473.tar.gz
gentoo-1df70b79e87fedd162f72368553088c2c9e40473.tar.bz2
gentoo-1df70b79e87fedd162f72368553088c2c9e40473.zip
dev-python/pygit2: Version bump to 0.25.1
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python/pygit2/pygit2-0.25.1.ebuild')
-rw-r--r--dev-python/pygit2/pygit2-0.25.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pygit2/pygit2-0.25.1.ebuild b/dev-python/pygit2/pygit2-0.25.1.ebuild
new file mode 100644
index 000000000000..a88aff4993c4
--- /dev/null
+++ b/dev-python/pygit2/pygit2-0.25.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1 versionator
+
+DESCRIPTION="Python bindings for libgit2"
+HOMEPAGE="https://github.com/libgit2/pygit2 https://pypi.python.org/pypi/pygit2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-libs/libgit2-$(get_version_component_range 1-2)*
+ >=dev-python/cffi-1.0:=[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ esetup.py test
+}