summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-03-28 14:48:46 +0100
committerMichał Górny <mgorny@gentoo.org>2019-03-28 14:49:48 +0100
commitb051a290fe10bcb4435d9dbd23e3fa24de6217c2 (patch)
tree5ed3aeba7e72b3b74ce7de9eff2e86dabd6df7cc /dev-python/pygit2
parentnet-wireless/unifi: bump to 5.11.10 unstable (diff)
downloadgentoo-b051a290fe10bcb4435d9dbd23e3fa24de6217c2.tar.gz
gentoo-b051a290fe10bcb4435d9dbd23e3fa24de6217c2.tar.bz2
gentoo-b051a290fe10bcb4435d9dbd23e3fa24de6217c2.zip
dev-python/pygit2: pytest is needed for tests only
Closes: https://bugs.gentoo.org/681876 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pygit2')
-rw-r--r--dev-python/pygit2/pygit2-0.27.4.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-python/pygit2/pygit2-0.27.4.ebuild b/dev-python/pygit2/pygit2-0.27.4.ebuild
index bc0bb7e5f0aa..fee4feb21364 100644
--- a/dev-python/pygit2/pygit2-0.27.4.ebuild
+++ b/dev-python/pygit2/pygit2-0.27.4.ebuild
@@ -13,6 +13,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="GPL-2-with-linking-exception"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+IUSE="test"
RDEPEND="
=dev-libs/libgit2-$(ver_cut 1-2)*
@@ -20,7 +21,9 @@ RDEPEND="
dev-python/six[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]"
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+RESTRICT="!test? ( test )"
python_prepare_all() {
sed -i -e '/pycparser/s:<2.18::' setup.py || die