summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-24 19:44:36 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-24 19:45:03 +0200
commit24665a703d78a29fd34b0b9a4b9f64edc4b05f1b (patch)
treeef3e7bf3618979938a58581cf8ceb26f692363df /dev-python/pygments
parentdev-python/hypothesis: Bump to 5.38.0 (diff)
downloadgentoo-24665a703d78a29fd34b0b9a4b9f64edc4b05f1b.tar.gz
gentoo-24665a703d78a29fd34b0b9a4b9f64edc4b05f1b.tar.bz2
gentoo-24665a703d78a29fd34b0b9a4b9f64edc4b05f1b.zip
dev-python/pygments: Bump to 2.7.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pygments')
-rw-r--r--dev-python/pygments/Manifest1
-rw-r--r--dev-python/pygments/pygments-2.7.2.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pygments/Manifest b/dev-python/pygments/Manifest
index 336a274d3d2e..af759d0e15d4 100644
--- a/dev-python/pygments/Manifest
+++ b/dev-python/pygments/Manifest
@@ -1 +1,2 @@
DIST Pygments-2.7.1.tar.gz 2323072 BLAKE2B ee55bb47369caca78d180659c2f62af18c1b1c6bfd803148ed88254f33c7261bf8acd29d193be2ac9c04d022a1c0c14c0fe9ff3cfcf8a5dc1d4dec90d3f1ee43 SHA512 95d1109cd53092fafa2f1d5c21a135c426700fc92e39bb22a27f47e63d10bdcb9e52593cd282339a3b501430ededbccea4f8d5970ba1171204579b964a6771c8
+DIST Pygments-2.7.2.tar.gz 2350457 BLAKE2B 4a67cd34cc41402e485e2bbb827a00f5184c00d26ca6f341c190457134598bd1cccc87a995eee85eb007a98b6d7b9e3e33585d0c1c0bba4289bedb36d22f351d SHA512 cd667e2cb33261060c316e3b92934dae735e2aa6c427b77852d4d18f28941cb369da05adb8540dd9fe3262b3e30e2fd6456e345bccc848be9dbdba20e97ef157
diff --git a/dev-python/pygments/pygments-2.7.2.ebuild b/dev-python/pygments/pygments-2.7.2.ebuild
new file mode 100644
index 000000000000..d821d49619e3
--- /dev/null
+++ b/dev-python/pygments/pygments-2.7.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1 bash-completion-r1
+
+MY_P=${P^}
+DESCRIPTION="Pygments is a syntax highlighting package written in Python"
+HOMEPAGE="
+ https://pygments.org/
+ https://github.com/pygments/pygments/
+ https://pypi.org/project/Pygments/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${PN^}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+BDEPEND="
+ test? (
+ virtual/ttf-fonts
+ )"
+
+distutils_enable_sphinx doc
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ newbashcomp external/pygments.bashcomp pygmentize
+}