summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-06 18:22:43 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-06 18:39:29 +0100
commitd08de6991687d82971cf6566004552c88f679e75 (patch)
treeb77c989643f5ebc38183bfc5022ab4435ac776d0 /dev-python/pygments
parentdev-python/jsonrpclib: Stabilize 0.4.2 ALLARCHES, #758284 (diff)
downloadgentoo-d08de6991687d82971cf6566004552c88f679e75.tar.gz
gentoo-d08de6991687d82971cf6566004552c88f679e75.tar.bz2
gentoo-d08de6991687d82971cf6566004552c88f679e75.zip
dev-python/pygments: Bump to 2.7.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pygments')
-rw-r--r--dev-python/pygments/Manifest1
-rw-r--r--dev-python/pygments/pygments-2.7.3.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pygments/Manifest b/dev-python/pygments/Manifest
index 1d758ef22285..d39a8757bbbb 100644
--- a/dev-python/pygments/Manifest
+++ b/dev-python/pygments/Manifest
@@ -1 +1,2 @@
DIST Pygments-2.7.2.tar.gz 2350457 BLAKE2B 4a67cd34cc41402e485e2bbb827a00f5184c00d26ca6f341c190457134598bd1cccc87a995eee85eb007a98b6d7b9e3e33585d0c1c0bba4289bedb36d22f351d SHA512 cd667e2cb33261060c316e3b92934dae735e2aa6c427b77852d4d18f28941cb369da05adb8540dd9fe3262b3e30e2fd6456e345bccc848be9dbdba20e97ef157
+DIST Pygments-2.7.3.tar.gz 2355381 BLAKE2B a7ae0ce7fefd8e2ec707ca8cf2d01d1b746d233e36c78ec51055f750e1a508240b706be50e5f1260f93fe19e15dc27d8de8c614260783713dc61c3c683b86c57 SHA512 fe58ce0beb3d2fd88b374d7864e93dba41e4e2ad6dca570e284fd76615c5bb4e78459a4b8c4dd5f61603d4bccd5705cebafd7274369d158af149e838ec63f7eb
diff --git a/dev-python/pygments/pygments-2.7.3.ebuild b/dev-python/pygments/pygments-2.7.3.ebuild
new file mode 100644
index 000000000000..d821d49619e3
--- /dev/null
+++ b/dev-python/pygments/pygments-2.7.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1 bash-completion-r1
+
+MY_P=${P^}
+DESCRIPTION="Pygments is a syntax highlighting package written in Python"
+HOMEPAGE="
+ https://pygments.org/
+ https://github.com/pygments/pygments/
+ https://pypi.org/project/Pygments/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${PN^}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+BDEPEND="
+ test? (
+ virtual/ttf-fonts
+ )"
+
+distutils_enable_sphinx doc
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ newbashcomp external/pygments.bashcomp pygmentize
+}