summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-11-28 00:35:34 +0200
committerMart Raudsepp <leio@gentoo.org>2018-11-28 00:35:57 +0200
commitbe7635b89ab7714349cc47d78f0cb98628460923 (patch)
tree573aff3ecf16a41f0c0c887426302d3f766b1a44 /dev-python/pygobject/pygobject-3.28.3.ebuild
parentdev-vcs/hg-evolve: Version bumps (diff)
downloadgentoo-be7635b89ab7714349cc47d78f0cb98628460923.tar.gz
gentoo-be7635b89ab7714349cc47d78f0cb98628460923.tar.bz2
gentoo-be7635b89ab7714349cc47d78f0cb98628460923.zip
dev-python/pygobject: fix missing test dep, die on test failures
The testing emake call had a missing "|| die", thus the test phase only errored out if the last tested python version failed tests, but not if earlier python version tests failed. This was observed from pytest for python2.7 missing due to the missing dep and that not being fatal. Add the missing test dep. Closes: https://bugs.gentoo.org/670184 Signed-off-by: Mart Raudsepp <leio@gentoo.org> Package-Manager: Portage-2.3.52, Repoman-2.3.11
Diffstat (limited to 'dev-python/pygobject/pygobject-3.28.3.ebuild')
-rw-r--r--dev-python/pygobject/pygobject-3.28.3.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-python/pygobject/pygobject-3.28.3.ebuild b/dev-python/pygobject/pygobject-3.28.3.ebuild
index 59a56b471d05..dc92b0ddf3f0 100644
--- a/dev-python/pygobject/pygobject-3.28.3.ebuild
+++ b/dev-python/pygobject/pygobject-3.28.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -33,6 +33,7 @@ DEPEND="${COMMON_DEPEND}
cairo? ( x11-libs/cairo[glib] )
test? (
dev-libs/atk[introspection]
+ dev-python/pytest[${PYTHON_USEDEP}]
media-fonts/font-cursor-misc
media-fonts/font-misc-misc
x11-libs/cairo[glib]
@@ -86,7 +87,7 @@ src_test() {
testing() {
local -x XDG_CACHE_HOME="${T}/${EPYTHON}"
- emake -C "${BUILD_DIR}" check
+ emake -C "${BUILD_DIR}" check || die "emake check failed"
}
virtx python_foreach_impl testing
}