summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-02-19 06:31:11 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-02-26 18:02:03 +0000
commit44cbc4336636ae236bb06aac541f35b7489afbea (patch)
tree09c7b4cb317e8ef5817c630c8fd257914d447a1f /dev-python/pygpu/pygpu-0.6.0.ebuild
parentdev-libs/libgpuarray: version bump (diff)
downloadgentoo-44cbc4336636ae236bb06aac541f35b7489afbea.tar.gz
gentoo-44cbc4336636ae236bb06aac541f35b7489afbea.tar.bz2
gentoo-44cbc4336636ae236bb06aac541f35b7489afbea.zip
dev-python/pygpu: version bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/pygpu/pygpu-0.6.0.ebuild')
-rw-r--r--dev-python/pygpu/pygpu-0.6.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pygpu/pygpu-0.6.0.ebuild b/dev-python/pygpu/pygpu-0.6.0.ebuild
new file mode 100644
index 000000000000..dfa5aad4d8cd
--- /dev/null
+++ b/dev-python/pygpu/pygpu-0.6.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+MYPV=${PV/_/-}
+
+DESCRIPTION="Python bindings to libgpuarray"
+HOMEPAGE="http://deeplearning.net/software/libgpuarray/"
+SRC_URI="https://github.com/Theano/libgpuarray/archive/v${MYPV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cuda opencl test"
+
+RDEPEND="
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-libs/libgpuarray:=[cuda?,opencl?]
+"
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+S="${WORKDIR}/libgpuarray-${MYPV}"
+
+python_test() {
+ local DEVICE=cuda
+ use opencl && DEVICE=opencl
+ nosetests -svw "${BUILD_DIR}/lib/" || die
+}