summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pygraphviz
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pygraphviz')
-rw-r--r--dev-python/pygraphviz/Manifest1
-rw-r--r--dev-python/pygraphviz/files/pygraphviz-1.0-setup.py.patch33
-rw-r--r--dev-python/pygraphviz/files/pygraphviz-1.1-avoid_tests.patch41
-rw-r--r--dev-python/pygraphviz/files/pygraphviz-1.2-avoid_tests.patch47
-rw-r--r--dev-python/pygraphviz/metadata.xml14
-rw-r--r--dev-python/pygraphviz/pygraphviz-1.2.ebuild40
6 files changed, 176 insertions, 0 deletions
diff --git a/dev-python/pygraphviz/Manifest b/dev-python/pygraphviz/Manifest
new file mode 100644
index 000000000000..68e8904f10fa
--- /dev/null
+++ b/dev-python/pygraphviz/Manifest
@@ -0,0 +1 @@
+DIST pygraphviz-1.2.tar.gz 90913 SHA256 2e8a82a07dcf006b9558d22c5a6357c012193d4cc681776845e515fffeccc6b3 SHA512 e477af635594c3ba1aa6fa499bc5e60df14e76616a1a777f648e2e96d3953dd3d0b3bae4a92275dac2f7466276cf526ecb8b6a63fd3fbad26ee24b67d76ecfa3 WHIRLPOOL 2757d02b130f326ee2638b78761094de1a841293b6de1d5ea2c89c169cbc8525041e06daef9ded32d7c1ac944ef99293ab67fee6c75a2976283f87725635a4d5
diff --git a/dev-python/pygraphviz/files/pygraphviz-1.0-setup.py.patch b/dev-python/pygraphviz/files/pygraphviz-1.0-setup.py.patch
new file mode 100644
index 000000000000..13eb0f213ce1
--- /dev/null
+++ b/dev-python/pygraphviz/files/pygraphviz-1.0-setup.py.patch
@@ -0,0 +1,33 @@
+--- setup_egg.py
++++ setup_egg.py
+@@ -46,7 +46,6 @@
+ download_url = release.download_url,
+ classifiers = release.classifiers,
+ packages = packages,
+- data_files = data,
+ ext_modules = extension,
+ package_data = package_data,
+ install_requires=['setuptools'],
+--- setup.py
++++ setup.py
+@@ -98,12 +98,6 @@
+ sys.path.pop(0)
+
+ packages = ["pygraphviz","pygraphviz.tests"]
+-docdirbase = 'share/doc/pygraphviz-%s' % release.version
+-data = [(docdirbase, glob("*.txt")),
+- (os.path.join(docdirbase, 'examples'),glob("examples/*.py")),
+- (os.path.join(docdirbase, 'examples'),glob("examples/*.dat")),
+- (os.path.join(docdirbase, 'examples'),glob("examples/*.dat.gz")),
+- ]
+ extension = [Extension("pygraphviz._graphviz",
+ ["pygraphviz/graphviz_wrap.c"],
+ include_dirs=include_dirs,
+@@ -130,7 +124,6 @@
+ download_url = release.download_url,
+ classifiers = release.classifiers,
+ packages = packages,
+- data_files = data,
+ ext_modules = extension,
+ package_data = package_data
+ )
diff --git a/dev-python/pygraphviz/files/pygraphviz-1.1-avoid_tests.patch b/dev-python/pygraphviz/files/pygraphviz-1.1-avoid_tests.patch
new file mode 100644
index 000000000000..0d52e968bf0a
--- /dev/null
+++ b/dev-python/pygraphviz/files/pygraphviz-1.1-avoid_tests.patch
@@ -0,0 +1,41 @@
+--- pygraphviz/agraph.py
++++ pygraphviz/agraph.py
+@@ -1767,29 +1767,3 @@
+ value.decode(self.encoding))
+ except KeyError: # gv.agxget returned KeyError, skip
+ continue
+-
+-
+-
+-def _test_suite():
+- import doctest
+- suite = doctest.DocFileSuite('tests/graph.txt',
+- 'tests/attributes.txt',
+- 'tests/layout_draw.txt',
+- 'tests/subgraph.txt',
+- package='pygraphviz')
+- doctest.testmod() # test docstrings in module
+- return suite
+-
+-
+-if __name__ == "__main__":
+- import os
+- import sys
+- import unittest
+- if sys.version_info[:2] < (2, 4):
+- print "Python version 2.4 or later required for tests (%d.%d detected)." % sys.version_info[:2]
+- sys.exit(-1)
+- # directory of package (relative to this)
+- nxbase=sys.path[0]+os.sep+os.pardir
+- sys.path.insert(0,nxbase) # prepend to search path
+- unittest.TextTestRunner().run(_test_suite())
+-
+--- pygraphviz/__init__.py
++++ pygraphviz/__init__.py
+@@ -67,6 +67,3 @@
+ print "pygraphviz-"+__version__
+ neato=_get_prog('neato')
+ os.system(neato+' -V')
+-
+-# import tests: run as pygraphviz.test()
+-from tests import run as test
diff --git a/dev-python/pygraphviz/files/pygraphviz-1.2-avoid_tests.patch b/dev-python/pygraphviz/files/pygraphviz-1.2-avoid_tests.patch
new file mode 100644
index 000000000000..d444ee3d2df7
--- /dev/null
+++ b/dev-python/pygraphviz/files/pygraphviz-1.2-avoid_tests.patch
@@ -0,0 +1,47 @@
+ pygraphviz/__init__.py | 2 --
+ pygraphviz/agraph.py | 25 -------------------------
+ 2 files changed, 27 deletions(-)
+
+diff --git a/pygraphviz/__init__.py b/pygraphviz/__init__.py
+index a807801..33f727e 100644
+--- a/pygraphviz/__init__.py
++++ b/pygraphviz/__init__.py
+@@ -68,5 +68,3 @@ def version():
+ neato=_get_prog('neato')
+ os.system(neato+' -V')
+
+-# import tests: run as pygraphviz.test()
+-from tests import run as test
+diff --git a/pygraphviz/agraph.py b/pygraphviz/agraph.py
+index c9f735b..90a661e 100644
+--- a/pygraphviz/agraph.py
++++ b/pygraphviz/agraph.py
+@@ -1771,28 +1771,3 @@ class ItemAttribute(Attribute):
+ value.decode(self.encoding))
+ except KeyError: # gv.agxget returned KeyError, skip
+ continue
+-
+-
+-
+-def _test_suite():
+- import doctest
+- suite = doctest.DocFileSuite('tests/graph.txt',
+- 'tests/attributes.txt',
+- 'tests/layout_draw.txt',
+- 'tests/subgraph.txt',
+- package='pygraphviz')
+- doctest.testmod() # test docstrings in module
+- return suite
+-
+-
+-if __name__ == "__main__":
+- import os
+- import sys
+- import unittest
+- if sys.version_info[:2] < (2, 4):
+- print "Python version 2.4 or later required for tests (%d.%d detected)." % sys.version_info[:2]
+- sys.exit(-1)
+- # directory of package (relative to this)
+- nxbase=sys.path[0]+os.sep+os.pardir
+- sys.path.insert(0,nxbase) # prepend to search path
+- unittest.TextTestRunner().run(_test_suite())
diff --git a/dev-python/pygraphviz/metadata.xml b/dev-python/pygraphviz/metadata.xml
new file mode 100644
index 000000000000..d86fec8b72cd
--- /dev/null
+++ b/dev-python/pygraphviz/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription lang="en">
+ Pygraphviz is a Python interface to the Graphviz graph layout and
+ visualization package.
+ With Pygraphviz you can create, edit, read, write, and draw graphs using
+ Python to access the Graphviz graph data structure and layout algorithms.
+</longdescription>
+ <upstream>
+ <remote-id type="pypi">pygraphviz</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pygraphviz/pygraphviz-1.2.ebuild b/dev-python/pygraphviz/pygraphviz-1.2.ebuild
new file mode 100644
index 000000000000..b2b7c6824878
--- /dev/null
+++ b/dev-python/pygraphviz/pygraphviz-1.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for the Graphviz Agraph data structure"
+HOMEPAGE="http://networkx.lanl.gov/pygraphviz/ http://pypi.python.org/pypi/pygraphviz"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="examples"
+
+# Note: only C API of graphviz is used, PYTHON_USEDEP unnecessary.
+RDEPEND="media-gfx/graphviz"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0-setup.py.patch
+ "${FILESDIR}"/${P}-avoid_tests.patch
+)
+
+python_test() {
+ PYTHONPATH=${PYTHONPATH}:${BUILD_DIR}/lib/pygraphviz \
+ "${PYTHON}" \
+ -c "import pygraphviz.tests; pygraphviz.tests.run()" \
+ || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}