summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-07 09:33:01 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-07 09:33:39 +0200
commit7c6b217aa892a259b091a11e7d33d0cf2ee995f0 (patch)
tree501163f341d038834b06754fae0ab25c191967ac /dev-python/pygraphviz
parentdev-python/networkx: Add python3 support for pygraphviz (diff)
downloadgentoo-7c6b217aa892a259b091a11e7d33d0cf2ee995f0.tar.gz
gentoo-7c6b217aa892a259b091a11e7d33d0cf2ee995f0.tar.bz2
gentoo-7c6b217aa892a259b091a11e7d33d0cf2ee995f0.zip
dev-python/pygraphviz: Version Bump
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=554436 Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pygraphviz')
-rw-r--r--dev-python/pygraphviz/Manifest1
-rw-r--r--dev-python/pygraphviz/files/pygraphviz-1.3.1-docs.patch29
-rw-r--r--dev-python/pygraphviz/files/pygraphviz-1.3.1-swig-3.patch23
-rw-r--r--dev-python/pygraphviz/pygraphviz-1.3.1.ebuild49
4 files changed, 102 insertions, 0 deletions
diff --git a/dev-python/pygraphviz/Manifest b/dev-python/pygraphviz/Manifest
index 68e8904f10fa..bece6bf1af78 100644
--- a/dev-python/pygraphviz/Manifest
+++ b/dev-python/pygraphviz/Manifest
@@ -1 +1,2 @@
DIST pygraphviz-1.2.tar.gz 90913 SHA256 2e8a82a07dcf006b9558d22c5a6357c012193d4cc681776845e515fffeccc6b3 SHA512 e477af635594c3ba1aa6fa499bc5e60df14e76616a1a777f648e2e96d3953dd3d0b3bae4a92275dac2f7466276cf526ecb8b6a63fd3fbad26ee24b67d76ecfa3 WHIRLPOOL 2757d02b130f326ee2638b78761094de1a841293b6de1d5ea2c89c169cbc8525041e06daef9ded32d7c1ac944ef99293ab67fee6c75a2976283f87725635a4d5
+DIST pygraphviz-1.3.1.tar.gz 103336 SHA256 7c294cbc9d88946be671cc0d8602aac176d8c56695c0a7d871eadea75a958408 SHA512 e1957d7daf7ae9e60873cb6f23ac19a3320b4b10579ab24a2307beb558dad11a8e82e1da528799165b761d944efb4860b7296e3218846f7885f715c396a8e3dc WHIRLPOOL dd4ac48c4e4c05a134a6ba076979f9dc1ea7fab03700208aedf9cd6acf3fb5595a26b3a0f1de8d46a61750dea60a6e31f180719cb51b1e916ecc677dde61a618
diff --git a/dev-python/pygraphviz/files/pygraphviz-1.3.1-docs.patch b/dev-python/pygraphviz/files/pygraphviz-1.3.1-docs.patch
new file mode 100644
index 000000000000..aed5c9075b88
--- /dev/null
+++ b/dev-python/pygraphviz/files/pygraphviz-1.3.1-docs.patch
@@ -0,0 +1,29 @@
+ setup.py | 8 --------
+ 1 file changed, 8 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index fc0a96f..98b7f58 100644
+--- a/setup.py
++++ b/setup.py
+@@ -36,13 +36,6 @@ release.write_versionfile()
+ sys.path.pop(0)
+
+ packages = ["pygraphviz", "pygraphviz.tests"]
+-docdirbase = 'share/doc/pygraphviz-%s' % release.version
+-data = [
+- (docdirbase, glob("*.txt")),
+- (os.path.join(docdirbase, 'examples'), glob("examples/*.py")),
+- (os.path.join(docdirbase, 'examples'), glob("examples/*.dat")),
+- (os.path.join(docdirbase, 'examples'), glob("examples/*.dat.gz")),
+-]
+ package_data = {'': ['*.txt'], }
+
+ if __name__ == "__main__":
+@@ -75,7 +68,6 @@ if __name__ == "__main__":
+ download_url=release.download_url,
+ classifiers=release.classifiers,
+ packages=packages,
+- data_files=data,
+ ext_modules=extension,
+ cmdclass={
+ 'install': AddExtensionInstallCommand,
diff --git a/dev-python/pygraphviz/files/pygraphviz-1.3.1-swig-3.patch b/dev-python/pygraphviz/files/pygraphviz-1.3.1-swig-3.patch
new file mode 100644
index 000000000000..912667e7f5a7
--- /dev/null
+++ b/dev-python/pygraphviz/files/pygraphviz-1.3.1-swig-3.patch
@@ -0,0 +1,23 @@
+ pygraphviz/graphviz.i | 12 ++++++------
+ 1 file changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/pygraphviz/graphviz.i b/pygraphviz/graphviz.i
+index 0d9b43b..5f1f6b0 100644
+--- a/pygraphviz/graphviz.i
++++ b/pygraphviz/graphviz.i
+@@ -1,9 +1,9 @@
+-# Copyright (C) 2004-2006 by
+-# Aric Hagberg <hagberg@lanl.gov>
+-# Dan Schult <dschult@colgate.edu>
+-# Manos Renieris, http://www.cs.brown.edu/~er/
+-# Distributed with BSD license.
+-# All rights reserved, see LICENSE for details.
++// Copyright (C) 2004-2006 by
++// Aric Hagberg <hagberg@lanl.gov>
++// Dan Schult <dschult@colgate.edu>
++// Manos Renieris, http://www.cs.brown.edu/~er/
++// Distributed with BSD license.
++// All rights reserved, see LICENSE for details.
+
+ %module graphviz
+
diff --git a/dev-python/pygraphviz/pygraphviz-1.3.1.ebuild b/dev-python/pygraphviz/pygraphviz-1.3.1.ebuild
new file mode 100644
index 000000000000..376cf2d9dad7
--- /dev/null
+++ b/dev-python/pygraphviz/pygraphviz-1.3.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for the Graphviz Agraph data structure"
+HOMEPAGE="http://networkx.lanl.gov/pygraphviz/ https://pypi.python.org/pypi/pygraphviz"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="examples test"
+
+# Note: only C API of graphviz is used, PYTHON_USEDEP unnecessary.
+RDEPEND="media-gfx/graphviz"
+DEPEND="${RDEPEND}
+ dev-lang/swig:0
+ test? (
+ dev-python/doctest-ignore-unicode[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-docs.patch
+ "${FILESDIR}"/${P}-swig-3.patch
+)
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ swig -python pygraphviz/graphviz.i || die
+}
+
+python_test() {
+ PYTHONPATH=${PYTHONPATH}:${BUILD_DIR}/lib/pygraphviz \
+ nosetests -c setup.cfg -x -v || die
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}