summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenning Schild <henning@hennsch.de>2016-10-05 19:57:01 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-10-06 17:35:59 +0200
commitabcb1fbb298cbf4f9034c753fc8eb62b06e1b3cb (patch)
tree7387b8550f4478cfe05d83afde2374e4b8326858 /dev-python/pygtkspellcheck
parentx11-misc/rednotebook: cleanup unused patch. (diff)
downloadgentoo-abcb1fbb298cbf4f9034c753fc8eb62b06e1b3cb.tar.gz
gentoo-abcb1fbb298cbf4f9034c753fc8eb62b06e1b3cb.tar.bz2
gentoo-abcb1fbb298cbf4f9034c753fc8eb62b06e1b3cb.zip
dev-python/pygtkspellcheck: Add pygtkspellcheck to the tree.
It is a spellchecking library for GTK written in python. Signed-off-by: Henning Schild <henning@hennsch.de> Closes: https://github.com/gentoo/gentoo/pull/2484 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python/pygtkspellcheck')
-rw-r--r--dev-python/pygtkspellcheck/Manifest3
-rw-r--r--dev-python/pygtkspellcheck/metadata.xml12
-rw-r--r--dev-python/pygtkspellcheck/pygtkspellcheck-4.0.5.ebuild21
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pygtkspellcheck/Manifest b/dev-python/pygtkspellcheck/Manifest
new file mode 100644
index 000000000000..ced9b94500e5
--- /dev/null
+++ b/dev-python/pygtkspellcheck/Manifest
@@ -0,0 +1,3 @@
+DIST pygtkspellcheck-4.0.5.tar.gz 184313 SHA256 5d7473de147ab2c8fb61de93f7275139c53b08d8cee6b43a2062d6c83a6b2987 SHA512 f2ea035093a4d8bd9ca3b04f7433808b1ea8c3723b3ea12b95f470d8eb003c9cf58114cb4f342f36732ae46e6156223db5185f16a8c4b27551a6b99bc28a45b9 WHIRLPOOL c7a891987c148ca3531b43ad245576efdff328ace04e10ba992efea99768ad84a35f9d94d20e98973c37ceffe6e242dcee635ff0e912192a4605cd07153514a4
+EBUILD pygtkspellcheck-4.0.5.ebuild 564 SHA256 f72d980e63ccb290427825c4df87750b7d1d47cddab1090318a254b605cd352b SHA512 5c0c3476f9685056f2f4a0596ecd688d206ce53f4e991fcb07860457213e2e19f49ad260f4bdddf731c376eb047474ad2fe815c2ea8e00fde29937e81dce415f WHIRLPOOL ffaea976694f9fcd0247606f8182e1a7a77da6e00f1fceabda278a85f9c31d0c7ede94c6cff4281588f0a736ab6b2264cc869075c75914bce8b693509447d75c
+MISC metadata.xml 381 SHA256 11a6ef60d00856e06235b7b8db96784a94a8cc960a328d2ed5d30399370c374d SHA512 da194ec55795437aca489e1f99bcc097234dc6a0d811f55bc216f3b49420a4da190c997da593da25fc259e6cdaf41feb44e8baebe7ceb55c82ca10bf571c41f8 WHIRLPOOL 11aa352eb7b87f3ffa5340c72b445b42e6b5f3a15d3e47fcb5357286ac1df3ca20e181d73da8c3909cb0dd02dc93bb868bed41adcdbdbd09da8738b81d8bd166
diff --git a/dev-python/pygtkspellcheck/metadata.xml b/dev-python/pygtkspellcheck/metadata.xml
new file mode 100644
index 000000000000..6666f980a131
--- /dev/null
+++ b/dev-python/pygtkspellcheck/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pygtkspellcheck</remote-id>
+ <remote-id type="github">koehlma/pygtkspellcheck</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pygtkspellcheck/pygtkspellcheck-4.0.5.ebuild b/dev-python/pygtkspellcheck/pygtkspellcheck-4.0.5.ebuild
new file mode 100644
index 000000000000..ac114f41af2b
--- /dev/null
+++ b/dev-python/pygtkspellcheck/pygtkspellcheck-4.0.5.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 )
+PYTHON_REQ_USE="sqlite"
+inherit distutils-r1
+
+DESCRIPTION="a simple but quite powerful spellchecking library for GTK written in pure Python"
+HOMEPAGE="https://github.com/koehlma/pygtkspellcheck"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/pyenchant[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"