summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-22 11:41:57 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-22 11:42:49 +0200
commite2b572bc0e69a2c6dd78fd69fda542048bdb8fcc (patch)
tree4a14534b5e72563dab9320d1d7a52533d2bf9d8b /dev-python/pyh2o/pyh2o-1.ebuild
parentdev-python/pyh2o: Enable tests, port to py3.9 (diff)
downloadgentoo-e2b572bc0e69a2c6dd78fd69fda542048bdb8fcc.tar.gz
gentoo-e2b572bc0e69a2c6dd78fd69fda542048bdb8fcc.tar.bz2
gentoo-e2b572bc0e69a2c6dd78fd69fda542048bdb8fcc.zip
dev-python/pyh2o: Add initial version (v1)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyh2o/pyh2o-1.ebuild')
-rw-r--r--dev-python/pyh2o/pyh2o-1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/pyh2o/pyh2o-1.ebuild b/dev-python/pyh2o/pyh2o-1.ebuild
new file mode 100644
index 000000000000..f8392f678f6c
--- /dev/null
+++ b/dev-python/pyh2o/pyh2o-1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python API for sci-libs/libh2o"
+HOMEPAGE="https://github.com/mgorny/pyh2o/"
+SRC_URI="
+ https://github.com/mgorny/pyh2o/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=sci-libs/libh2o-0.2.1:="
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest