summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl@gmail.com>2018-09-30 21:49:21 +0200
committerMichał Górny <mgorny@gentoo.org>2018-10-11 20:42:50 +0200
commit5536d29f8eda56741b434b92f3885434dba7282a (patch)
tree5c1af7b801bf293659142fda42d3d60b5c0d6ce6 /dev-python/pyilmbase
parentmedia-libs/openexr: bump to version 2.3.0 (diff)
downloadgentoo-5536d29f8eda56741b434b92f3885434dba7282a.tar.gz
gentoo-5536d29f8eda56741b434b92f3885434dba7282a.tar.bz2
gentoo-5536d29f8eda56741b434b92f3885434dba7282a.zip
dev-python/pyilmbase: bump to version 2.3.0
Remove multilib inherit, python isn't multilib aware Improve ebuild functions Closes: https://bugs.gentoo.org/639998 Suggested-by: Jonathan Scruggs <dracwyrm@gentoo.org> Signed-off-by: Bernd Waibel <waebbl@gmail.com> Package-Manager: Portage-2.3.49, Repoman-2.3.10 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyilmbase')
-rw-r--r--dev-python/pyilmbase/Manifest1
-rw-r--r--dev-python/pyilmbase/files/pyilmbase-2.3.0-fix-build-system.patch48
-rw-r--r--dev-python/pyilmbase/files/pyilmbase-2.3.0-link-pyimath.patch13
-rw-r--r--dev-python/pyilmbase/pyilmbase-2.3.0.ebuild59
4 files changed, 121 insertions, 0 deletions
diff --git a/dev-python/pyilmbase/Manifest b/dev-python/pyilmbase/Manifest
index d7a8cdc14e02..55654e87ea46 100644
--- a/dev-python/pyilmbase/Manifest
+++ b/dev-python/pyilmbase/Manifest
@@ -1 +1,2 @@
DIST pyilmbase-2.2.0.tar.gz 469927 BLAKE2B 74a806f30bf8881a4c58135110c3e805b9748074eab08e9afa17735630ee7de16ffe6a797ced926bb93d122eafdeb04c5e6e80ddba1a90bc551cb87ddeb30671 SHA512 111deb65a73b4d0454454d4fb64d09165fb25aad2e5714e35510c2b7ef301dc8765041de3188c2f89c9bd2770494a55a24372953fcda8dcedb23c401137e4344
+DIST pyilmbase-2.3.0.tar.gz 524975 BLAKE2B 7c3114921392ad29198025c672c366e6c98d2da968ed213ccfb446533b81fae4b78c687aba2108e476e16c4e97f11924799d0b0474ff3f82f17632f886bb6a39 SHA512 c20c26155315f2ae38efc183e5f33e2c18610365f5f1bca7a50363a005ff91c8782177293290ea037cf5f164f9b404f5710ce3cccba862e5e7f830727753589f
diff --git a/dev-python/pyilmbase/files/pyilmbase-2.3.0-fix-build-system.patch b/dev-python/pyilmbase/files/pyilmbase-2.3.0-fix-build-system.patch
new file mode 100644
index 000000000000..bd35f87a0e0f
--- /dev/null
+++ b/dev-python/pyilmbase/files/pyilmbase-2.3.0-fix-build-system.patch
@@ -0,0 +1,48 @@
+diff --git a/configure.ac b/configure.ac
+index 5cbf273..9e80b48 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -4,8 +4,7 @@ AC_SUBST(PYILMBASE_VERSION, 2.3.0)
+ AC_CANONICAL_HOST
+ AC_CONFIG_SRCDIR(PyIex/iexmodule.cpp)
+ AC_CONFIG_HEADER(config/PyIlmBaseConfig.h)
+-AM_INIT_AUTOMAKE(1.6.3) dnl Require automake 1.6.3 or better
+-AM_MAINTAINER_MODE
++AM_INIT_AUTOMAKE
+ dnl static python modules make no sense - disable static
+ AC_DISABLE_STATIC
+
+@@ -20,7 +19,7 @@ dnl Checks for programs.
+ AC_PROG_CXX
+ AC_PROG_INSTALL
+ AC_PROG_LN_S
+-AC_PROG_LIBTOOL
++LT_INIT
+ AC_PROG_MAKE_SET
+
+ dnl
+@@ -164,22 +163,13 @@ AC_C_CONST
+ AC_C_INLINE
+ AC_TYPE_SIZE_T
+
+-AC_MSG_CHECKING(for gcc optimization flags)
+-old_cflags=$CFLAGS
+-CFLAGS="$CFLAGS -pipe"
+-AC_TRY_COMPILE([#include <stdio.h>],
+-[ printf ("hello, world"); ],
+-[ EXTRA_OPT_CFLAGS="-pipe"],[ EXTRA_OPT_CFLAGS=""])
+-CFLAGS=$old_cflags
+-AC_MSG_RESULT([$EXTRA_OPT_CFLAGS])
+-
+ dnl Platform-specific stuff
+ case "$host" in
+ *linux*)
+- AC_DEFINE(HAVE_LINUX_PROCFS)
++ AC_DEFINE([HAVE_LINUX_PROCFS], [1], [define on linux])
+ ;;
+ *darwin*)
+- AC_DEFINE(HAVE_DARWIN)
++ AC_DEFINE([HAVE_DARWIN], [1], [define on OSX])
+ ;;
+ esac
+
diff --git a/dev-python/pyilmbase/files/pyilmbase-2.3.0-link-pyimath.patch b/dev-python/pyilmbase/files/pyilmbase-2.3.0-link-pyimath.patch
new file mode 100644
index 000000000000..878c270a885a
--- /dev/null
+++ b/dev-python/pyilmbase/files/pyilmbase-2.3.0-link-pyimath.patch
@@ -0,0 +1,13 @@
+diff --git a/PyImath/Makefile.am b/PyImath/Makefile.am
+index bf87542..ad69515 100644
+--- a/PyImath/Makefile.am
++++ b/PyImath/Makefile.am
+@@ -82,7 +82,7 @@ imathmodule_la_SOURCES = imathmodule.cpp \
+ PyImathBasicTypes.cpp
+
+ imathmodule_la_LDFLAGS = -avoid-version -module
+-imathmodule_la_LIBADD = -lPyImath @BOOST_PYTHON_LIBS@
++imathmodule_la_LIBADD = libPyImath.la @BOOST_PYTHON_LIBS@
+
+ noinst_HEADERS = PyImathFun.h \
+ PyImathBasicTypes.h
diff --git a/dev-python/pyilmbase/pyilmbase-2.3.0.ebuild b/dev-python/pyilmbase/pyilmbase-2.3.0.ebuild
new file mode 100644
index 000000000000..fda4c62db801
--- /dev/null
+++ b/dev-python/pyilmbase/pyilmbase-2.3.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools python-single-r1
+
+DESCRIPTION="ilmbase Python bindings"
+HOMEPAGE="http://www.openexr.com"
+SRC_URI="https://github.com/openexr/openexr/releases/download/v${PV}/${P}.tar.gz"
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+numpy"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEP}
+ >=dev-libs/boost-1.62.0-r1[python(+),${PYTHON_USEDEP}]
+ ~media-libs/ilmbase-${PV}:=
+ numpy? ( >=dev-python/numpy-1.10.4 )"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEP}
+ >=virtual/pkgconfig-0-r1"
+
+PATCHES=(
+ "${FILESDIR}/${P}-link-pyimath.patch"
+ "${FILESDIR}/${P}-fix-build-system.patch"
+)
+
+DOCS=( README.md )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-boost-include-dir="${EPREFIX}/usr/include/boost"
+ --with-boost-lib-dir="${EPREFIX}/usr/$(get_libdir)"
+ --with-boost-python-libname="boost_python-${EPYTHON:6}"
+ $(use_with numpy)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ # Fails to install with multiple jobs
+ emake DESTDIR="${D}" -j1 install
+
+ einstalldocs
+
+ # package provides pkg-config files
+ find "${D}" -name '*.la' -delete || die
+}