summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-07-18 14:23:13 +0200
committerMichał Górny <mgorny@gentoo.org>2018-07-18 14:54:34 +0200
commitc1da8c001b38a31a93eb41ac70d2fb85940c628f (patch)
tree69b4dd2c9cc0c9d3a4737a82025508a31a069bd2 /dev-python/pyjwt/pyjwt-1.5.3.ebuild
parentgames-strategy/tornado: Add USE=nls. (diff)
downloadgentoo-c1da8c001b38a31a93eb41ac70d2fb85940c628f.tar.gz
gentoo-c1da8c001b38a31a93eb41ac70d2fb85940c628f.tar.bz2
gentoo-c1da8c001b38a31a93eb41ac70d2fb85940c628f.zip
dev-python/pyjwt: Remove unnecessary test-deps
Diffstat (limited to 'dev-python/pyjwt/pyjwt-1.5.3.ebuild')
-rw-r--r--dev-python/pyjwt/pyjwt-1.5.3.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-python/pyjwt/pyjwt-1.5.3.ebuild b/dev-python/pyjwt/pyjwt-1.5.3.ebuild
index ae1f2157dead..652713206d13 100644
--- a/dev-python/pyjwt/pyjwt-1.5.3.ebuild
+++ b/dev-python/pyjwt/pyjwt-1.5.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -24,8 +24,6 @@ DEPEND="
test? (
>=dev-python/cryptography-1.4.0[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- dev-python/pytest-runner[${PYTHON_USEDEP}]
)"
S="${WORKDIR}"/${MY_PN}-${PV}
@@ -34,11 +32,14 @@ python_prepare_all() {
find . -name '__pycache__' -prune -exec rm -rf {} \; || die "Cleaning __pycache__ failed"
find . -name '*.pyc' -exec rm -f {} \; || die "Cleaing *.pyc failed"
+ # enables coverage, we don't need that
+ rm setup.cfg || die
+
distutils-r1_python_prepare_all
}
python_test() {
- esetup.py test
+ pytest -vv || die "Tests fail with ${EPYTHON}"
}
pkg_postinst() {