summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-08 17:08:40 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-08 17:22:55 +0200
commitb2bb39fb9aee459692ba6fc1fdbf5ad589e87555 (patch)
tree89e7fe399b422665f8c4338477075b2ada26ca3a /dev-python/pykerberos
parentdev-python/pyftpdlib: EAPI 8, PEP517, fix tests (diff)
downloadgentoo-b2bb39fb9aee459692ba6fc1fdbf5ad589e87555.tar.gz
gentoo-b2bb39fb9aee459692ba6fc1fdbf5ad589e87555.tar.bz2
gentoo-b2bb39fb9aee459692ba6fc1fdbf5ad589e87555.zip
dev-python/pykerberos: EAPI 8, PEP517
Closes: https://bugs.gentoo.org/909941 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pykerberos')
-rw-r--r--dev-python/pykerberos/Manifest1
-rw-r--r--dev-python/pykerberos/pykerberos-1.3.1-r2.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/pykerberos/Manifest b/dev-python/pykerberos/Manifest
index cf0fb2ef6e73..1bc6200a7b32 100644
--- a/dev-python/pykerberos/Manifest
+++ b/dev-python/pykerberos/Manifest
@@ -1 +1,2 @@
DIST PyKerberos-1.3.1.tar.gz 41954 BLAKE2B b95a3473c5803ebcb461db7f2589caa03e92f4cb3ba3a4890a31db99b687aa4c77ae4e58f09ae2339a1fd8acf6fe9ab5797e3b7178dfeb2ee7a95bb851fff402 SHA512 dcadc5c3b095d8bba947a745ac84cc558d7eebad139a0e86260891966786506a7a62600fde93fa14683971e436da8cc5cd3795817b20ba45ce7e39f8c05deb53
+DIST ccs-pykerberos-PyKerberos-1.3.1.gh.tar.gz 41954 BLAKE2B b95a3473c5803ebcb461db7f2589caa03e92f4cb3ba3a4890a31db99b687aa4c77ae4e58f09ae2339a1fd8acf6fe9ab5797e3b7178dfeb2ee7a95bb851fff402 SHA512 dcadc5c3b095d8bba947a745ac84cc558d7eebad139a0e86260891966786506a7a62600fde93fa14683971e436da8cc5cd3795817b20ba45ce7e39f8c05deb53
diff --git a/dev-python/pykerberos/pykerberos-1.3.1-r2.ebuild b/dev-python/pykerberos/pykerberos-1.3.1-r2.ebuild
new file mode 100644
index 000000000000..99abdec65e6e
--- /dev/null
+++ b/dev-python/pykerberos/pykerberos-1.3.1-r2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P=ccs-pykerberos-PyKerberos-${PV}
+DESCRIPTION="A high-level Python wrapper for Kerberos/GSSAPI operations"
+HOMEPAGE="
+ https://www.calendarserver.org/PyKerberos.html
+ https://github.com/apple/ccs-pykerberos/
+ https://pypi.org/project/kerberos/
+"
+SRC_URI="
+ https://github.com/apple/ccs-pykerberos/archive/PyKerberos-${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~riscv ~x86"
+# test environment is non-trivial to set up, so just use docker
+# (see python_test below)
+# also for alpha/beta Python releases support:
+# https://github.com/apple/ccs-pykerberos/pull/83/commits/5f1130a1305b5f6e7d7d8b41067c4713f0c8950f
+RESTRICT="test"
+
+DEPEND="
+ app-crypt/mit-krb5
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.1-python3.10.patch
+)
+
+python_test() {
+ set -- docker run \
+ -v "${PWD}:/app" \
+ -w /app \
+ -e PYENV=$("${EPYTHON}" -c 'import sys; print(sys.version.split()[0])') \
+ -e KERBEROS_USERNAME=administrator \
+ -e KERBEROS_PASSWORD=Password01 \
+ -e KERBEROS_REALM=example.com \
+ -e KERBEROS_PORT=80 \
+ ubuntu:16.04 \
+ /bin/bash .travis.sh
+ echo "${@}" >&2
+ "${@}" || die "Tests failed with ${EPYTHON}"
+}