summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-07 10:34:10 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-07 11:33:49 +0200
commit079a09d095bb410057cece39eccea4bc623cc1c3 (patch)
treeface13bd13d73141fe28fcc5c7a87a1e4d8e8be8 /dev-python/pylint
parentdev-python/sphinxcontrib-doxylink: Bump to 1.12.0 (diff)
downloadgentoo-079a09d095bb410057cece39eccea4bc623cc1c3.tar.gz
gentoo-079a09d095bb410057cece39eccea4bc623cc1c3.tar.bz2
gentoo-079a09d095bb410057cece39eccea4bc623cc1c3.zip
dev-python/pylint: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/Manifest1
-rw-r--r--dev-python/pylint/pylint-2.12.2.ebuild64
2 files changed, 0 insertions, 65 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index 537fb5fdf564..a00f5866a4fe 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1,4 +1,3 @@
-DIST pylint-2.12.2.gh.tar.gz 1032702 BLAKE2B de7dce04159b332baa5c23f4034ee249e49f9239c5c9190213a51a84a47ac2129f8a2265e1ad9c01ab448ec58f4f36653c6de5b0be6bfdf6aa286c8887313759 SHA512 0d2b9b785371af0a1c809271153abbab58f50455b34f12370461ded2c4f3d62656e4c0391adff48e179b95da945a2f44e762863e2b7d63808976bf5f684e20d2
DIST pylint-2.13.5.gh.tar.gz 1118551 BLAKE2B 70ee4254aa140aba16adfe67aeb896d9c455843dfa945d335b5ba48e85c9d2d8f057223bc74bd4c0c0bfa2d343a9f78e783705b885caaee6895fcddf7ce23ccb SHA512 e399239fbea58260b17f226dddb63f1e6a2f12cdd601a4e73913a169d23fe2b6085e776bf8144e2c5a555dfdc1b28a5818a4103969d504b638b6b41ee296d182
DIST pylint-2.13.7.gh.tar.gz 1120083 BLAKE2B c45d6ec65c11d3682bf3279969f3e45b827b2bbcebbfeb05a31df3a93bb943bf9643a5d467c1e2eebf717577032571a48db1ce84e1c81d72000808ec302aaf1b SHA512 ec0b2ef565239ab3e577c5c2d22c1c8df8b8bb0858c34b6606f649484d69a25c1f51ca61a3da66833d9a713e8a686dc32b940e574650577bdcc4e13d76acc2e5
DIST pylint-2.13.8.gh.tar.gz 1121081 BLAKE2B 06a0a5c3801318ca45073f04a631e0617b5803ce01fd3973fc96d350c38a988222d4b8b03f86c12c317f6f87db5b7b85d1c428373a17e51d1044b382a0d03c1d SHA512 8ab01a15da7d9b659aa11de3ee804e0ad54fefd549be468fe194f8ec66640f5ecbdeddec468c9fd76d1eea8006d60249b1abba59d5047774d22b7b461224695d
diff --git a/dev-python/pylint/pylint-2.12.2.ebuild b/dev-python/pylint/pylint-2.12.2.ebuild
deleted file mode 100644
index 21083c4d3e9f..000000000000
--- a/dev-python/pylint/pylint-2.12.2.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Python code static checker"
-HOMEPAGE="https://www.logilab.org/project/pylint
- https://pypi.org/project/pylint/
- https://github.com/pycqa/pylint/"
-SRC_URI="
- https://github.com/pycqa/pylint/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="examples"
-
-# Make sure to check https://github.com/PyCQA/pylint/blob/main/setup.cfg#L43 on bumps
-# Adjust dep bounds!
-RDEPEND="
- <dev-python/astroid-2.10[${PYTHON_USEDEP}]
- >=dev-python/astroid-2.9.0[${PYTHON_USEDEP}]
- >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
- <dev-python/isort-6[${PYTHON_USEDEP}]
- >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
- <dev-python/mccabe-0.7[${PYTHON_USEDEP}]
- >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/toml-0.9.2[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/typing-extensions[${PYTHON_USEDEP}]
- ' python3_{8,9})
-"
-BDEPEND="test? ( >=dev-python/GitPython-3[${PYTHON_USEDEP}] )"
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.4.4-sphinx-theme.patch"
-)
-
-distutils_enable_sphinx doc --no-autodoc
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # No need to run the benchmarks
- tests/benchmark/test_baseline_benchmarks.py
- )
- # Specify the test directory explicitly to avoid import file mismatches
- epytest tests
-}
-
-python_install_all() {
- if use examples ; then
- docompress -x "/usr/share/doc/${PF}/examples"
- docinto examples
- dodoc -r examples/.
- fi
-
- distutils-r1_python_install_all
-}