summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-17 09:56:53 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-17 10:00:31 +0100
commit303b566ddfbccfb2a1bb82aeff8e2bf1630737ae (patch)
treeb71331945ab3dfc6a5ae363d1fcb4fda2c8a2aa1 /dev-python/pylint
parentdev-python/eventlet: Bump to 0.33.0 (diff)
downloadgentoo-303b566ddfbccfb2a1bb82aeff8e2bf1630737ae.tar.gz
gentoo-303b566ddfbccfb2a1bb82aeff8e2bf1630737ae.tar.bz2
gentoo-303b566ddfbccfb2a1bb82aeff8e2bf1630737ae.zip
dev-python/pylint: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/Manifest1
-rw-r--r--dev-python/pylint/pylint-2.9.6.ebuild57
2 files changed, 0 insertions, 58 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index d3c387d2fb88..458d429e51ac 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1,2 +1 @@
DIST pylint-2.10.2.gh.tar.gz 813391 BLAKE2B 109f8817e32ddf8d93c9120518e77a1d2f7e61cd1a6362eb1cf9e6d242db72fa1a9271588a3abb28efca54bcc449dce623ae5d5fd63153ec2bc367e008aab465 SHA512 5d694587956c4f11eb4afaec26cefb66ccbe14dc2aacf378a0362326506d80eb2633e0d351c0a20715a3359a9bc438092d77b2e46f7f787210c7ab0555f2722f
-DIST pylint-2.9.6.gh.tar.gz 779390 BLAKE2B b1d8794e1e7ccdde87919eb943f83287c0a7b85b67f3722cbbe68887f2c61ab30b354548e25b70c661234647e35f79beb6aaad5f6be6bfde8c2475cf03676922 SHA512 a23ff089853398df2e4232767ca87c21e4ab4fc6805de80db796c78c56e0da1ade9b0586f5c14a98524bf607e0d240c354cf63287eec7dfdce263188eb19ddce
diff --git a/dev-python/pylint/pylint-2.9.6.ebuild b/dev-python/pylint/pylint-2.9.6.ebuild
deleted file mode 100644
index ccd48c7f91f5..000000000000
--- a/dev-python/pylint/pylint-2.9.6.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..9} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Python code static checker"
-HOMEPAGE="https://www.logilab.org/project/pylint
- https://pypi.org/project/pylint/
- https://github.com/pycqa/pylint/"
-SRC_URI="
- https://github.com/pycqa/pylint/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~ia64 ppc ppc64 ~riscv sparc x86"
-IUSE="examples"
-
-RDEPEND="
- <dev-python/astroid-2.7[${PYTHON_USEDEP}]
- >=dev-python/astroid-2.6.5[${PYTHON_USEDEP}]
- >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
- <dev-python/isort-6[${PYTHON_USEDEP}]
- >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
- <dev-python/mccabe-0.7[${PYTHON_USEDEP}]
- >=dev-python/toml-0.7.1[${PYTHON_USEDEP}]
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.4.4-sphinx-theme.patch"
-)
-
-distutils_enable_sphinx doc --no-autodoc
-distutils_enable_tests pytest
-
-python_test() {
- local skipped_tests=(
- # No need to run the benchmarks
- tests/benchmark/test_baseline_benchmarks.py
- )
- # Specify the test directory explicitly to avoid import file mismatches
- epytest tests ${skipped_tests[@]/#/--deselect }
-}
-
-python_install_all() {
- if use examples ; then
- docompress -x "/usr/share/doc/${PF}/examples"
- docinto examples
- dodoc -r examples/.
- fi
-
- distutils-r1_python_install_all
-}