summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-25 22:33:31 +0000
committerSam James <sam@gentoo.org>2021-11-25 22:37:24 +0000
commite821374dd1524a50cb9fa3dce72601b5227c8b8a (patch)
treec1949d5ab439a6a4d53ea75f2b56801585547683 /dev-python/pylint
parentdev-python/GitPython: enable py3.10 (diff)
downloadgentoo-e821374dd1524a50cb9fa3dce72601b5227c8b8a.tar.gz
gentoo-e821374dd1524a50cb9fa3dce72601b5227c8b8a.tar.bz2
gentoo-e821374dd1524a50cb9fa3dce72601b5227c8b8a.zip
dev-python/pylint: add 2.12.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/Manifest1
-rw-r--r--dev-python/pylint/pylint-2.12.1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index c2c9d79dee14..bb2abc140426 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1,2 +1,3 @@
DIST pylint-2.10.2.gh.tar.gz 813391 BLAKE2B 109f8817e32ddf8d93c9120518e77a1d2f7e61cd1a6362eb1cf9e6d242db72fa1a9271588a3abb28efca54bcc449dce623ae5d5fd63153ec2bc367e008aab465 SHA512 5d694587956c4f11eb4afaec26cefb66ccbe14dc2aacf378a0362326506d80eb2633e0d351c0a20715a3359a9bc438092d77b2e46f7f787210c7ab0555f2722f
DIST pylint-2.11.1.gh.tar.gz 967223 BLAKE2B 435bb4589fa6dbfadfa234f8cb968a1d5c39efaf9b37fd20dfadc6feb1e997b34124386dab777b1aa1657bd9a36055d535e231181c71834517528cbbc04c698f SHA512 fe283b6eb8090414ea99809158b4e7f9fe85187ef6488ec37c5f34430793b0b4ff8afd9c97452fe0bb88efb9be001c0fd9f9a09a23081cb79084ae409b277f34
+DIST pylint-2.12.1.gh.tar.gz 1025764 BLAKE2B 650cf89a6b1d39be1eb6e9595e26e84c8f2beb62deebc0886e6a507bcfd7ee4ce87094fd05a139297ea5a4afc4ae5bb2af655bb245d95ac6946f8989efab5531 SHA512 f758775b6ecc8b73096e3556b3c22c81d84baa12d7623448aaa9e2ac19ff5b99112938ee7c8daf7122dbdb4d2b41012a7606213972a2dcf855b450a0a74f0d1e
diff --git a/dev-python/pylint/pylint-2.12.1.ebuild b/dev-python/pylint/pylint-2.12.1.ebuild
new file mode 100644
index 000000000000..7d00a5792ed0
--- /dev/null
+++ b/dev-python/pylint/pylint-2.12.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python code static checker"
+HOMEPAGE="https://www.logilab.org/project/pylint
+ https://pypi.org/project/pylint/
+ https://github.com/pycqa/pylint/"
+SRC_URI="
+ https://github.com/pycqa/pylint/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+IUSE="examples"
+
+# Make sure to check https://github.com/PyCQA/pylint/blob/main/setup.cfg#L43 on bumps
+# Adjust dep bounds!
+RDEPEND="
+ <dev-python/astroid-2.10[${PYTHON_USEDEP}]
+ >=dev-python/astroid-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
+ <dev-python/isort-6[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.7[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/toml-0.9.2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' python3_{8,9})
+"
+BDEPEND="test? ( >=dev-python/GitPython-3[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.4.4-sphinx-theme.patch"
+)
+
+distutils_enable_sphinx doc --no-autodoc
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # No need to run the benchmarks
+ tests/benchmark/test_baseline_benchmarks.py
+ )
+ # Specify the test directory explicitly to avoid import file mismatches
+ epytest tests
+}
+
+python_install_all() {
+ if use examples ; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ docinto examples
+ dodoc -r examples/.
+ fi
+
+ distutils-r1_python_install_all
+}