summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-20 08:10:33 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-20 08:10:33 +0200
commitc0325aa63da06326448f361fa64eb096eef27590 (patch)
tree57c79fa4f222836b7ab4e0248f5a626747f3e244 /dev-python/pyls-spyder
parentprofiles: mask Meson tinyxml2 for now (diff)
downloadgentoo-c0325aa63da06326448f361fa64eb096eef27590.tar.gz
gentoo-c0325aa63da06326448f361fa64eb096eef27590.tar.bz2
gentoo-c0325aa63da06326448f361fa64eb096eef27590.zip
dev-python/pyls-spyder: Bump to 0.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyls-spyder')
-rw-r--r--dev-python/pyls-spyder/Manifest1
-rw-r--r--dev-python/pyls-spyder/pyls-spyder-0.4.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/pyls-spyder/Manifest b/dev-python/pyls-spyder/Manifest
index 6443d60444f4..4557c9c07b30 100644
--- a/dev-python/pyls-spyder/Manifest
+++ b/dev-python/pyls-spyder/Manifest
@@ -1 +1,2 @@
DIST pyls-spyder-0.3.2-gh.tar.gz 8781 BLAKE2B ac24e0433c2e5ba43274d6266bc7532e7a1f1b0c3c34b9acfe10e5c7d789937536e81c4b19f96090f32d34c932529c0f4c23b49d2b01e7a0b628f8c2dd6f7611 SHA512 c08910ebaf161ceb712f273f054add1f3a202684b001d8d95650555bd67fa5675b3fef9e3d62d0d1b9da0f5adfeae9ff0fbfee44e4362856550d77582dbc6e95
+DIST pyls-spyder-0.4.0-gh.tar.gz 8854 BLAKE2B d14a78be98c1db0a37a2fffe2e6bd8955687a95af8524c852d434e57cdd157dda8f5ecceb19ad34527dedede4497c59fb7949a709d266803c2d8cd67c60380ce SHA512 5a9d6667cb85434ec41a176e097d20c78751d5f3879d4d361e097da214b54b37fbef97d95a763a58d7f5e3c148215672e769091814f06a34139c6625cdae3f9f
diff --git a/dev-python/pyls-spyder/pyls-spyder-0.4.0.ebuild b/dev-python/pyls-spyder/pyls-spyder-0.4.0.ebuild
new file mode 100644
index 000000000000..0e13e95ffaa2
--- /dev/null
+++ b/dev-python/pyls-spyder/pyls-spyder-0.4.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Spyder extensions for the python language server"
+HOMEPAGE="https://github.com/spyder-ide/pyls-spyder
+ https://pypi.org/project/pyls-spyder/"
+SRC_URI="https://github.com/spyder-ide/${PN}/archive/v${PV}.tar.gz -> ${P}-gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/python-lsp-server[${PYTHON_USEDEP}]"
+BDEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest