summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-11-24 00:27:32 +0100
committerLouis Sautier <sbraz@gentoo.org>2020-11-24 00:28:25 +0100
commit706216bab9faa0eb6f93cc5c806c631f578b1347 (patch)
treef8754c91eb18a5a39f7234f7fdec67c851eefde7 /dev-python/pymediainfo/pymediainfo-5.0.3.ebuild
parentdev-vcs/qgit: inherit xdg cmake, because src_prepare (diff)
downloadgentoo-706216bab9faa0eb6f93cc5c806c631f578b1347.tar.gz
gentoo-706216bab9faa0eb6f93cc5c806c631f578b1347.tar.bz2
gentoo-706216bab9faa0eb6f93cc5c806c631f578b1347.zip
dev-python/pymediainfo: bump to 5.0.3
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/pymediainfo/pymediainfo-5.0.3.ebuild')
-rw-r--r--dev-python/pymediainfo/pymediainfo-5.0.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pymediainfo/pymediainfo-5.0.3.ebuild b/dev-python/pymediainfo/pymediainfo-5.0.3.ebuild
new file mode 100644
index 000000000000..8fcb1b108fb6
--- /dev/null
+++ b/dev-python/pymediainfo/pymediainfo-5.0.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6..9} )
+PYTHON_REQ_USE="xml(+)"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="A wrapper around the mediainfo library"
+HOMEPAGE="https://github.com/sbraz/pymediainfo"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="media-libs/libmediainfo"
+BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+distutils_enable_sphinx docs dev-python/alabaster
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Disable tests which requires network access
+ sed -i 's/@pytest.mark.internet/@pytest.mark.skip/' \
+ tests/test_pymediainfo.py || die
+ distutils-r1_python_prepare_all
+}