summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2016-03-04 19:21:52 +0600
committerAndrey Grozin <grozin@gentoo.org>2016-03-04 19:22:45 +0600
commite72e58844eaf93dc8228ecade8695dfd7c033680 (patch)
tree15db95e9546c40a5df6349bec667fafcb2dd0dd1 /dev-python/pyminuit
parentsci-visualization/veusz: added python3_5, dropped python3_3 (diff)
downloadgentoo-e72e58844eaf93dc8228ecade8695dfd7c033680.tar.gz
gentoo-e72e58844eaf93dc8228ecade8695dfd7c033680.tar.bz2
gentoo-e72e58844eaf93dc8228ecade8695dfd7c033680.zip
dev-python/pyminuit: added python3_5
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-python/pyminuit')
-rw-r--r--dev-python/pyminuit/pyminuit-1.2.1-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pyminuit/pyminuit-1.2.1-r1.ebuild b/dev-python/pyminuit/pyminuit-1.2.1-r1.ebuild
new file mode 100644
index 000000000000..2aadc71eb82a
--- /dev/null
+++ b/dev-python/pyminuit/pyminuit-1.2.1-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Minuit numerical function minimization in Python"
+HOMEPAGE="https://github.com/jpivarski/pyminuit"
+SRC_URI="
+ https://pyminuit.googlecode.com/files/${P}.tgz
+ https://pyminuit.googlecode.com/files/Minuit-1_7_9-patch1.tar.gz
+ "
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+S="${WORKDIR}"/${PN}
+
+src_configure() {
+ cd "${WORKDIR}"/Minuit-1_7_9 && econf --disable-static || die
+}
+src_compile() {
+ cd "${WORKDIR}"/Minuit-1_7_9 && emake
+ cd "${S}"
+ distutils-r1_src_compile
+}
+
+python_install_all() {
+ cd "${WORKDIR}"/Minuit-1_7_9 || die
+ default
+ distutils-r1_python_install_all
+}