summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2019-11-26 13:41:25 +0100
committerAlexys Jacob <ultrabug@gentoo.org>2019-11-26 13:42:16 +0100
commitc413b946b0d2c5a347d5a4d810a5ab7ddeb20656 (patch)
treecbb0316e8bc67b6ec93538f8fdd2ce902f97cc69 /dev-python/pymongo
parentsys-kernel/gentoo-sources: amd64 stable (bug #700416) (diff)
downloadgentoo-c413b946b0d2c5a347d5a4d810a5ab7ddeb20656.tar.gz
gentoo-c413b946b0d2c5a347d5a4d810a5ab7ddeb20656.tar.bz2
gentoo-c413b946b0d2c5a347d5a4d810a5ab7ddeb20656.zip
dev-python/pymongo: version bump
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Alexys Jacob <ultrabug@gentoo.org>
Diffstat (limited to 'dev-python/pymongo')
-rw-r--r--dev-python/pymongo/Manifest1
-rw-r--r--dev-python/pymongo/pymongo-3.9.0.ebuild119
2 files changed, 120 insertions, 0 deletions
diff --git a/dev-python/pymongo/Manifest b/dev-python/pymongo/Manifest
index deaf685626d5..6bc5bf112543 100644
--- a/dev-python/pymongo/Manifest
+++ b/dev-python/pymongo/Manifest
@@ -2,3 +2,4 @@ DIST pymongo-3.4.0.tar.gz 583303 BLAKE2B 2031b52731db8c5def167b2aceb4e1d064f0ff2
DIST pymongo-3.5.1.tar.gz 1332463 BLAKE2B d581409a4b6cdede3e126e31747d34ed0e238919163ed442477ae51765ebdd1ebfb53fc94f7f1f53161c2019bf9db46640730aa54f19af6af25a37c95372308d SHA512 67526bcc27233b85226d7ef6aacce6dfb848efc88730fb8207c3b610f3943ac813f6c2842b7e514d733a65a2b7ea4f255574732e42372551b1b333e3437fd82f
DIST pymongo-3.7.1.tar.gz 723014 BLAKE2B fd0be64f01006405f30e8d96e5edc0d565a8b67ec057a27b6143b4dd0592e2302efea65b6e3d4898d12e196b1efe01787aa608d8564573a83bfd193c703ba0c4 SHA512 34f7448c90a0741d1c80e5924d53e70d5c4bf74d140ea50cef1a519e11b7429dc8551ddb868ec4c02351da6619924ae0d4f7bfc12ef4fa9635c81e2f69aea30f
DIST pymongo-3.7.2.tar.gz 628611 BLAKE2B 4eac5f11c8cd9a1bf8e0553a1fc3ec8f0a4bec0fd6b04dd75fe85da7315baa0e81a3c2b2aa4eba351aa4206aae974bce263f0630ac8828d8a982c4902cf7f518 SHA512 4d1dfe03d94f381f27cfb5c8dd4f75ecbab90567fdc4dd594b880031e68825eda6285c8b261a4c9d76fb7ccc92c91e27ae2f696525f7732b1f0084794042a33d
+DIST pymongo-3.9.0.tar.gz 701117 BLAKE2B c13b53f06fa1788f65de46b6a05474355e312a1cdd7798610b300c1a7bb9964d32243da52a4dad61d5b50e736c717f5549f61b28c06e1024505bdd3ec04ab99a SHA512 3ac8831ffd82c27bfbf8429a38fe26aed177ba68b89d0ddf043adfde326b8c01eea9be449bb985421f42677fab4dd5ab44e1c1c9eeb3aff41d792c660fe23e0b
diff --git a/dev-python/pymongo/pymongo-3.9.0.ebuild b/dev-python/pymongo/pymongo-3.9.0.ebuild
new file mode 100644
index 000000000000..6128d0c11ad7
--- /dev/null
+++ b/dev-python/pymongo/pymongo-3.9.0.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
+
+inherit check-reqs distutils-r1
+
+DESCRIPTION="Python driver for MongoDB"
+HOMEPAGE="https://github.com/mongodb/mongo-python-driver https://pypi.org/project/pymongo/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~x86"
+IUSE="doc kerberos test"
+
+RDEPEND="
+ kerberos? ( dev-python/pykerberos[${PYTHON_USEDEP}] )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-db/mongodb-2.6.0
+ )
+"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+reqcheck() {
+ if use test; then
+ # During the tests, database size reaches 1.5G.
+ local CHECKREQS_DISK_BUILD=1536M
+
+ check-reqs_${1}
+ fi
+}
+
+pkg_pretend() {
+ reqcheck pkg_pretend
+}
+
+pkg_setup() {
+ reqcheck pkg_setup
+}
+
+python_compile_all() {
+ if use doc; then
+ mkdir html || die
+ sphinx-build doc html || die
+ fi
+}
+
+python_test() {
+ # Yes, we need TCP/IP for that...
+ local DB_IP=127.0.0.1
+ local DB_PORT=27000
+
+ export DB_IP DB_PORT
+
+ local dbpath=${TMPDIR}/mongo.db
+ local logpath=${TMPDIR}/mongod.log
+
+ # Now, the hard part: we need to find a free port for mongod.
+ # We're just trying to run it random port numbers and check the log
+ # for bind errors. It shall be noted that 'mongod --fork' does not
+ # return failure when it fails to bind.
+
+ mkdir -p "${dbpath}" || die
+ while true; do
+ ebegin "Trying to start mongod on port ${DB_PORT}"
+
+ LC_ALL=C \
+ mongod --dbpath "${dbpath}" --nojournal \
+ --bind_ip ${DB_IP} --port ${DB_PORT} \
+ --unixSocketPrefix "${TMPDIR}" \
+ --logpath "${logpath}" --fork \
+ && sleep 2
+
+ # Now we need to check if the server actually started...
+ if [[ ${?} -eq 0 && -S "${TMPDIR}"/mongodb-${DB_PORT}.sock ]]; then
+ # yay!
+ eend 0
+ break
+ elif grep -q 'Address already in use' "${logpath}"; then
+ # ay, someone took our port!
+ eend 1
+ : $(( DB_PORT += 1 ))
+ continue
+ else
+ eend 1
+ eerror "Unable to start mongod for tests. See the server log:"
+ eerror " ${logpath}"
+ die "Unable to start mongod for tests."
+ fi
+ done
+
+ local failed
+ #https://jira.mongodb.org/browse/PYTHON-521, py2.[6-7] has intermittent failure with gevent
+ pushd "${BUILD_DIR}"/../ > /dev/null
+ if [[ "${EPYTHON}" == python3* ]]; then
+ 2to3 --no-diffs -w test
+ fi
+ DB_PORT2=$(( DB_PORT + 1 )) DB_PORT3=$(( DB_PORT + 2 )) esetup.py test || failed=1
+
+ mongod --dbpath "${dbpath}" --shutdown || die
+
+ [[ ${failed} ]] && die "Tests fail with ${EPYTHON}"
+
+ rm -rf "${dbpath}" || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( html/. )
+
+ distutils-r1_python_install_all
+}