summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-19 17:26:43 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-19 18:29:11 +0200
commit080ba3e574d2602a921b3c2259da65427accfb3e (patch)
treed78c7400fa469f4b060a3e624212fb2d945e1758 /dev-python/pymysql/pymysql-0.6.7.ebuild
parentdev-python/passwordmeter: Version Bump (diff)
downloadgentoo-080ba3e574d2602a921b3c2259da65427accfb3e.tar.gz
gentoo-080ba3e574d2602a921b3c2259da65427accfb3e.tar.bz2
gentoo-080ba3e574d2602a921b3c2259da65427accfb3e.zip
dev-python/pymysql: Version Bump
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pymysql/pymysql-0.6.7.ebuild')
-rw-r--r--dev-python/pymysql/pymysql-0.6.7.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pymysql/pymysql-0.6.7.ebuild b/dev-python/pymysql/pymysql-0.6.7.ebuild
new file mode 100644
index 000000000000..c0fc33183520
--- /dev/null
+++ b/dev-python/pymysql/pymysql-0.6.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN="PyMySQL"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Pure-Python MySQL Driver"
+HOMEPAGE="http://www.pymysql.org/"
+SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+S=${WORKDIR}/${MY_P}
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# While tests exist, they require an unsecure server to run without manual config file
+RESTRICT="test"
+
+python_test() {
+ ${PYTHON} runtests.py || die
+}