summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pynotifier
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pynotifier')
-rw-r--r--dev-python/pynotifier/Manifest1
-rw-r--r--dev-python/pynotifier/metadata.xml10
-rw-r--r--dev-python/pynotifier/pynotifier-0.7.0-r2.ebuild28
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pynotifier/Manifest b/dev-python/pynotifier/Manifest
new file mode 100644
index 000000000000..c7fe651f0777
--- /dev/null
+++ b/dev-python/pynotifier/Manifest
@@ -0,0 +1 @@
+DIST pynotifier_0.7.0.orig.tar.gz 35358 SHA256 2b27bd034b631226e4bf878183c208909f2653102dfa200af5a075ebf54d2723 SHA512 60be00e5a729c3bb3a6f778025e2422268986645bcb461a81db457cb8e4c94b86d7215d7725f0bc9dd1ea1dfaa16a879760c53dd6824fb398d02b7dc8979c3ef WHIRLPOOL d620d9493129061a02a23310eaeb8c32a6d7f0a963e0cde143019bf3ee27907e29305b52dc833bb8933d69cd9ffc7bcbf2276cd624e060df007f85c14222e42c
diff --git a/dev-python/pynotifier/metadata.xml b/dev-python/pynotifier/metadata.xml
new file mode 100644
index 000000000000..3c0d60c95c68
--- /dev/null
+++ b/dev-python/pynotifier/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription>
+ pyNotifier provides an implementation of a notifier/event
+ scheduler and is capable of wrapping other notifier
+ implementations of GTK+, Qt and wxWidgets.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/pynotifier/pynotifier-0.7.0-r2.ebuild b/dev-python/pynotifier/pynotifier-0.7.0-r2.ebuild
new file mode 100644
index 000000000000..38c834a6e49b
--- /dev/null
+++ b/dev-python/pynotifier/pynotifier-0.7.0-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="pyNotifier provides an implementation of a notifier/event scheduler"
+HOMEPAGE="http://www.bitkipper.net/"
+SRC_URI="http://www.bitkipper.net/bytes/debian/dists/unstable/source/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="qt4 gtk"
+
+DEPEND=""
+RDEPEND="dev-python/twisted-core
+ gtk? ( dev-python/pygobject:2[${PYTHON_USEDEP}] )
+ qt4? ( dev-python/PyQt4[X,${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ use gtk || rm notifier/nf_gtk.py
+ use qt4 || rm notifier/nf_qt.py
+ distutils-r1_python_prepare_all
+}