summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-12-09 11:26:38 +0100
committerMarek Szuba <marecki@gentoo.org>2020-12-09 11:26:38 +0100
commit346aeb4b1217f3c11e33b203ed77f60edebb506f (patch)
treee15bcff1f2eb80f146128ca9a41ec0b4406d1f1c /dev-python/pyopencl
parentdev-python/pytools: bump to 2020.4.3 (diff)
downloadgentoo-346aeb4b1217f3c11e33b203ed77f60edebb506f.tar.gz
gentoo-346aeb4b1217f3c11e33b203ed77f60edebb506f.tar.bz2
gentoo-346aeb4b1217f3c11e33b203ed77f60edebb506f.zip
dev-python/pyopencl: bump to 2020.3.1
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-python/pyopencl')
-rw-r--r--dev-python/pyopencl/Manifest1
-rw-r--r--dev-python/pyopencl/pyopencl-2020.3.1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/pyopencl/Manifest b/dev-python/pyopencl/Manifest
index 7d6ae05491b2..a19ae22c5c31 100644
--- a/dev-python/pyopencl/Manifest
+++ b/dev-python/pyopencl/Manifest
@@ -1,2 +1,3 @@
DIST pyopencl-2020.2.2.tar.gz 352110 BLAKE2B a3bb5f74abbb5d9600651dc0659f2472f7bf91d67cf3474f7306a29ccd3a8249dc952fc1e5b81f0514990e49246d106325a6697559b260a490981541666cb3a7 SHA512 2c4f21d9c0a5d3d53f2a0e4aaa8f85f42fc6fbedc5282cfc107ff047936aa731a973605f5500b56b62d5b580a00e9f2be2aa9a259287291641ca4b4d60c51ca9
DIST pyopencl-2020.2.tar.gz 351600 BLAKE2B 47a733d7a552f5d1f69a1a9710c3262d50c26651ed9f46146829babe28962e236e2c1b9ba3d3d14207f28bdc562323a94ab4c51dbf5fcf1a0b12282b3c6aff50 SHA512 233bbf2e99507d3a832222cc8149bf7ac17332a550e4867f843fcc2b31104d961a3f0d972b0a1878d4716b2da4548f1390560141cd09cb1ba13300c541b058b9
+DIST pyopencl-2020.3.1.tar.gz 357422 BLAKE2B de9cb6408e957e30f54797ce682ed17f3272dc82019bcd9a744a0696a7e344f47645a3549332da90e0bcc442f7a8ea9c6a12a375875a9728fa9814ca9d1a9b30 SHA512 459d6f060f4203e83276c47bf832f33fc4348dd59904ea55fe2a53684cb7c8eaad45875476d10dcb6653820f9cb1f7e013c6b854410b2040b2dfe847fc1f7658
diff --git a/dev-python/pyopencl/pyopencl-2020.3.1.ebuild b/dev-python/pyopencl/pyopencl-2020.3.1.ebuild
new file mode 100644
index 000000000000..e5fbb9b9f447
--- /dev/null
+++ b/dev-python/pyopencl/pyopencl-2020.3.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for OpenCL"
+HOMEPAGE="https://mathema.tician.de/software/pyopencl
+ https://pypi.org/project/pyopencl/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples opengl"
+
+COMMON="dev-python/numpy[${PYTHON_USEDEP}]"
+RDEPEND="${COMMON}
+ >=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/decorator-3.2.0[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/pytools-2017.6[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=virtual/opencl-2"
+DEPEND="${COMMON}
+ dev-python/pybind11[${PYTHON_USEDEP}]"
+
+# The test suite fails if there are no OpenCL platforms available, and
+# even if there is one (which requires the presence of both an OpenCL
+# runtime *and* hardware supported by it - simply emerging any runtime
+# is not enough) the vast majority of tests end up skipped because by
+# default the portage user hasn't got sufficient privileges to talk
+# to the GPU.
+RESTRICT="test"
+
+python_configure_all() {
+ local myconf=()
+ if use opengl; then
+ myconf+=(--cl-enable-gl)
+ fi
+
+ "${EPYTHON}" configure.py \
+ "${myconf[@]}"
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}