summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-05-30 11:56:12 +0100
committerMarek Szuba <marecki@gentoo.org>2022-05-30 11:56:12 +0100
commit63f2c9778bc3b568767ee8df73d1944e0be14221 (patch)
tree2272031939d7bcd82b3e6160d6815d1aa1dc91b4 /dev-python/pyopencl
parentdev-python/nodeenv: disable py3.7 (diff)
downloadgentoo-63f2c9778bc3b568767ee8df73d1944e0be14221.tar.gz
gentoo-63f2c9778bc3b568767ee8df73d1944e0be14221.tar.bz2
gentoo-63f2c9778bc3b568767ee8df73d1944e0be14221.zip
dev-python/pyopencl: add 2022.1.5
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-python/pyopencl')
-rw-r--r--dev-python/pyopencl/Manifest1
-rw-r--r--dev-python/pyopencl/pyopencl-2022.1.5.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/pyopencl/Manifest b/dev-python/pyopencl/Manifest
index 7f8032a1f828..cb94944ac75d 100644
--- a/dev-python/pyopencl/Manifest
+++ b/dev-python/pyopencl/Manifest
@@ -1 +1,2 @@
+DIST pyopencl-2022.1.5.tar.gz 454129 BLAKE2B 266bc327c9af5654287fc47cdf4e6002c7cddcd6f5e55bb70bb62aaee666dc5c102f78d4e946f010c1e109390c1d2e981e7ca6ca002d10f66248cb008b308734 SHA512 e6eb3e6d886d8ca1d94867a398b286556fd2d93535bb8481c7603cd521cd47606ce3d9cd6422830c6404305a4a1293234d8774fdda6923bdd2b4fc21fb39d377
DIST pyopencl-2022.1.tar.gz 452537 BLAKE2B 0d4d178a6bdf14dc3769dcb78c42bc894c0a443a6811fe9b25dedbc4a43debc06d1a1c32cb2a0df06fe16d1b2e78e65ef4f3ca8e9931be39384b3c8c813336de SHA512 e873807e757c19b59dbac2a0522fbb9c6e8af955d62bdcf06d8f3d792db3c9d2ce15372a6eefdca5b3f6756c35a85b5ff8d7dc1b6449bfd12c2b588576dd6f24
diff --git a/dev-python/pyopencl/pyopencl-2022.1.5.ebuild b/dev-python/pyopencl/pyopencl-2022.1.5.ebuild
new file mode 100644
index 000000000000..dc2cb443735e
--- /dev/null
+++ b/dev-python/pyopencl/pyopencl-2022.1.5.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for OpenCL"
+HOMEPAGE="https://mathema.tician.de/software/pyopencl/
+ https://pypi.org/project/pyopencl/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples opengl"
+
+DEPEND=">=virtual/opencl-2"
+RDEPEND="${DEPEND}
+ >=dev-python/mako-0.3.6[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pytools-2021.2.7[${PYTHON_USEDEP}]"
+# libglvnd is only needed for the headers
+BDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/pybind11-2.5.0[${PYTHON_USEDEP}]
+ opengl? ( media-libs/libglvnd )"
+
+# The test suite fails if there are no OpenCL platforms available, and
+# even if there is one (which requires the presence of both an OpenCL
+# runtime *and* hardware supported by it - simply emerging any runtime
+# is not enough) the vast majority of tests end up skipped because by
+# default the portage user hasn't got sufficient privileges to talk
+# to the GPU.
+RESTRICT="test"
+
+python_configure_all() {
+ local myconf=()
+ if use opengl; then
+ myconf+=(--cl-enable-gl)
+ fi
+
+ "${EPYTHON}" configure.py \
+ "${myconf[@]}"
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}