summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-06-05 14:20:47 +0100
committerMarek Szuba <marecki@gentoo.org>2021-06-05 14:23:28 +0100
commitf337d99feab3e650497b6c3091448124c2aad1ee (patch)
treeed90634974a0ccffe8308af4eaa13fd1ed8259e9 /dev-python/pyopencl
parentdev-ada/gnatmem: drop gnat_2016 (diff)
downloadgentoo-f337d99feab3e650497b6c3091448124c2aad1ee.tar.gz
gentoo-f337d99feab3e650497b6c3091448124c2aad1ee.tar.bz2
gentoo-f337d99feab3e650497b6c3091448124c2aad1ee.zip
dev-python/pyopencl: add missing dependency on OpenGL headers
Only in DEPEND because it seems it's just the headers that are needed, the extension doesn't get linked against any OpenGL libraries. And of course only for USE=opengl. Closes: https://bugs.gentoo.org/794247 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-python/pyopencl')
-rw-r--r--dev-python/pyopencl/pyopencl-2021.1.3.ebuild3
-rw-r--r--dev-python/pyopencl/pyopencl-2021.2.2.ebuild3
2 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/pyopencl/pyopencl-2021.1.3.ebuild b/dev-python/pyopencl/pyopencl-2021.1.3.ebuild
index a08b0c4fd9b4..103b128915c0 100644
--- a/dev-python/pyopencl/pyopencl-2021.1.3.ebuild
+++ b/dev-python/pyopencl/pyopencl-2021.1.3.ebuild
@@ -26,7 +26,8 @@ RDEPEND="${COMMON}
>=dev-python/pytools-2017.6[${PYTHON_USEDEP}]
>=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
DEPEND="${COMMON}
- dev-python/pybind11[${PYTHON_USEDEP}]"
+ dev-python/pybind11[${PYTHON_USEDEP}]
+ opengl? ( media-libs/libglvnd )"
# The test suite fails if there are no OpenCL platforms available, and
# even if there is one (which requires the presence of both an OpenCL
diff --git a/dev-python/pyopencl/pyopencl-2021.2.2.ebuild b/dev-python/pyopencl/pyopencl-2021.2.2.ebuild
index 863ef6a22457..a1278e628527 100644
--- a/dev-python/pyopencl/pyopencl-2021.2.2.ebuild
+++ b/dev-python/pyopencl/pyopencl-2021.2.2.ebuild
@@ -26,7 +26,8 @@ RDEPEND="${COMMON}
>=dev-python/pytools-2017.6[${PYTHON_USEDEP}]
>=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
DEPEND="${COMMON}
- dev-python/pybind11[${PYTHON_USEDEP}]"
+ dev-python/pybind11[${PYTHON_USEDEP}]
+ opengl? ( media-libs/libglvnd )"
# The test suite fails if there are no OpenCL platforms available, and
# even if there is one (which requires the presence of both an OpenCL