summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2020-03-18 22:11:34 -0400
committerRick Farina <zerochaos@gentoo.org>2020-03-18 22:11:58 -0400
commit6340061ed3c97189e0022065f99066561c4452d4 (patch)
treef3130d87207c9282a6778dac398b406eba45670d /dev-python/pyotherside
parentapp-crypt/yubikey-manager-qt: adding python3_{7,8} (diff)
downloadgentoo-6340061ed3c97189e0022065f99066561c4452d4.tar.gz
gentoo-6340061ed3c97189e0022065f99066561c4452d4.tar.bz2
gentoo-6340061ed3c97189e0022065f99066561c4452d4.zip
dev-python/pyotherside: bump
adding python3_8 Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'dev-python/pyotherside')
-rw-r--r--dev-python/pyotherside/Manifest1
-rw-r--r--dev-python/pyotherside/pyotherside-1.5.9.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pyotherside/Manifest b/dev-python/pyotherside/Manifest
index 47641a4a0d9f..19fa9f8ebd76 100644
--- a/dev-python/pyotherside/Manifest
+++ b/dev-python/pyotherside/Manifest
@@ -1,2 +1,3 @@
DIST pyotherside-1.5.4.tar.gz 183745 BLAKE2B 3dad2486dbc3d2632999aff0a7a7af41f6fefcae011bd1dd92b491b4403bbd62adb9a8520af627d5f96644f4fb25e89ee8fb49277723d5f80521d2add984008d SHA512 feaf95e0c981a8fb8b3a57926f48f803584a371752e7f1d2f3c739ee220960df33ad4ca2a38322f3e56d4f8fde193bd7342105303d847b2f532937e8bf2c3b65
DIST pyotherside-1.5.8.tar.gz 184812 BLAKE2B 6d6688ded2c726edf12a82611953a8124c49f904ab41a26a733eb74ff9fa071a4dcde4f3a2a21c424feebf6d85a0e5b3bf6179f3b48bb3828449ce1e5e6262ad SHA512 ff82bf693a239560001baa622c3854dbc920310573f4e565f247ac79a8ed717446231bc9a9d4990e9b8cb4032ca05d0c5ec9a1c87341be09238a62d005e6ac0f
+DIST pyotherside-1.5.9.tar.gz 185230 BLAKE2B 7130f17f29ed07cefc641d77631db46d08f3bd836c8517427e38fb454cbf34c2e875bb46798b3d785aa68064c24f154ed166617cde263f722e77eac6d0903980 SHA512 62c171b273b921d8e0220c7b73f0ff95a0a911eb3785cc37f3dab2ec624e54301ac5fbccfb57cac6a4bee967728624d4738b03aff0c5762452b99674cdff6ab2
diff --git a/dev-python/pyotherside/pyotherside-1.5.9.ebuild b/dev-python/pyotherside/pyotherside-1.5.9.ebuild
new file mode 100644
index 000000000000..768b631a0b94
--- /dev/null
+++ b/dev-python/pyotherside/pyotherside-1.5.9.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit qmake-utils python-single-r1
+
+DESCRIPTION="Asynchronous Python 3 Bindings for Qt 5"
+HOMEPAGE="https://github.com/thp/pyotherside https://thp.io/2011/pyotherside/"
+SRC_URI="https://github.com/thp/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+# Requires active X display
+RESTRICT="test"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ "
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i -e "s/qtquicktests//" pyotherside.pro || die
+
+ default
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+}