summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2020-07-24 16:44:56 +0000
committerThomas Deutschmann <whissi@gentoo.org>2020-07-26 18:22:17 +0200
commit5e3a4dbed02a6304c28671c839f03cc3d0187a64 (patch)
tree033d8b5cc970ddc55d77fae9cccd64a6630411b6 /dev-python/pypam
parentdev-db/redis: drop old and unsupported (diff)
downloadgentoo-5e3a4dbed02a6304c28671c839f03cc3d0187a64.tar.gz
gentoo-5e3a4dbed02a6304c28671c839f03cc3d0187a64.tar.bz2
gentoo-5e3a4dbed02a6304c28671c839f03cc3d0187a64.zip
dev-python/pypam: add python3.9 support
Needed by app-emulation/xen-tools Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-python/pypam')
-rw-r--r--dev-python/pypam/pypam-0.5.0-r5.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/pypam/pypam-0.5.0-r5.ebuild b/dev-python/pypam/pypam-0.5.0-r5.ebuild
new file mode 100644
index 000000000000..d2e07613cfd6
--- /dev/null
+++ b/dev-python/pypam/pypam-0.5.0-r5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_{6..9} )
+
+inherit distutils-r1 flag-o-matic
+
+MY_PN="PyPAM"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python Bindings for PAM (Pluggable Authentication Modules)"
+HOMEPAGE="http://www.pangalactic.org/PyPAM"
+SRC_URI="http://www.pangalactic.org/PyPAM/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND=">=sys-libs/pam-0.64"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( AUTHORS examples/pamtest.py )
+
+PATCHES=(
+ # Pull patches from fedora.
+ "${FILESDIR}/PyPAM-${PV}-dealloc.patch"
+ "${FILESDIR}/PyPAM-${PV}-nofree.patch"
+ "${FILESDIR}/PyPAM-${PV}-memory-errors.patch"
+ "${FILESDIR}/PyPAM-${PV}-return-value.patch"
+ "${FILESDIR}/PyPAM-python3-support.patch"
+ # Fix a missing include.
+ "${FILESDIR}/${P}-stricter.patch"
+)
+
+src_compile() {
+ append-cflags -fno-strict-aliasing
+ distutils-r1_src_compile
+}
+
+python_test() {
+ "${PYTHON}" tests/PamTest.py
+}