summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-25 07:41:39 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-25 07:58:35 +0200
commit7b642e8102d6394673bc3a0803082e78a82af4be (patch)
tree517ff3ca73823bddb8b86327a8440ac6633cf4aa /dev-python/pyparsing
parentdev-python/APScheduler: Bump to 3.8.1 (diff)
downloadgentoo-7b642e8102d6394673bc3a0803082e78a82af4be.tar.gz
gentoo-7b642e8102d6394673bc3a0803082e78a82af4be.tar.bz2
gentoo-7b642e8102d6394673bc3a0803082e78a82af4be.zip
dev-python/pyparsing: Bump to 3.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyparsing')
-rw-r--r--dev-python/pyparsing/Manifest1
-rw-r--r--dev-python/pyparsing/pyparsing-3.0.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pyparsing/Manifest b/dev-python/pyparsing/Manifest
index e8f441a8ad91..fb0d52f8b908 100644
--- a/dev-python/pyparsing/Manifest
+++ b/dev-python/pyparsing/Manifest
@@ -1,2 +1,3 @@
DIST pyparsing_2.4.7.tar.gz 648158 BLAKE2B 24525b4ee7876e245b9eb270f0e3e22fe2d8b398f9777ad3b3657b8a1227dcbd25983aa64a3f3018debdbffc1a042c732e6b3a09800e081c7acac7b97da15317 SHA512 c7a546729f86a2b5176e2482b566b9fd715b03e495aaef4d720b21307bb03f385dbc849247f8d266cb3d92be0a83c34ce4995b655ce85318355d5a0d42d6991e
DIST pyparsing_3.0.0.tar.gz 935578 BLAKE2B 2932fb8da83f4f7b0ba98057002c870ab54f50bb93cea3f1da1cb9bba87fd8a6066c7bbee700667663285226ad6bf637f340160ccf7b7b06616e1140a7b93ce3 SHA512 1400370a6e7518940b7965645578028588af5a4ec1c379d57c924f036c86e342a9a60f1dd5c700ce8a4dbcd16afb55a2a4c371548c8bac6c53338b5cc349f4d8
+DIST pyparsing_3.0.1.tar.gz 936219 BLAKE2B cc7dc4670f37a09e98c8bda785bac4121150f1a48438cc42c6fbf0546531e7fc674f2bfe1c85aba66ac1075b9c086d9ee30672a3eebc60efec21fd51772f577f SHA512 70f2f957c713a88979ae95de8834a79c777196a2a6d47a25bf930cdefdc3120919147a33119ada0d33c53bb215fcddfa969b0d1630d2979c9e685d85e5c57414
diff --git a/dev-python/pyparsing/pyparsing-3.0.1.ebuild b/dev-python/pyparsing/pyparsing-3.0.1.ebuild
new file mode 100644
index 000000000000..5e4cb765d6ac
--- /dev/null
+++ b/dev-python/pyparsing/pyparsing-3.0.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2004-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+MY_P=${P/-/_}
+DESCRIPTION="Easy-to-use Python module for text parsing"
+HOMEPAGE="https://github.com/pyparsing/pyparsing https://pypi.org/project/pyparsing/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${MY_P}.tar.gz"
+S=${WORKDIR}/${PN}-${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # railroad-diagrams not packaged (and not suitable for packaging yet)
+ tests/test_diagram.py
+)
+
+EPYTEST_DESELECT=(
+ # also railroad-diagrams
+ tests/test_unit.py::Test02_WithoutPackrat::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test04_WithPackrat::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test06_WithBoundedPackrat::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test08_WithUnboundedPackrat::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test09_WithLeftRecursionParsing::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test10_WithLeftRecursionParsingBoundedMemo::testEmptyExpressionsAreHandledProperly
+)
+
+python_install_all() {
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}