summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-27 10:13:20 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-27 10:21:20 +0100
commitac520a91836a7b5341caaa6e5e363e5c78d6d501 (patch)
tree64a601eead496515070eb104d314171e478e72e9 /dev-python/pyphen/pyphen-0.12.0-r1.ebuild
parentdev-python/pkgconfig: Switch to PEP 517 build (diff)
downloadgentoo-ac520a91836a7b5341caaa6e5e363e5c78d6d501.tar.gz
gentoo-ac520a91836a7b5341caaa6e5e363e5c78d6d501.tar.bz2
gentoo-ac520a91836a7b5341caaa6e5e363e5c78d6d501.zip
dev-python/pyphen: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyphen/pyphen-0.12.0-r1.ebuild')
-rw-r--r--dev-python/pyphen/pyphen-0.12.0-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pyphen/pyphen-0.12.0-r1.ebuild b/dev-python/pyphen/pyphen-0.12.0-r1.ebuild
new file mode 100644
index 000000000000..e7e1115064f2
--- /dev/null
+++ b/dev-python/pyphen/pyphen-0.12.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for hyphenation using hunspell dictionaries"
+HOMEPAGE="https://github.com/Kozea/Pyphen"
+SRC_URI="https://github.com/Kozea/Pyphen/archive/${PV}.tar.gz -> ${P^}.tar.gz"
+S=${WORKDIR}/${P^}
+
+LICENSE="GPL-2+ LGPL-2+ MPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # avoid dep on extra plugins
+ sed -i -e '/addopts/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}