summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-05 19:50:41 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-05 19:59:40 +0200
commit6d4e735345a9bee6ede3e855780a3c3168a55242 (patch)
tree159bfafbe2b437258a894afddfdb2a47fd89e06f /dev-python/pyphen
parentdev-python/pyperclip: Enable py3.10 (diff)
downloadgentoo-6d4e735345a9bee6ede3e855780a3c3168a55242.tar.gz
gentoo-6d4e735345a9bee6ede3e855780a3c3168a55242.tar.bz2
gentoo-6d4e735345a9bee6ede3e855780a3c3168a55242.zip
dev-python/pyphen: Enable py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyphen')
-rw-r--r--dev-python/pyphen/Manifest2
-rw-r--r--dev-python/pyphen/pyphen-0.10.0.ebuild18
2 files changed, 6 insertions, 14 deletions
diff --git a/dev-python/pyphen/Manifest b/dev-python/pyphen/Manifest
index d08a1ce9c5c2..78b4df97eefd 100644
--- a/dev-python/pyphen/Manifest
+++ b/dev-python/pyphen/Manifest
@@ -1 +1 @@
-DIST pyphen-0.10.0.tar.gz 1894118 BLAKE2B c33283d6eb3dd7affb52b91826fa0f8fab8ec8f858158e905e8487dc2ad8c77a88e4b25699ed6272d246bcf8a926560e18ec224f59703452ea1ad5c921e4fb4b SHA512 b6d789ca6eb010c1c79b28a9a0e68620ea5600adc43111bed5dbda3cb8b3a4c8c05caa3fb44ea60b0ef4a20272f17cf5e6fe61f0d1e48038395407ff53da7a92
+DIST Pyphen-0.10.0.tar.gz 1894118 BLAKE2B c33283d6eb3dd7affb52b91826fa0f8fab8ec8f858158e905e8487dc2ad8c77a88e4b25699ed6272d246bcf8a926560e18ec224f59703452ea1ad5c921e4fb4b SHA512 b6d789ca6eb010c1c79b28a9a0e68620ea5600adc43111bed5dbda3cb8b3a4c8c05caa3fb44ea60b0ef4a20272f17cf5e6fe61f0d1e48038395407ff53da7a92
diff --git a/dev-python/pyphen/pyphen-0.10.0.ebuild b/dev-python/pyphen/pyphen-0.10.0.ebuild
index 99764ca32724..37507a56effb 100644
--- a/dev-python/pyphen/pyphen-0.10.0.ebuild
+++ b/dev-python/pyphen/pyphen-0.10.0.ebuild
@@ -1,30 +1,22 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-PYTHON_COMPAT=( python3_{7,8,9} )
-DISTUTILS_USE_SETUPTOOLS=bdepend
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Python module for hyphenation using hunspell dictionaries"
-MY_PN="Pyphen"
-MY_P="${MY_PN}-${PV}"
-SRC_URI="https://github.com/Kozea/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
HOMEPAGE="https://github.com/Kozea/Pyphen"
+SRC_URI="https://github.com/Kozea/Pyphen/archive/${PV}.tar.gz -> ${P^}.tar.gz"
+S=${WORKDIR}/${P^}
LICENSE="GPL-2+ LGPL-2+ MPL-1.1"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
-
-RDEPEND=""
-DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
distutils_enable_tests pytest
python_test() {
- pytest -v test.py || die
+ epytest test.py
}