summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-26 08:52:40 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-26 09:09:12 +0200
commit06a878910a184db3e7ed1954e6b3996551773822 (patch)
tree6da9d2b623302771448cc53d4c0c26c0c19aea6a /dev-python/pypng/pypng-0.0.21.ebuild
parentapp-admin/awscli: Bump to 1.20.29 (diff)
downloadgentoo-06a878910a184db3e7ed1954e6b3996551773822.tar.gz
gentoo-06a878910a184db3e7ed1954e6b3996551773822.tar.bz2
gentoo-06a878910a184db3e7ed1954e6b3996551773822.zip
dev-python/pypng: Bump to 0.0.21
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pypng/pypng-0.0.21.ebuild')
-rw-r--r--dev-python/pypng/pypng-0.0.21.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/pypng/pypng-0.0.21.ebuild b/dev-python/pypng/pypng-0.0.21.ebuild
new file mode 100644
index 000000000000..da8290ca6532
--- /dev/null
+++ b/dev-python/pypng/pypng-0.0.21.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure Python PNG image encoder/decoder"
+HOMEPAGE="
+ https://github.com/drj11/pypng/
+ https://pypi.org/project/pypng/"
+SRC_URI="https://github.com/drj11/pypng/archive/${P}.tar.gz"
+S=${WORKDIR}/pypng-${P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+python_test() {
+ "${EPYTHON}" code/test_png.py -v || die "Tests fail with ${EPYTHON}"
+}