summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-04 22:52:42 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-04 22:52:42 +0200
commit07ee6824b5dc64522c59d3ec8bb244f969995aa0 (patch)
tree49faacfdec7c3e96ad5514b2a808a8266f1bc92b /dev-python/pypng
parentdev-python/argon2-cffi: Remove old (diff)
downloadgentoo-07ee6824b5dc64522c59d3ec8bb244f969995aa0.tar.gz
gentoo-07ee6824b5dc64522c59d3ec8bb244f969995aa0.tar.bz2
gentoo-07ee6824b5dc64522c59d3ec8bb244f969995aa0.zip
dev-python/pypng: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pypng')
-rw-r--r--dev-python/pypng/Manifest1
-rw-r--r--dev-python/pypng/files/pypng-0.0.20-py39.patch34
-rw-r--r--dev-python/pypng/pypng-0.0.20.ebuild25
3 files changed, 0 insertions, 60 deletions
diff --git a/dev-python/pypng/Manifest b/dev-python/pypng/Manifest
index 9987a295acfc..bf24b244d0ea 100644
--- a/dev-python/pypng/Manifest
+++ b/dev-python/pypng/Manifest
@@ -1,2 +1 @@
-DIST pypng-0.0.20.tar.gz 649538 BLAKE2B 9a15923c7f4d06deb982dc0b70d7502d3a5189f06cd6cdd0b35e81fcba6ea6b8ef50a6ab1ea03d8ac69a5e4d712eb23d7e18a3f1641c5a51f6f4d287d2fb5e43 SHA512 4f84e9b9cc68c0ad7e4558f0f46c54b0f091561f1a3679ac0679d8a1f1ab9a06493d71bf9df4db5deb6bedbdfa53bb1775ee51204133309eba962077102fdcdd
DIST pypng-0.0.21.tar.gz 111899 BLAKE2B b4b8f17b76918f415c02edc09a597af643615f46839fb4464f3116e4cefb0a251227f344ff2c1c51efb87933faf647bfa6a7c4d89bc91c8389a3dc71479e878d SHA512 b8f5f9be05aafe59aeb69462b7ccc9e5c4df8eb157731d888773f0ef223dc1c45db83daa51347b45dc3c59be5141c3fc4e031004ac28927b786d7e254ffff4fa
diff --git a/dev-python/pypng/files/pypng-0.0.20-py39.patch b/dev-python/pypng/files/pypng-0.0.20-py39.patch
deleted file mode 100644
index e4c738ee3137..000000000000
--- a/dev-python/pypng/files/pypng-0.0.20-py39.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From fe9c973c5e92f24746dfa1be8796c14a2befec4f Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Wed, 15 Jul 2020 07:54:53 +0200
-Subject: [PATCH] test_png: Use array.tobytes to fix py3.9 compatibility
-
-The deprecated array.tostring() method has been removed in Python 3.9.
-Use .tobytes() instead.
----
- code/test_png.py | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/code/test_png.py b/code/test_png.py
-index c858d18..447c314 100644
---- a/code/test_png.py
-+++ b/code/test_png.py
-@@ -448,13 +448,13 @@ class Test(unittest.TestCase):
- def test_interlaced_array(self):
- """Reading an interlaced PNG yields each row as an array."""
- r = png.Reader(bytes=pngsuite.basi0g08)
-- list(r.read()[2])[0].tostring
-+ list(r.read()[2])[0].tobytes
-
- def test_trns_array(self):
- """A type 2 PNG with tRNS chunk yields each row
- as an array (using asDirect)."""
- r = png.Reader(bytes=pngsuite.tbrn2c08)
-- list(r.asDirect()[2])[0].tostring
-+ list(r.asDirect()[2])[0].tobytes
-
- def test_flat(self):
- """Test read_flat."""
---
-2.27.0
-
diff --git a/dev-python/pypng/pypng-0.0.20.ebuild b/dev-python/pypng/pypng-0.0.20.ebuild
deleted file mode 100644
index 040f2abb119f..000000000000
--- a/dev-python/pypng/pypng-0.0.20.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{7..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Pure Python PNG image encoder/decoder"
-HOMEPAGE="https://github.com/drj11/pypng https://pypi.org/project/pypng/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 x86"
-
-PATCHES=(
- "${FILESDIR}"/${P}-py39.patch
-)
-
-python_test() {
- "${EPYTHON}" code/test_png.py -v || die "Tests fail with ${EPYTHON}"
-}