summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-11 05:10:40 +0000
committerSam James <sam@gentoo.org>2021-02-11 05:10:40 +0000
commitf069438fd0b1ddb0805ec770a1b05835389984e8 (patch)
tree217783582427909911a5c824f4ffda40adfac2d3 /dev-python/pyprof2calltree
parentapp-office/mdbtools: fix -Werror (diff)
downloadgentoo-f069438fd0b1ddb0805ec770a1b05835389984e8.tar.gz
gentoo-f069438fd0b1ddb0805ec770a1b05835389984e8.tar.bz2
gentoo-f069438fd0b1ddb0805ec770a1b05835389984e8.zip
dev-python/pyprof2calltree: bump to 1.4.5
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pyprof2calltree')
-rw-r--r--dev-python/pyprof2calltree/Manifest1
-rw-r--r--dev-python/pyprof2calltree/pyprof2calltree-1.4.5.ebuild19
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/pyprof2calltree/Manifest b/dev-python/pyprof2calltree/Manifest
index a7476c489766..8b4e28492409 100644
--- a/dev-python/pyprof2calltree/Manifest
+++ b/dev-python/pyprof2calltree/Manifest
@@ -1 +1,2 @@
DIST pyprof2calltree-1.4.4.tar.gz 8797 BLAKE2B 0929728d3a6de1cc40e54bd4581bb4b64875a4d7f3ccef725300d40d2b3fd175d8ff462591357e32a471e5c3a4c5c51ac7e9c81c2e857050745a748bc4117d8a SHA512 7ffc228e542a568cb421394035660623415495472b5b3659a35b02c7ccccb7f578dc872d2bb1daf4fdfcd44134e1ad9b5ce3a18f49b15dd4aeb3b5f1201a28d8
+DIST pyprof2calltree-1.4.5.tar.gz 8806 BLAKE2B 3a8a838a8b03294504c64dbe1d0caee2606a1ec53005222dfe6c3692bacd0801041ce199fedb9c38e4f6edc91e210116d9c1e034e0aa283cafebb19bf6303fed SHA512 2fcda74ae67dc3a8abb5dc153864ef59f96cc62b1c9359d02be12e83966c17738f5aa4a3d1c6e2ff81614dc963fc4b2faf375bbbb1ad15650a6817e493cdde39
diff --git a/dev-python/pyprof2calltree/pyprof2calltree-1.4.5.ebuild b/dev-python/pyprof2calltree/pyprof2calltree-1.4.5.ebuild
new file mode 100644
index 000000000000..5b5cbe820dbc
--- /dev/null
+++ b/dev-python/pyprof2calltree/pyprof2calltree-1.4.5.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="convert python profile data to kcachegrind calltree form"
+HOMEPAGE="https://pypi.org/project/pyprof2calltree/"
+# pypi tarball lacks tests
+SRC_URI="https://github.com/pwaller/pyprof2calltree/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests setup.py