summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-10-24 00:36:32 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-10-24 01:26:56 +0200
commitb4a9b0066dec41a195498410c1c907d15de441e7 (patch)
tree559f8953689c329a27f3b7da3e046d9f56e9e149 /dev-python/pyproj
parentsci-libs/shapely: python3_9, tests pass (diff)
downloadgentoo-b4a9b0066dec41a195498410c1c907d15de441e7.tar.gz
gentoo-b4a9b0066dec41a195498410c1c907d15de441e7.tar.bz2
gentoo-b4a9b0066dec41a195498410c1c907d15de441e7.zip
dev-python/pyproj: 2.6.1_p1 version bump, python3_9, tests pass
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-python/pyproj')
-rw-r--r--dev-python/pyproj/Manifest1
-rw-r--r--dev-python/pyproj/files/pyproj-2.6.1_p1-tests.patch58
-rw-r--r--dev-python/pyproj/pyproj-2.6.1_p1.ebuild52
3 files changed, 111 insertions, 0 deletions
diff --git a/dev-python/pyproj/Manifest b/dev-python/pyproj/Manifest
index 294e1a01904d..9ef79528f4d0 100644
--- a/dev-python/pyproj/Manifest
+++ b/dev-python/pyproj/Manifest
@@ -1 +1,2 @@
DIST pyproj-2.4.2.tar.gz 463252 BLAKE2B aa80ee3052f42f0d49d02b1dfa3d1790e02fe6aa4092319ff8e827b0a341cff2cb4779891f74919c2b14781d841b3662154882b5f218a22b55ad79397f3eb4a7 SHA512 20f0a742ea5699a6d7a621e93157512478de69ba740bb7b0df46b6d5668f6db93b07e1fc0bf4d089362275ea8edddf3100a972a533ed8b6a0bc56a04a20d4ef9
+DIST pyproj-2.6.1.post1.tar.gz 545482 BLAKE2B ba87cbbe93dad357c1fc4f333c7d3f02b632e6f2a00821b3875e73965f36fd7ea958f24705c125c3ae43dc8edac1b53a20578c46bc55bcbf335a9457d193d493 SHA512 43a885dbbf4ba54839c3b697d2582700e2b30172ef34acf6297b5e4ddba9b3148aeab83b3a515f1ce975898828c77ad457b6f6460e91083189f66a2fde6d77b7
diff --git a/dev-python/pyproj/files/pyproj-2.6.1_p1-tests.patch b/dev-python/pyproj/files/pyproj-2.6.1_p1-tests.patch
new file mode 100644
index 000000000000..69eb97ea2e04
--- /dev/null
+++ b/dev-python/pyproj/files/pyproj-2.6.1_p1-tests.patch
@@ -0,0 +1,58 @@
+From 5856cdacef62746594e17f69cb802a202d3fdfaa Mon Sep 17 00:00:00 2001
+From: "Alan D. Snow" <alansnow21@gmail.com>
+Date: Fri, 29 May 2020 07:41:44 -0500
+Subject: TST: Update tests with scope & remarks (#649)
+
+---
+ test/crs/test_crs.py | 16 +++++-----------
+ test/test_transformer.py | 10 +++++-----
+ 2 files changed, 10 insertions(+), 16 deletions(-)
+
+--- a/test/crs/test_crs.py
++++ b/test/crs/test_crs.py
+@@ -1261,17 +1261,11 @@ def test_operations():
+
+
+ def test_operations__scope_remarks():
+-
+- transformer = TransformerGroup(28356, 7856).transformers[0]
+- coord_op = CoordinateOperation.from_string(transformer.to_wkt())
+- assert coord_op.operations == transformer.operations
+- # scope does not transfer for some reason
+- # assert [op.scope for op in transformer.operations] == [
+- # op.scope for op in coord_op.operations
+- # ]
+- assert [op.remarks for op in transformer.operations] == [
+- op.remarks for op in coord_op.operations
+- ]
++ operation = TransformerGroup(28356, 7856).transformers[0].operations[1]
++ coord_op = CoordinateOperation.from_string(operation.to_wkt())
++ assert coord_op == operation
++ assert coord_op.remarks == operation.remarks
++ assert coord_op.scope == operation.scope
+
+
+ def test_crs_equals():
+--- a/test/test_transformer.py
++++ b/test/test_transformer.py
+@@ -536,15 +536,15 @@ def test_transformer__operations__scope_
+ transformer = TransformerGroup(28356, 7856).transformers[0]
+ assert transformer.scope is None
+ assert [op.scope for op in transformer.operations] == [
+- None,
++ "Large and medium scale topographic mapping and engineering survey.",
+ "Conformal transformation of GDA94 coordinates that have been derived through "
+ "GNSS CORS.",
+- None,
++ "Large and medium scale topographic mapping and engineering survey.",
+ ]
+- assert [str(op.remarks)[:5] for op in transformer.operations] == [
+- "None",
++ assert [str(op.remarks)[:5].strip() for op in transformer.operations] == [
++ "Grid",
+ "Scale",
+- "None",
++ "Grid",
+ ]
+
+
diff --git a/dev-python/pyproj/pyproj-2.6.1_p1.ebuild b/dev-python/pyproj/pyproj-2.6.1_p1.ebuild
new file mode 100644
index 000000000000..457c8d466c4f
--- /dev/null
+++ b/dev-python/pyproj/pyproj-2.6.1_p1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+inherit distutils-r1
+
+DESCRIPTION="Python interface to the PROJ library"
+HOMEPAGE="https://github.com/pyproj4/pyproj"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P/_p/.post}.tar.gz"
+
+S="${WORKDIR}/${P/_p/.post}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="doc"
+
+RDEPEND=">=sci-libs/proj-6.2.0:="
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/shapely[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ if has_version ">=sci-libs/proj-7.1"; then
+ eapply "${FILESDIR}"/${P}-tests.patch
+ fi
+ distutils-r1_python_prepare_all
+}
+
+distutils-r1_src_test() {
+ # workaround circular import error
+ # https://github.com/pyproj4/pyproj/issues/647
+ mkdir ../mytest || die
+ cp -r test ../mytest || die
+ cd ../mytest || die
+ _distutils-r1_run_foreach_impl python_test
+ _distutils-r1_run_foreach_impl _distutils-r1_clean_egg_info
+}
+
+python_test() {
+ PROJ_LIB="${EPREFIX}/usr/share/proj" pytest -ra || die
+}