summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-08-01 15:32:47 +0200
committerMichał Górny <mgorny@gentoo.org>2018-08-01 15:34:21 +0200
commitbd8453f541b60d86b5a64c8dd0becf34c64c6e01 (patch)
treeb8eefb09f1ed5dd22d458ef0c56eba2909664af7 /dev-python/pypy-bin
parentnet-im/err: version bump (diff)
downloadgentoo-bd8453f541b60d86b5a64c8dd0becf34c64c6e01.tar.gz
gentoo-bd8453f541b60d86b5a64c8dd0becf34c64c6e01.tar.bz2
gentoo-bd8453f541b60d86b5a64c8dd0becf34c64c6e01.zip
dev-python/pypy-bin: Disable more problematic tests
Bug: https://bugs.gentoo.org/637208
Diffstat (limited to 'dev-python/pypy-bin')
-rw-r--r--dev-python/pypy-bin/pypy-bin-6.0.0.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/dev-python/pypy-bin/pypy-bin-6.0.0.ebuild b/dev-python/pypy-bin/pypy-bin-6.0.0.ebuild
index 312b592c2706..2330fd7634d4 100644
--- a/dev-python/pypy-bin/pypy-bin-6.0.0.ebuild
+++ b/dev-python/pypy-bin/pypy-bin-6.0.0.ebuild
@@ -150,7 +150,18 @@ src_test() {
# (unset)
local -x PYTHONDONTWRITEBYTECODE=
- ./pypy-c ./pypy/test_all.py --pypy=./pypy-c -vv lib-python || die
+ local ignored_tests=(
+ # network
+ --ignore=lib-python/2.7/test/test_urllibnet.py
+ --ignore=lib-python/2.7/test/test_urllib2net.py
+ # lots of free space
+ --ignore=lib-python/2.7/test/test_zipfile64.py
+ # no module named 'worker' -- a lot
+ --ignore=lib-python/2.7/test/test_xpickle.py
+ )
+
+ ./pypy-c ./pypy/test_all.py --pypy=./pypy-c -vv \
+ "${ignored_tests[@]}" lib-python || die
}
src_install() {