summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-12-20 23:01:52 +0100
committerMichał Górny <mgorny@gentoo.org>2015-12-20 23:02:51 +0100
commit0dd2eb79f9fe0834698bc21203ad6c8969a10be1 (patch)
tree88224e56e87788fef548022a041d0d50e66d9735 /dev-python/pypy3/pypy3-9999.ebuild
parentapp-laptop/tp_smapi: Fix compilation (bug #492964) (diff)
downloadgentoo-0dd2eb79f9fe0834698bc21203ad6c8969a10be1.tar.gz
gentoo-0dd2eb79f9fe0834698bc21203ad6c8969a10be1.tar.bz2
gentoo-0dd2eb79f9fe0834698bc21203ad6c8969a10be1.zip
dev-python/pypy3: Add an updated distutils/C++ patch
Diffstat (limited to 'dev-python/pypy3/pypy3-9999.ebuild')
-rw-r--r--dev-python/pypy3/pypy3-9999.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-python/pypy3/pypy3-9999.ebuild b/dev-python/pypy3/pypy3-9999.ebuild
index a335b0f70a7b..73bd1594c24e 100644
--- a/dev-python/pypy3/pypy3-9999.ebuild
+++ b/dev-python/pypy3/pypy3-9999.ebuild
@@ -88,6 +88,11 @@ src_prepare() {
-e "s^@libdir@^$(get_libdir)^" \
-i lib-python/3/distutils/command/install.py || die
+ # apply CPython stdlib patches
+ pushd lib-python/3 > /dev/null || die
+ epatch "${FILESDIR}"/21_all_distutils_c++.patch
+ popd > /dev/null || die
+
epatch_user
}