summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-03-03 10:48:00 +0100
committerMichał Górny <mgorny@gentoo.org>2016-03-03 11:47:37 +0100
commit83eb744d8b60b3c911902999a40c0479823c271b (patch)
tree456d3bfd8e659c8399a403664c0ffc38127b18a2 /dev-python/pypy3/pypy3-9999.ebuild
parentdev-python/pypy3-bin: Add RDEPs to DEPEND, and subslots everywhere (diff)
downloadgentoo-83eb744d8b60b3c911902999a40c0479823c271b.tar.gz
gentoo-83eb744d8b60b3c911902999a40c0479823c271b.tar.bz2
gentoo-83eb744d8b60b3c911902999a40c0479823c271b.zip
dev-python/pypy3: Sync between release and live ebuild
Diffstat (limited to 'dev-python/pypy3/pypy3-9999.ebuild')
-rw-r--r--dev-python/pypy3/pypy3-9999.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-python/pypy3/pypy3-9999.ebuild b/dev-python/pypy3/pypy3-9999.ebuild
index 80507799ecbb..5f1b62c15d96 100644
--- a/dev-python/pypy3/pypy3-9999.ebuild
+++ b/dev-python/pypy3/pypy3-9999.ebuild
@@ -9,22 +9,24 @@ PYTHON_COMPAT=( python2_7 pypy )
EHG_PROJECT="pypy"
EHG_REPO_URI="https://bitbucket.org/pypy/pypy"
EHG_REVISION="py3k"
-inherit check-reqs eutils mercurial multilib multiprocessing pax-utils python-any-r1 toolchain-funcs versionator
+inherit check-reqs eutils mercurial multilib multiprocessing pax-utils \
+ python-any-r1 toolchain-funcs versionator
-DESCRIPTION="A fast, compliant alternative implementation of the Python language"
+DESCRIPTION="A fast, compliant alternative implementation of Python 3"
HOMEPAGE="http://pypy.org/"
SRC_URI=""
LICENSE="MIT"
SLOT="0/$(get_version_component_range 1-2 ${PV})"
KEYWORDS=""
-IUSE="bzip2 gdbm +jit low-memory ncurses sandbox +shadowstack sqlite cpu_flags_x86_sse2 test tk"
+IUSE="bzip2 gdbm +jit libressl low-memory ncurses sandbox +shadowstack sqlite cpu_flags_x86_sse2 tk"
RDEPEND=">=sys-libs/zlib-1.1.3:0=
virtual/libffi:0=
virtual/libintl:0=
dev-libs/expat:0=
- dev-libs/openssl:0=[-bindist]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
bzip2? ( app-arch/bzip2:0= )
gdbm? ( sys-libs/gdbm:0= )
ncurses? ( sys-libs/ncurses:0= )