summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-11 12:42:56 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-11 23:05:01 +0200
commit0605937f45b2f636fd675e53367279e4c54e85e1 (patch)
tree502bba0e05c419f61094c67c635f4ba30f44f60d /dev-python/pypy3
parentdev-python/pypy3-exe: Include pypy3.7 version (diff)
downloadgentoo-0605937f45b2f636fd675e53367279e4c54e85e1.tar.gz
gentoo-0605937f45b2f636fd675e53367279e4c54e85e1.tar.bz2
gentoo-0605937f45b2f636fd675e53367279e4c54e85e1.zip
dev-python/pypy3: Add PyPy3.7 version
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pypy3')
-rw-r--r--dev-python/pypy3/Manifest1
-rw-r--r--dev-python/pypy3/files/7.3.2-py37-distutils-cxx.patch314
-rw-r--r--dev-python/pypy3/pypy3-7.3.2_rc1-r100.ebuild352
3 files changed, 667 insertions, 0 deletions
diff --git a/dev-python/pypy3/Manifest b/dev-python/pypy3/Manifest
index 0b16f02d6f27..4d82772ad7bd 100644
--- a/dev-python/pypy3/Manifest
+++ b/dev-python/pypy3/Manifest
@@ -1,3 +1,4 @@
DIST pypy3.6-v7.3.0-src.tar.bz2 21937786 BLAKE2B c53ac32a9cca1c4624160eae9f11b5705a59613f1e5100fbb0ee86118de5a7845b8fa5087165d7f5a077d20337dfca14a1c7eadbe768995e20e249ec271ac10d SHA512 313a4254262dd8d8b995a50bddbc360cfb67add0818e51a3e9ce25bda6a9b639e9fea8efe7da6adda76dff0a86a364544a13faa516e51b9ea6c25ec99223b435
DIST pypy3.6-v7.3.1-src.tar.bz2 22712809 BLAKE2B 4250b3fe98c611b9635319c106b80e88ab469eab5f883babb738e175e7b7adc22c85f8ef3fdce1cdc127b521beef8d6c7862e188d8c8889c39f90136d6bbe374 SHA512 f8e32aae7f01225e0e4d6763eaac40fc02dffc3d0b6a30f22d422147f9be4f3290ea78160a912ffae311dea3d503eb31a7a4f3999d3b541fbccd93d1cef4ca56
DIST pypy3.6-v7.3.2rc1-src.tar.bz2 22730858 BLAKE2B 41a0702d0077c0f546998b858bc8b76226fe8903f4819497aa284231edcb32bc8b047b0a2a35bacfb18ea11fb85de98b95998276c22a3f0dc716b16871b35a3a SHA512 1a6f93f7e767b0db5c40c1e06cadd781c6ddfb02ec86aa61a37f649fe1aa5cd71f7857052e5b48092e3bf8b5cbef6d6401097bf4c4e80c62f7dbdffcd20b70c0
+DIST pypy3.7-v7.3.2rc1-src.tar.bz2 24805791 BLAKE2B 7b16ba9f0b33d572facdf009701712fe1b2c1eb5a4187c3a9197973ef4da140c7704b3409c7c336e1027f89df340fcefc9e52c6ccac75b251aa79d67c98e49c4 SHA512 d2a5c02a541c0ae79cf8c8e1a38299351f9dd81d1a17724d9fe346d8eb4311e2566a319cf1b8a90d393bffdc11657f6fa2f6475441634e57701b00e74899baa0
diff --git a/dev-python/pypy3/files/7.3.2-py37-distutils-cxx.patch b/dev-python/pypy3/files/7.3.2-py37-distutils-cxx.patch
new file mode 100644
index 000000000000..d126edacc6b9
--- /dev/null
+++ b/dev-python/pypy3/files/7.3.2-py37-distutils-cxx.patch
@@ -0,0 +1,314 @@
+diff --git a/lib-python/3/distutils/cygwinccompiler.py b/lib-python/3/distutils/cygwinccompiler.py
+index 6c5d777..640fa2d 100644
+--- a/lib-python/3/distutils/cygwinccompiler.py
++++ b/lib-python/3/distutils/cygwinccompiler.py
+@@ -125,8 +125,10 @@ class CygwinCCompiler(UnixCCompiler):
+ # dllwrap 2.10.90 is buggy
+ if self.ld_version >= "2.10.90":
+ self.linker_dll = "gcc"
++ self.linker_dll_cxx = "g++"
+ else:
+ self.linker_dll = "dllwrap"
++ self.linker_dll_cxx = "dllwrap"
+
+ # ld_version >= "2.13" support -shared so use it instead of
+ # -mdll -static
+@@ -140,9 +142,13 @@ class CygwinCCompiler(UnixCCompiler):
+ self.set_executables(compiler='gcc -mcygwin -O -Wall',
+ compiler_so='gcc -mcygwin -mdll -O -Wall',
+ compiler_cxx='g++ -mcygwin -O -Wall',
++ compiler_so_cxx='g++ -mcygwin -mdll -O -Wall',
+ linker_exe='gcc -mcygwin',
+ linker_so=('%s -mcygwin %s' %
+- (self.linker_dll, shared_option)))
++ (self.linker_dll, shared_option)),
++ linker_exe_cxx='g++ -mcygwin',
++ linker_so_cxx=('%s -mcygwin %s' %
++ (self.linker_dll_cxx, shared_option)))
+
+ # cygwin and mingw32 need different sets of libraries
+ if self.gcc_version == "2.91.57":
+@@ -166,8 +172,12 @@ class CygwinCCompiler(UnixCCompiler):
+ raise CompileError(msg)
+ else: # for other files use the C-compiler
+ try:
+- self.spawn(self.compiler_so + cc_args + [src, '-o', obj] +
+- extra_postargs)
++ if self.detect_language(src) == 'c++':
++ self.spawn(self.compiler_so_cxx + cc_args + [src, '-o', obj] +
++ extra_postargs)
++ else:
++ self.spawn(self.compiler_so + cc_args + [src, '-o', obj] +
++ extra_postargs)
+ except DistutilsExecError as msg:
+ raise CompileError(msg)
+
+@@ -302,9 +312,14 @@ class Mingw32CCompiler(CygwinCCompiler):
+ self.set_executables(compiler='gcc -O -Wall',
+ compiler_so='gcc -mdll -O -Wall',
+ compiler_cxx='g++ -O -Wall',
++ compiler_so_cxx='g++ -mdll -O -Wall',
+ linker_exe='gcc',
+ linker_so='%s %s %s'
+ % (self.linker_dll, shared_option,
++ entry_point),
++ linker_exe_cxx='g++',
++ linker_so_cxx='%s %s %s'
++ % (self.linker_dll_cxx, shared_option,
+ entry_point))
+ # Maybe we should also append -mthreads, but then the finished
+ # dlls need another dll (mingwm10.dll see Mingw32 docs)
+diff --git a/lib-python/3/distutils/sysconfig_cpython.py b/lib-python/3/distutils/sysconfig_cpython.py
+index 484721f..0088dd4 100644
+--- a/lib-python/3/distutils/sysconfig_cpython.py
++++ b/lib-python/3/distutils/sysconfig_cpython.py
+@@ -188,9 +188,13 @@ def customize_compiler(compiler):
+ _osx_support.customize_compiler(_config_vars)
+ _config_vars['CUSTOMIZED_OSX_COMPILER'] = 'True'
+
+- (cc, cxx, cflags, ccshared, ldshared, shlib_suffix, ar, ar_flags) = \
+- get_config_vars('CC', 'CXX', 'CFLAGS',
+- 'CCSHARED', 'LDSHARED', 'SHLIB_SUFFIX', 'AR', 'ARFLAGS')
++ (cc, cxx, ccshared, ldshared, ldcxxshared, shlib_suffix, ar, ar_flags) = \
++ get_config_vars('CC', 'CXX',
++ 'CCSHARED', 'LDSHARED', 'LDCXXSHARED',
++ 'SHLIB_SUFFIX', 'AR', 'ARFLAGS')
++
++ cflags = ''
++ cxxflags = ''
+
+ if 'CC' in os.environ:
+ newcc = os.environ['CC']
+@@ -205,19 +209,27 @@ def customize_compiler(compiler):
+ cxx = os.environ['CXX']
+ if 'LDSHARED' in os.environ:
+ ldshared = os.environ['LDSHARED']
++ if 'LDCXXSHARED' in os.environ:
++ ldcxxshared = os.environ['LDCXXSHARED']
+ if 'CPP' in os.environ:
+ cpp = os.environ['CPP']
+ else:
+ cpp = cc + " -E" # not always
+ if 'LDFLAGS' in os.environ:
+ ldshared = ldshared + ' ' + os.environ['LDFLAGS']
++ ldcxxshared = ldcxxshared + ' ' + os.environ['LDFLAGS']
+ if 'CFLAGS' in os.environ:
+- cflags = cflags + ' ' + os.environ['CFLAGS']
++ cflags = os.environ['CFLAGS']
+ ldshared = ldshared + ' ' + os.environ['CFLAGS']
++ if 'CXXFLAGS' in os.environ:
++ cxxflags = os.environ['CXXFLAGS']
++ ldcxxshared = ldcxxshared + ' ' + os.environ['CXXFLAGS']
+ if 'CPPFLAGS' in os.environ:
+ cpp = cpp + ' ' + os.environ['CPPFLAGS']
+ cflags = cflags + ' ' + os.environ['CPPFLAGS']
++ cxxflags = cxxflags + ' ' + os.environ['CPPFLAGS']
+ ldshared = ldshared + ' ' + os.environ['CPPFLAGS']
++ ldcxxshared = ldcxxshared + ' ' + os.environ['CPPFLAGS']
+ if 'AR' in os.environ:
+ ar = os.environ['AR']
+ if 'ARFLAGS' in os.environ:
+@@ -226,13 +238,17 @@ def customize_compiler(compiler):
+ archiver = ar + ' ' + ar_flags
+
+ cc_cmd = cc + ' ' + cflags
++ cxx_cmd = cxx + ' ' + cxxflags
+ compiler.set_executables(
+ preprocessor=cpp,
+ compiler=cc_cmd,
+ compiler_so=cc_cmd + ' ' + ccshared,
+- compiler_cxx=cxx,
++ compiler_cxx=cxx_cmd,
++ compiler_so_cxx=cxx_cmd + ' ' + ccshared,
+ linker_so=ldshared,
+ linker_exe=cc,
++ linker_so_cxx=ldcxxshared,
++ linker_exe_cxx=cxx,
+ archiver=archiver)
+
+ compiler.shared_lib_extension = shlib_suffix
+diff --git a/lib-python/3/distutils/sysconfig_pypy.py b/lib-python/3/distutils/sysconfig_pypy.py
+index bf1748e..70dfd72 100644
+--- a/lib-python/3/distutils/sysconfig_pypy.py
++++ b/lib-python/3/distutils/sysconfig_pypy.py
+@@ -145,36 +145,52 @@ def customize_compiler(compiler):
+ _osx_support.customize_compiler(_config_vars)
+ _config_vars['CUSTOMIZED_OSX_COMPILER'] = 'True'
+
+- (cc, cxx, opt, cflags, ccshared, ldshared, shlib_suffix, ar, ar_flags) = \
+- get_config_vars('CC', 'CXX', 'OPT', 'CFLAGS',
+- 'CCSHARED', 'LDSHARED', 'SHLIB_SUFFIX', 'AR', 'ARFLAGS')
++ (cc, cxx, ccshared, ldshared, ldcxxshared, shlib_suffix, ar, ar_flags) = \
++ get_config_vars('CC', 'CXX', 'CCSHARED', 'LDSHARED', 'LDCXXSHARED',
++ 'SHLIB_SUFFIX', 'AR', 'ARFLAGS')
++
++ cflags = ''
++ cxxflags = ''
+
+ if 'CC' in os.environ:
+ newcc = os.environ['CC']
+- if (sys.platform == 'darwin'
++ if (True
+ and 'LDSHARED' not in os.environ
+ and ldshared.startswith(cc)):
+ # On OS X, if CC is overridden, use that as the default
+ # command for LDSHARED as well
++ # Gentoo: s/OS X/every system/
+ ldshared = newcc + ldshared[len(cc):]
+ cc = newcc
+ if 'CXX' in os.environ:
+- cxx = os.environ['CXX']
++ newcxx = os.environ['CXX']
++ if ('LDCXXSHARED' not in os.environ
++ and ldcxxshared.startswith(cxx)):
++ ldcxxshared = newcxx + ldcxxshared[len(cxx):]
++ cxx = newcxx
+ if 'LDSHARED' in os.environ:
+ ldshared = os.environ['LDSHARED']
++ if 'LDCXXSHARED' in os.environ:
++ ldcxxshared = os.environ['LDCXXSHARED']
+ if 'CPP' in os.environ:
+ cpp = os.environ['CPP']
+ else:
+ cpp = cc + " -E" # not always
+ if 'LDFLAGS' in os.environ:
+ ldshared = ldshared + ' ' + os.environ['LDFLAGS']
++ ldcxxshared = ldcxxshared + ' ' + os.environ['LDFLAGS']
+ if 'CFLAGS' in os.environ:
+- cflags = opt + ' ' + os.environ['CFLAGS']
++ cflags = os.environ['CFLAGS']
+ ldshared = ldshared + ' ' + os.environ['CFLAGS']
++ if 'CXXFLAGS' in os.environ:
++ cxxflags = os.environ['CXXFLAGS']
++ ldcxxshared = ldcxxshared + ' ' + os.environ['CXXFLAGS']
+ if 'CPPFLAGS' in os.environ:
+ cpp = cpp + ' ' + os.environ['CPPFLAGS']
+ cflags = cflags + ' ' + os.environ['CPPFLAGS']
++ cxxflags = cxxflags + ' ' + os.environ['CPPFLAGS']
+ ldshared = ldshared + ' ' + os.environ['CPPFLAGS']
++ ldcxxshared = ldcxxshared + ' ' + os.environ['CPPFLAGS']
+ if 'AR' in os.environ:
+ ar = os.environ['AR']
+ if 'ARFLAGS' in os.environ:
+@@ -183,13 +199,17 @@ def customize_compiler(compiler):
+ archiver = ar + ' ' + ar_flags
+
+ cc_cmd = cc + ' ' + cflags
++ cxx_cmd = cxx + ' ' + cxxflags
+ compiler.set_executables(
+ preprocessor=cpp,
+ compiler=cc_cmd,
+ compiler_so=cc_cmd + ' ' + ccshared,
+- compiler_cxx=cxx,
++ compiler_cxx=cxx_cmd,
++ compiler_so_cxx=cxx_cmd + ' ' + ccshared,
+ linker_so=ldshared,
+ linker_exe=cc,
++ linker_so_cxx=ldcxxshared,
++ linker_exe_cxx=cxx,
+ archiver=archiver)
+
+ compiler.shared_lib_extension = shlib_suffix
+diff --git a/lib-python/3/distutils/unixccompiler.py b/lib-python/3/distutils/unixccompiler.py
+index 06fc718..c3773f0 100644
+--- a/lib-python/3/distutils/unixccompiler.py
++++ b/lib-python/3/distutils/unixccompiler.py
+@@ -52,14 +52,17 @@ class UnixCCompiler(CCompiler):
+ # are pretty generic; they will probably have to be set by an outsider
+ # (eg. using information discovered by the sysconfig about building
+ # Python extensions).
+- executables = {'preprocessor' : None,
+- 'compiler' : ["cc"],
+- 'compiler_so' : ["cc"],
+- 'compiler_cxx' : ["c++"], # pypy: changed, 'cc' is bogus
+- 'linker_so' : ["cc", "-shared"],
+- 'linker_exe' : ["cc"],
+- 'archiver' : ["ar", "-cr"],
+- 'ranlib' : None,
++ executables = {'preprocessor' : None,
++ 'compiler' : ["cc"],
++ 'compiler_so' : ["cc"],
++ 'compiler_cxx' : ["c++"],
++ 'compiler_so_cxx' : ["c++"],
++ 'linker_so' : ["cc", "-shared"],
++ 'linker_exe' : ["cc"],
++ 'linker_so_cxx' : ["c++", "-shared"],
++ 'linker_exe_cxx' : ["c++"],
++ 'archiver' : ["ar", "-cr"],
++ 'ranlib' : None,
+ }
+
+ if sys.platform[:6] == "darwin":
+@@ -125,12 +128,19 @@ class UnixCCompiler(CCompiler):
+
+ def _compile(self, obj, src, ext, cc_args, extra_postargs, pp_opts):
+ compiler_so = self.compiler_so
++ compiler_so_cxx = self.compiler_so_cxx
+ if sys.platform == 'darwin':
+ compiler_so = _osx_support.compiler_fixup(compiler_so,
+ cc_args + extra_postargs)
++ compiler_so_cxx = _osx_support.compiler_fixup(compiler_so_cxx,
++ cc_args + extra_postargs)
+ try:
+- self.spawn(compiler_so + cc_args + [src, '-o', obj] +
+- extra_postargs)
++ if self.detect_language(src) == 'c++':
++ self.spawn(compiler_so_cxx + cc_args + [src, '-o', obj] +
++ extra_postargs)
++ else:
++ self.spawn(compiler_so + cc_args + [src, '-o', obj] +
++ extra_postargs)
+ except DistutilsExecError as msg:
+ raise CompileError(msg)
+
+@@ -188,30 +198,16 @@ class UnixCCompiler(CCompiler):
+ ld_args.extend(extra_postargs)
+ self.mkpath(os.path.dirname(output_filename))
+ try:
+- if target_desc == CCompiler.EXECUTABLE:
+- linker = self.linker_exe[:]
++ if target_lang == "c++":
++ if target_desc == CCompiler.EXECUTABLE:
++ linker = self.linker_exe_cxx[:]
++ else:
++ linker = self.linker_so_cxx[:]
+ else:
+- linker = self.linker_so[:]
+- if target_lang == "c++" and self.compiler_cxx:
+- # skip over environment variable settings if /usr/bin/env
+- # is used to set up the linker's environment.
+- # This is needed on OSX. Note: this assumes that the
+- # normal and C++ compiler have the same environment
+- # settings.
+- i = 0
+- if os.path.basename(linker[0]) == "env":
+- i = 1
+- while '=' in linker[i]:
+- i += 1
+-
+- if os.path.basename(linker[i]) == 'ld_so_aix':
+- # AIX platforms prefix the compiler with the ld_so_aix
+- # script, so we need to adjust our linker index
+- offset = 1
++ if target_desc == CCompiler.EXECUTABLE:
++ linker = self.linker_exe[:]
+ else:
+- offset = 0
+-
+- linker[i+offset] = self.compiler_cxx[i]
++ linker = self.linker_so[:]
+
+ if sys.platform == 'darwin':
+ linker = _osx_support.compiler_fixup(linker, ld_args)
+diff --git a/lib_pypy/_sysconfigdata.py b/lib_pypy/_sysconfigdata.py
+index f1cca41..3ec5b4c 100644
+--- a/lib_pypy/_sysconfigdata.py
++++ b/lib_pypy/_sysconfigdata.py
+@@ -20,6 +20,7 @@ build_time_vars = {
+ 'CFLAGS': "-DNDEBUG -O2",
+ 'CCSHARED': "-fPIC",
+ 'LDSHARED': "cc -pthread -shared",
++ 'LDCXXSHARED': "c++ -pthread -shared",
+ 'EXT_SUFFIX': so_ext,
+ 'SHLIB_SUFFIX': ".so",
+ 'AR': "ar",
diff --git a/dev-python/pypy3/pypy3-7.3.2_rc1-r100.ebuild b/dev-python/pypy3/pypy3-7.3.2_rc1-r100.ebuild
new file mode 100644
index 000000000000..2ba33e2c40c3
--- /dev/null
+++ b/dev-python/pypy3/pypy3-7.3.2_rc1-r100.ebuild
@@ -0,0 +1,352 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+inherit pax-utils python-any-r1 toolchain-funcs
+
+MY_P=pypy3.7-v${PV/_/}
+
+DESCRIPTION="A fast, compliant alternative implementation of the Python (3.7) language"
+HOMEPAGE="https://pypy.org/"
+SRC_URI="https://downloads.python.org/pypy/${MY_P}-src.tar.bz2"
+S="${WORKDIR}/${MY_P}-src"
+
+LICENSE="MIT"
+# pypy3 -c 'import sysconfig; print(sysconfig.get_config_var("SOABI"))'
+SLOT="0/pypy37-pp73"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="bzip2 gdbm +jit libressl ncurses sqlite test tk"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ || (
+ dev-python/pypy3-exe:${PV}-py37[bzip2?,ncurses?]
+ dev-python/pypy3-exe-bin:${PV}-py37
+ )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ gdbm? ( sys-libs/gdbm:0= )
+ sqlite? ( dev-db/sqlite:3= )
+ tk? (
+ dev-lang/tk:0=
+ dev-tcltk/tix:0=
+ )
+ !<dev-python/pypy3-bin-7.3.0:0"
+DEPEND="${RDEPEND}
+ test? (
+ ${PYTHON_DEPS}
+ !!dev-python/pytest-forked
+ )"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ eapply "${FILESDIR}/7.3.1-gentoo-path.patch"
+ eapply "${FILESDIR}/1.9-distutils.unixccompiler.UnixCCompiler.runtime_library_dir_option.patch"
+ eapply "${FILESDIR}/7.3.2-py37-distutils-cxx.patch"
+
+ sed -e "s^@EPREFIX@^${EPREFIX}^" \
+ -i lib-python/3/distutils/command/install.py || die
+
+ # apply CPython stdlib patches
+ pushd lib-python/3 > /dev/null || die
+ eapply "${FILESDIR}"/python-3.5-distutils-OO-build.patch
+ popd > /dev/null || die
+
+ # see http://buildbot.pypy.org/summary?branch=py3.7&builder=pypy-c-jit-linux-x86-64
+ sed -i -e 's:test_snippets(:_&:' \
+ lib-python/3/test/test_ast.py || die
+ sed -i -e 's:testConstructorErrorMessages(:_&:' \
+ lib-python/3/test/test_class.py || die
+ sed -i -e 's:test_pythonmalloc(:_&:' \
+ -e 's:test_sys_flags_set(:_&:' \
+ -e 's:test_unbuffered_output(:_&:' \
+ -e 's:test_xdev(:_&:' \
+ -e 's:test_ignore_PYTHONHASHSEED(:_&:' \
+ lib-python/3/test/test_cmd_line.py || die
+ sed -i -e 's:test_consistent_sys_path_for_module_execution(:_&:' \
+ -e 's:test_issue8202(:_&:' \
+ -e 's:test_issue8202_dash_m_file_ignored(:_&:' \
+ -e 's:test_module_in_package(:_&:' \
+ -e 's:test_module_in_package_in_zipfile(:_&:' \
+ -e 's:test_module_in_subpackage_in_zipfile(:_&:' \
+ -e 's:test_nonexisting_script(:_&:' \
+ -e 's:test_package(:_&:' \
+ -e 's:test_package_compiled(:_&:' \
+ -e 's:test_script_compiled(:_&:' \
+ lib-python/3/test/test_cmd_line_script.py || die
+ sed -i -e 's:test_incremental_errors(:_&:' \
+ lib-python/3/test/test_codecs.py || die
+ sed -i -e 's:test_ressources_gced_in_workers(:_&:' \
+ -e 's:test_submit_after_interpreter_shutdown(:_&:' \
+ lib-python/3/test/test_concurrent_futures.py || die
+ sed -i -e 's:test_for_3(:_&:' \
+ -e 's:test_func_4(:_&:' \
+ lib-python/3/test/test_coroutines.py || die
+ sed -i -e 's:test_strftime(:_&:' \
+ -e 's:test_more_strftime(:_&:' \
+ lib-python/3/test/datetimetester.py || die
+ sed -i -e 's:test_info(:_&:' \
+ -e 's:test_code_info(:_&:' \
+ -e 's:test_show_code(:_&:' \
+ -e 's:test_disassemble_recursive(:_&:' \
+ -e 's:test_disassemble_str(:_&:' \
+ -e 's:test_jumpy(:_&:' \
+ lib-python/3/test/test_dis.py || die
+ sed -i -e 's:test_generator_doesnt_retain_old_exc2(:_&:' \
+ -e 's:test_attributes(:_&:' \
+ lib-python/3/test/test_exceptions.py || die
+ sed -i -e 's:test_frozen(:_&:' \
+ lib-python/3/test/test_frozen.py || die
+ sed -i -e 's:test_ssl_raises(:_&:' \
+ -e 's:test_ssl_verified(:_&:' \
+ lib-python/3/test/test_imaplib.py || die
+ sed -i -e 's:test_script_compiled(:_&:' \
+ lib-python/3/test/test_multiprocessing_main_handling.py || die
+ sed -i -e 's:test_execve_invalid_env(:_&:' \
+ lib-python/3/test/test_os.py || die
+ sed -i -e 's:test_get_and_set_scheduler_and_param(:_&:' \
+ lib-python/3/test/test_posix.py || die
+ sed -i -e 's:test_copying(:_&:' \
+ -e 's:test_re_split(:_&:' \
+ -e 's:test_zerowidth(:_&:' \
+ -e 's:test_locale_caching(:_&:' \
+ -e 's:test_locale_compiled(:_&:' \
+ -e 's:test_match_repr(:_&:' \
+ -e 's:test_qualified_re_split(:_&:' \
+ -e 's:test_scoped_flags(:_&:' \
+ lib-python/3/test/test_re.py || die
+ sed -i -e 's:test_auto_history_disabled(:_&:' \
+ -e 's:test_auto_history_enabled(:_&:' \
+ -e 's:test_history_size(:_&:' \
+ lib-python/3/test/test_readline.py || die
+ sed -i -e 's:test_multiprocess(:_&:' \
+ lib-python/3/test/test_regrtest.py || die
+ sed -i -e 's:test_warn_on_full_buffer(:_&:' \
+ lib-python/3/test/test_signal.py || die
+ sed -i -e 's:test_get_path(:_&:' \
+ lib-python/3/test/test_site.py || die
+ sed -i -e 's:test_check_hostname(:_&:' \
+ -e 's:test_npn_protocols(:_&:' \
+ -e 's:test_sni_callback(:_&:' \
+ -e 's:test_sni_callback_raising(:_&:' \
+ lib-python/3/test/test_ssl.py || die
+ sed -i -e 's:test_invalid_placeholders(:_&:' \
+ lib-python/3/test/test_string.py || die
+ sed -i -e 's:test_eval_bytes_invalid_escape(:_&:' \
+ -e 's:test_eval_str_invalid_escape(:_&:' \
+ lib-python/3/test/test_string_literals.py || die
+ sed -i -e 's:test_boundary_error_message_with_large_offset(:_&:' \
+ lib-python/3/test/test_struct.py || die
+ sed -i -e 's:test_restore_signals(:_&:' \
+ lib-python/3/test/test_subprocess.py || die
+ sed -i -e 's:test_jump_out_of_async_for_block_backwards(:_&:' \
+ -e 's:test_jump_out_of_async_for_block_forwards(:_&:' \
+ -e 's:test_jump_over_async_for_block_before_else(:_&:' \
+ -e 's:test_no_jump_backwards_into_async_for_block(:_&:' \
+ -e 's:test_no_jump_forwards_into_async_for_block(:_&:' \
+ -e 's:test_no_jump_into_async_for_block_before_else(:_&:' \
+ -e 's:test_no_jump_from_yield(:_&:' \
+ lib-python/3/test/test_sys_settrace.py || die
+ sed -i -e 's:test_install_schemes(:_&:' \
+ lib-python/3/test/test_sysconfig_pypy.py || die
+ sed -i -e 's:test_circular_imports(:_&:' \
+ lib-python/3/test/test_threaded_import.py || die
+ sed -i -e 's:test_main_milliseconds(:_&:' \
+ -e 's:test_main_verbose(:_&:' \
+ -e 's:test_main_very_verbose(:_&:' \
+ -e 's:test_main_with_time_unit(:_&:' \
+ lib-python/3/test/test_timeit.py || die
+ sed -i -e 's:test_cannot_subclass(:_&:' \
+ lib-python/3/test/test_typing.py || die
+ sed -i -e 's:test_warnings(:_&:' \
+ lib-python/3/unittest/test/test_runner.py || die
+ sed -i -e 's:test_cmd_line(:_&:' \
+ -e 's:test_env_var(:_&:' \
+ -e 's:test_locale_getpreferredencoding(:_&:' \
+ -e 's:test_posix_locale(:_&:' \
+ -e 's:test_stdio(:_&:' \
+ -e 's:test_xoption(:_&:' \
+ lib-python/3/test/test_utf8_mode.py || die
+ sed -i -e 's:test_asyncgen_finalization_by_gc(:_&:' \
+ -e 's:test_asyncgen_finalization_by_gc_in_other_thread(:_&:' \
+ -e 's:test_create_connection_ipv6_scope(:_&:' \
+ lib-python/3/test/test_asyncio/test_base_events.py || die
+ sed -i -e 's:test_buffered_proto_create_connection(:_&:' \
+ lib-python/3/test/test_asyncio/test_buffered_proto.py || die
+ sed -i -e 's:test_create_connection_memory_leak(:_&:' \
+ -e 's:test_handshake_timeout(:_&:' \
+ -e 's:test_start_tls_client_reg_proto_1(:_&:' \
+ lib-python/3/test/test_asyncio/test_sslproto.py || die
+ sed -i -e 's:test_bare_create_task(:_&:' \
+ -e 's:test_current_task(:_&:' \
+ lib-python/3/test/test_asyncio/test_tasks.py || die
+ sed -i -e 's:test_asyncio_task_decimal_context(:_&:' \
+ lib-python/3/test/test_asyncio/test_context.py || die
+ sed -i -e 's:test_create_server_ssl_match_failed(:_&:' \
+ lib-python/3/test/test_asyncio/test_events.py || die
+ sed -i -e 's:test_binding(:_&:' \
+ -e 's:test_from_import_AttributeError(:_&:' \
+ -e 's:test_from_import_missing_attr_has_name_and_path(:_&:' \
+ -e 's:test_from_import_missing_attr_path_is_canonical(:_&:' \
+ lib-python/3/test/test_import/__init__.py || die
+ sed -i -e 's:test_unrelated_contents(:_&:' \
+ -e 's:test_contents(:_&:' \
+ -e 's:test_submodule_contents(:_&:' \
+ -e 's:test_submodule_contents_by_name(:_&:' \
+ -e 's:test_is_resource_good_path(:_&:' \
+ -e 's:test_is_submodule_resource(:_&:' \
+ -e 's:test_read_submodule_resource_by_name(:_&:' \
+ lib-python/3/test/test_importlib/test_resource.py || die
+ sed -i -e 's:test_non_string_keys_dict(:_&:' \
+ lib-python/3/test/test_json/test_fail.py || die
+ sed -i -e 's:test_module(:_&:' \
+ lib-python/3/test/test_warnings/__init__.py || die
+
+ # flaky
+ sed -i -e 's:test_2_join_in_forked_process(:_&:' \
+ lib-python/3/test/test_threading.py || die
+
+ # TODO
+ sed -i -e 's:test_external_target_locale_configuration(:_&:' \
+ lib-python/3/test/test_c_locale_coercion.py || die
+ sed -i -e 's:test_locale(:_&:' \
+ lib-python/3/test/test_format.py || die
+ sed -i -e 's:test_decompressor_bug_28275(:_&:' \
+ lib-python/3/test/test_lzma.py || die
+ sed -i -e 's:test_wrapped_exception:_&:' \
+ lib-python/3/test/_test_multiprocessing.py || die
+ sed -i -e 's:test_https_sni(:_&:' \
+ lib-python/3/test/test_urllib2_localnet.py || die
+
+ # the first one's broken by sandbox, the second by our env
+ sed -i -e 's:test_executable(:_&:' \
+ -e 's:test_executable_without_cwd(:_&:' \
+ lib-python/3/test/test_subprocess.py || die
+
+ eapply_user
+}
+
+src_configure() {
+ tc-export CC
+}
+
+src_compile() {
+ # copy over to make sys.prefix happy
+ cp -p "${BROOT}"/usr/lib/pypy3.7/pypy3-c-${PV} pypy3-c || die
+ cp -p "${BROOT}"/usr/lib/pypy3.7/include/${PV}/* include/ || die
+ # (not installed by pypy)
+ rm pypy/module/cpyext/include/_numpypy/numpy/README || die
+ mv pypy/module/cpyext/include/* include/ || die
+ mv pypy/module/cpyext/parse/*.h include/ || die
+ pax-mark m pypy3-c
+
+ einfo "Generating caches and CFFI modules ..."
+
+ # Generate Grammar and PatternGrammar pickles.
+ ./pypy3-c -c "import lib2to3.pygram, lib2to3.patcomp; lib2to3.patcomp.PatternCompiler()" \
+ || die "Generation of Grammar and PatternGrammar pickles failed"
+
+ # Generate cffi modules
+ # Please keep in sync with pypy/tool/build_cffi_imports.py!
+#cffi_build_scripts = {
+# "_blake2": "_blake2/_blake2_build.py",
+# "_ssl": "_ssl_build.py",
+# "sqlite3": "_sqlite3_build.py",
+# "audioop": "_audioop_build.py",
+# "tk": "_tkinter/tklib_build.py",
+# "curses": "_curses_build.py" if sys.platform != "win32" else None,
+# "syslog": "_syslog_build.py" if sys.platform != "win32" else None,
+# "gdbm": "_gdbm_build.py" if sys.platform != "win32" else None,
+# "pwdgrp": "_pwdgrp_build.py" if sys.platform != "win32" else None,
+# "resource": "_resource_build.py" if sys.platform != "win32" else None,
+# "lzma": "_lzma_build.py",
+# "_decimal": "_decimal_build.py",
+# "_sha3": "_sha3/_sha3_build.py",
+ cffi_targets=( blake2/_blake2 sha3/_sha3 ssl
+ audioop syslog pwdgrp resource lzma decimal )
+ use gdbm && cffi_targets+=( gdbm )
+ use ncurses && cffi_targets+=( curses )
+ use sqlite && cffi_targets+=( sqlite3 )
+ use tk && cffi_targets+=( tkinter/tklib )
+
+ local t
+ # all modules except tkinter output to .
+ # tkinter outputs to the correct dir ...
+ cd lib_pypy || die
+ for t in "${cffi_targets[@]}"; do
+ # tkinter doesn't work via -m
+ ../pypy3-c "_${t}_build.py" || die "Failed to build CFFI bindings for ${t}"
+ done
+
+ # Cleanup temporary objects
+ find -name "_cffi_*.[co]" -delete || die
+ find -type d -empty -delete || die
+}
+
+src_test() {
+ # (unset)
+ local -x PYTHONDONTWRITEBYTECODE=
+ local -x COLUMNS=80
+
+ local ignore=(
+ # failing doctests
+ lib-python/3/test/test_extcall.py
+ lib-python/3/test/test_unpack_ex.py
+
+ # segfault
+ lib-python/3/test/test_capi.py
+ )
+
+ # Test runner requires Python 2 too. However, it spawns PyPy3
+ # internally so that we end up testing the correct interpreter.
+ # (--deselect for failing doctests)
+ "${EPYTHON}" ./pypy/test_all.py --pypy=./pypy3-c -vv lib-python \
+ ${ignore[@]/#/--ignore } || die
+}
+
+src_install() {
+ local dest=/usr/lib/pypy3.7
+ einfo "Installing PyPy ..."
+ dosym pypy3-c-${PV} "${dest}/pypy3-c"
+ insinto "${dest}"
+ # preserve mtimes to avoid obsoleting caches
+ insopts -p
+ doins -r include lib_pypy lib-python
+
+ # replace copied headers with symlinks
+ for x in "${BROOT}"/usr/lib/pypy3.7/include/${PV}/*; do
+ dosym "${PV}/${x##*/}" "${dest}/include/${x##*/}"
+ done
+
+ dosym ../lib/pypy3.7/pypy3-c /usr/bin/pypy3
+ dodoc README.rst
+
+ if ! use gdbm; then
+ rm -r "${ED}${dest}"/lib_pypy/_gdbm* || die
+ fi
+ if ! use sqlite; then
+ rm -r "${ED}${dest}"/lib-python/*3/sqlite3 \
+ "${ED}${dest}"/lib_pypy/_sqlite3* \
+ "${ED}${dest}"/lib-python/*3/test/test_sqlite.py || die
+ fi
+ if ! use tk; then
+ rm -r "${ED}${dest}"/lib-python/*3/{idlelib,tkinter} \
+ "${ED}${dest}"/lib_pypy/_tkinter \
+ "${ED}${dest}"/lib-python/*3/test/test_{tcl,tk,ttk*}.py || die
+ fi
+
+ local -x EPYTHON=pypy3
+ local -x PYTHON=${ED}${dest}/pypy3-c
+
+ echo "EPYTHON='${EPYTHON}'" > epython.py || die
+ python_moduleinto /usr/lib/pypy3.7/site-packages
+ python_domodule epython.py
+
+ einfo "Byte-compiling Python standard library..."
+ python_optimize "${ED}${dest}"
+}