summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-11 11:08:43 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-11 13:16:01 +0100
commit6c104eebf1e8f665bca793929ca04b2d4849c102 (patch)
tree26f95df79405a4aa19b7fdb2ca85d66402fb712b /dev-python/pypy3
parentdev-python/pypy3-exe: Bump to 7.3.8_rc2 (diff)
downloadgentoo-6c104eebf1e8f665bca793929ca04b2d4849c102.tar.gz
gentoo-6c104eebf1e8f665bca793929ca04b2d4849c102.tar.bz2
gentoo-6c104eebf1e8f665bca793929ca04b2d4849c102.zip
dev-python/pypy3: Bump to 7.3.8_rc2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pypy3')
-rw-r--r--dev-python/pypy3/Manifest2
-rw-r--r--dev-python/pypy3/pypy3-7.3.8_rc2.ebuild183
2 files changed, 185 insertions, 0 deletions
diff --git a/dev-python/pypy3/Manifest b/dev-python/pypy3/Manifest
index 37f0889ae7d2..4bb8feec81bf 100644
--- a/dev-python/pypy3/Manifest
+++ b/dev-python/pypy3/Manifest
@@ -3,4 +3,6 @@ DIST pypy3.8-v7.3.7-src.tar.bz2 24375444 BLAKE2B 44fe19ee63d95243c499ecb0b84e778
DIST pypy3.9-gentoo-patches-7.3.8rc1_p1.tar.xz 1720 BLAKE2B 2d72eca8525104753f67db2c55ea799c24dee1969b484f1d1cb7fb3295924a9980aa84cdf1a6045ee463a64f68893dfb4e0f161fe4e3f210a5976283a09e1e48 SHA512 1c87301fad10764b754bc852cf7216b58792a2583026bef05e6ea278ea941486cffd36eec810af2e56f99c8ed9f56e7f08b42d8bc03bd3c5d55b044411da0beb
DIST pypy3.9-gentoo-patches-7.3.8rc1_p2.tar.xz 7252 BLAKE2B 9d7b908f8506053600694dd9e00aac4cbed9a999935a3468309103070930972751b0838eb5fc15063895f3090815aeef7e7603d5f9e21a99b65f658ccb1592e0 SHA512 c699d11e3342ef0f2ee3a5ccbb6a18a6f7ecd5513b553f1c2b0cb0aea59992603c360cf9b995a0146e08f43ff71483d94bf117a5cddbe7e83b0fadc9eafd03b7
DIST pypy3.9-gentoo-patches-7.3.8rc1_p3.tar.xz 7960 BLAKE2B 195e2f581e16f97701848efa5fd11d7852ffedfd4c2a0d3b0948f7b43440a3b45823c0a38af04dad68789a9cc0f9f023d3d5e4754d8f7469c40a4717fd3276cb SHA512 539bf4785722ba1ef5e13c9705ba9cbc60dff12190b0cc5fd8253bda51304c399aefe3b725685a7a98a9d798c3561f28351ef1087b5bc26377ffb485b588497e
+DIST pypy3.9-gentoo-patches-7.3.8rc2.tar.xz 1568 BLAKE2B 983ccd0d7482a4542cf2cc7d66b5c515051cd9bdcc43b56ca932ddd7fe15b13d097f0257108fb82ef2619f468fcaa2e549be0ae115ac2635e867206f1d0a4431 SHA512 a8a9e477563d5bb64c7f1f401645f783f66e0a338e6ae44f4e5a5c11152ebca1232f0ce14270f6087b855137f00ba2dc57bfcccb4935eb5fb50c34e7791bb3a7
DIST pypy3.9-v7.3.8rc1-src.tar.bz2 26254113 BLAKE2B fb4eca88080eee91d4ec8886abb484de11997c73d5b60c5f9acab7cd7b8cbc9d80190608bb905d82b6bcd1bbf602b6afc53257c9263458fc51a2b5f32510a164 SHA512 d1b1942fbacc7f8d642c85ceb4c4c9796e73bd5836615e2db81f4ddabf9e4f94c230f2d946ea9c49b642d41304aeed3906df1931a52ec40c56d14f1028139978
+DIST pypy3.9-v7.3.8rc2-src.tar.bz2 26277719 BLAKE2B 7853d30983e43e20ee90af9a380c0c368c7d4cc0fd58c7e4ff3db80bffabdfefb7cb31a2d39e00f99ff0f34f23be77b9d7302926baa30a348c1ffde52f641937 SHA512 40fc0dd45bf24bc9a1bfa259bce11ee706ac73dd29f66a3e2a16bb9ca5c6683d4aedaf21394875ab3facb31eb65f4d497eaa3c10ef4394251ecb4b4a85511197
diff --git a/dev-python/pypy3/pypy3-7.3.8_rc2.ebuild b/dev-python/pypy3/pypy3-7.3.8_rc2.ebuild
new file mode 100644
index 000000000000..a08c44184921
--- /dev/null
+++ b/dev-python/pypy3/pypy3-7.3.8_rc2.ebuild
@@ -0,0 +1,183 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python2_7 )
+inherit pax-utils python-any-r1 toolchain-funcs
+
+PYPY_PV=${PV%_p*}
+MY_P=pypy3.9-v${PYPY_PV/_rc/rc}
+PATCHSET="pypy3.9-gentoo-patches-${PV/_rc/rc}"
+
+DESCRIPTION="A fast, compliant alternative implementation of the Python (3.9) language"
+HOMEPAGE="https://www.pypy.org/"
+SRC_URI="https://buildbot.pypy.org/pypy/${MY_P}-src.tar.bz2
+ https://dev.gentoo.org/~mgorny/dist/python/${PATCHSET}.tar.xz"
+S="${WORKDIR}/${MY_P}-src"
+
+LICENSE="MIT"
+# pypy3 -c 'import sysconfig; print(sysconfig.get_config_var("SOABI"))'
+# also check pypy/interpreter/pycode.py -> pypy_incremental_magic
+SLOT="0/pypy39-pp73"
+KEYWORDS=""
+IUSE="bzip2 gdbm +jit ncurses sqlite test tk"
+# many tests are failing upstream
+# see https://buildbot.pypy.org/summary?branch=py3.9
+RESTRICT="test"
+
+RDEPEND="
+ || (
+ >=dev-python/pypy3-exe-${PYPY_PV}:3.9-${PYPY_PV}[bzip2?,ncurses?]
+ >=dev-python/pypy3-exe-bin-${PYPY_PV}:3.9-${PYPY_PV}
+ )
+ dev-lang/python-exec[python_targets_pypy3(-)]
+ dev-libs/openssl:0=
+ gdbm? ( sys-libs/gdbm:0= )
+ sqlite? ( dev-db/sqlite:3= )
+ tk? (
+ dev-lang/tk:0=
+ dev-tcltk/tix:0=
+ )
+ !<dev-python/pypy3-bin-7.3.0:0"
+DEPEND="${RDEPEND}
+ test? (
+ ${PYTHON_DEPS}
+ !!dev-python/pytest-forked
+ )"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ local PATCHES=(
+ "${WORKDIR}/${PATCHSET}"
+ )
+ default
+
+ eapply_user
+}
+
+src_configure() {
+ tc-export CC
+}
+
+src_compile() {
+ mkdir bin || die
+ # switch to the layout expected for cffi module builds
+ mkdir include/pypy3.9 || die
+ # copy over to make sys.prefix happy
+ cp -p "${BROOT}"/usr/bin/pypy3.9-c-${PYPY_PV} pypy3.9-c || die
+ cp -p "${BROOT}"/usr/include/pypy3.9/${PYPY_PV}/* include/pypy3.9/ || die
+ # (not installed by pypy-exe)
+ rm pypy/module/cpyext/include/_numpypy/numpy/README || die
+ mv pypy/module/cpyext/include/* include/pypy3.9/ || die
+ mv pypy/module/cpyext/parse/*.h include/pypy3.9/ || die
+ pax-mark m pypy3.9-c
+
+ # verify the subslot
+ local soabi=$(./pypy3.9-c -c 'import sysconfig; print(sysconfig.get_config_var("SOABI"))')
+ [[ ${soabi} == ${SLOT#*/} ]] || die "update subslot to ${soabi}"
+
+ einfo "Generating caches and CFFI modules ..."
+
+ # Generate Grammar and PatternGrammar pickles.
+ ./pypy3.9-c -c "import lib2to3.pygram, lib2to3.patcomp; lib2to3.patcomp.PatternCompiler()" \
+ || die "Generation of Grammar and PatternGrammar pickles failed"
+
+ # Generate cffi modules
+ # Please keep in sync with pypy/tool/build_cffi_imports.py!
+ # (NB: we build CFFI modules first to avoid error log when importing
+ # build_cffi_imports).
+ cffi_targets=( pypy_util blake2/_blake2 sha3/_sha3 ssl
+ audioop syslog pwdgrp resource lzma posixshmem )
+ use gdbm && cffi_targets+=( gdbm )
+ use ncurses && cffi_targets+=( curses )
+ use sqlite && cffi_targets+=( sqlite3 )
+ use tk && cffi_targets+=( tkinter/tklib )
+
+ local t
+ # all modules except tkinter output to .
+ # tkinter outputs to the correct dir ...
+ cd lib_pypy || die
+ for t in "${cffi_targets[@]}"; do
+ # tkinter doesn't work via -m
+ ../pypy3.9-c "_${t}_build.py" || die "Failed to build CFFI bindings for ${t}"
+ done
+
+ # Verify that CFFI module list is up-to-date
+ local expected_cksum=63d4659f
+ local local_cksum=$(../pypy3.9-c -c '
+from pypy_tools.build_cffi_imports import cffi_build_scripts as x;
+import binascii, json;
+print("%08x" % (binascii.crc32(json.dumps(x).encode()),))')
+ if [[ ${local_cksum} != ${expected_cksum} ]]; then
+ die "Please verify cffi_targets and update checksum to ${local_cksum}"
+ fi
+
+ # Cleanup temporary objects
+ find -name "*_cffi.[co]" -delete || die
+ find -type d -empty -delete || die
+}
+
+src_test() {
+ # (unset)
+ local -x PYTHONDONTWRITEBYTECODE=
+ local -x COLUMNS=80
+
+ # Test runner requires Python 2 too. However, it spawns PyPy3
+ # internally so that we end up testing the correct interpreter.
+ # (--deselect for failing doctests)
+ "${EPYTHON}" ./pypy/test_all.py --pypy=./pypy3.9-c -vv lib-python || die
+}
+
+src_install() {
+ einfo "Installing PyPy ..."
+ dodir /usr/bin
+ dosym pypy3.9-c-${PYPY_PV} /usr/bin/pypy3.9
+ dosym pypy3.9 /usr/bin/pypy3
+ insinto /usr/lib/pypy3.9
+ # preserve mtimes to avoid obsoleting caches
+ insopts -p
+ doins -r lib-python/3/. lib_pypy/.
+ insinto /usr/include
+ doins -r include/pypy3.9
+
+ # replace copied headers with symlinks
+ for x in "${BROOT}"/usr/include/pypy3.9/${PYPY_PV}/*; do
+ dosym "${PYPY_PV}/${x##*/}" "/usr/include/pypy3.9/${x##*/}"
+ done
+
+ dodoc README.rst
+
+ local dest=/usr/lib/pypy3.9
+ if ! use gdbm; then
+ rm -r "${ED}${dest}"/_gdbm* || die
+ fi
+ if ! use sqlite; then
+ rm -r "${ED}${dest}"/sqlite3 \
+ "${ED}${dest}"/_sqlite3* \
+ "${ED}${dest}"/test/test_sqlite.py || die
+ fi
+ if ! use tk; then
+ rm -r "${ED}${dest}"/{idlelib,tkinter} \
+ "${ED}${dest}"/_tkinter \
+ "${ED}${dest}"/test/test_{tcl,tk,ttk*}.py || die
+ fi
+
+ local -x EPYTHON=pypy3
+ local -x PYTHON=${ED}/usr/bin/pypy3.9-c-${PYPY_PV}
+ # temporarily copy to build tree to facilitate module builds
+ cp -p "${BROOT}/usr/bin/pypy3.9-c-${PYPY_PV}" "${PYTHON}" || die
+
+ echo "EPYTHON='${EPYTHON}'" > epython.py || die
+ python_moduleinto "${dest}"/site-packages
+ python_domodule epython.py
+
+ einfo "Byte-compiling Python standard library..."
+ python_optimize "${ED}${dest}"
+
+ # remove to avoid collisions
+ rm "${PYTHON}" || die
+}