summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Gillespie <tgbugs@gmail.com>2020-08-02 01:38:19 -0700
committerMichał Górny <mgorny@gentoo.org>2020-08-02 11:35:01 +0200
commitae017fcc14207aadf50344392d7d869e7ef1eb53 (patch)
tree46da3b35d58334bf0c22ea7c2853848c84e87477 /dev-python/pypy3
parentdev-python/pypy: fix gentoo-path.patch and rev bump (diff)
downloadgentoo-ae017fcc14207aadf50344392d7d869e7ef1eb53.tar.gz
gentoo-ae017fcc14207aadf50344392d7d869e7ef1eb53.tar.bz2
gentoo-ae017fcc14207aadf50344392d7d869e7ef1eb53.zip
dev-python/pypy3: fix gentoo-path.patch and rev bump
Test that install_path starts with '/usr/lib/pypy' instead of doing an exact equality == test against the specific pypy version. This will allow the patch to be reused between pypy and pypy3 without the risk of having the gentoo specific fix fail to be detected due to a mismatched pypy version number. This also prevents the need to maintain an exact match the pypy version in the future since it will continue to change and I assume there is also the possibility that both pypy3.6 and pypy3.7 might be installed on the same system at the same time. Also rev bump so that users will recieve the fix. This also removes a blocker for https://bugs.gentoo.org/729958 and https://github.com/gentoo/gentoo/pull/16466. Closes: https://bugs.gentoo.org/735140 Related-to: https://bugs.gentoo.org/729958 Signed-off-by: Tom Gillespie <tgbugs@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/16943 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pypy3')
-rw-r--r--dev-python/pypy3/files/7.3.1-gentoo-path.patch2
-rw-r--r--dev-python/pypy3/pypy3-7.3.1-r2.ebuild (renamed from dev-python/pypy3/pypy3-7.3.1-r1.ebuild)0
2 files changed, 1 insertions, 1 deletions
diff --git a/dev-python/pypy3/files/7.3.1-gentoo-path.patch b/dev-python/pypy3/files/7.3.1-gentoo-path.patch
index c9809f89b880..fba00b9fcac3 100644
--- a/dev-python/pypy3/files/7.3.1-gentoo-path.patch
+++ b/dev-python/pypy3/files/7.3.1-gentoo-path.patch
@@ -30,7 +30,7 @@ index 6fe62be..a4e9f0d 100644
if (hasattr(sys, 'pypy_version_info') and
not name.endswith(('_user', '_home'))):
- if os.name == 'nt':
-+ if self.install_base == os.path.normpath('@EPREFIX@/usr/lib/pypy2.7'):
++ if self.install_base.startswith(os.path.normpath('@EPREFIX@/usr/lib/pypy')):
+ # override paths for system-wide install
+ name = 'gentoo'
+ elif os.name == 'nt':
diff --git a/dev-python/pypy3/pypy3-7.3.1-r1.ebuild b/dev-python/pypy3/pypy3-7.3.1-r2.ebuild
index 023f8e46c876..023f8e46c876 100644
--- a/dev-python/pypy3/pypy3-7.3.1-r1.ebuild
+++ b/dev-python/pypy3/pypy3-7.3.1-r2.ebuild