summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyqtgraph
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyqtgraph')
-rw-r--r--dev-python/pyqtgraph/Manifest2
-rw-r--r--dev-python/pyqtgraph/metadata.xml8
-rw-r--r--dev-python/pyqtgraph/pyqtgraph-0.9.10.ebuild50
-rw-r--r--dev-python/pyqtgraph/pyqtgraph-0.9.9.ebuild49
4 files changed, 109 insertions, 0 deletions
diff --git a/dev-python/pyqtgraph/Manifest b/dev-python/pyqtgraph/Manifest
new file mode 100644
index 000000000000..9f6dbadd1416
--- /dev/null
+++ b/dev-python/pyqtgraph/Manifest
@@ -0,0 +1,2 @@
+DIST pyqtgraph-0.9.10.tar.gz 1086558 SHA256 4c0589774e3c8b0c374931397cf6356b9cc99a790215d1917bb7f015c6f0729a SHA512 c947bf69116b8b0a61a1db6ec70d51741667387f98320ce581733a306bea704754b7bb0abf94d6f01ce74dfc218b3c573db017a5e189cde76d00f85bc6b23a3d WHIRLPOOL 45ce6873298b30f74b374d3e6d7a97b1602a723d6d08847f79560fb29e6d66b70e23705e07ec5481e427fde99f27d4b84da8565ea53d96a377f5727176d35c8f
+DIST pyqtgraph-0.9.9.tar.gz 1086535 SHA256 6f61a7415c9488b334f856f06bc436b61d3742b2257310fe4bc8a1b85f84590b SHA512 f1fdf6aa2d66f4fc222fbcf97709ef9d172a4f7611882f46e6f9738fed9485ada9d81dd4d078c51385743fa344e52c3c1e0477ae5b6fabd04718bba8622e6a3e WHIRLPOOL 4d68d476df65f71eb4d7ea88eb6004ffc09868de6dbcf5192da773af6069cd83f388e3945ced1977e2531c9249bc58cc950f8540aaf71696f55d973a005a0e33
diff --git a/dev-python/pyqtgraph/metadata.xml b/dev-python/pyqtgraph/metadata.xml
new file mode 100644
index 000000000000..8da1249232ec
--- /dev/null
+++ b/dev-python/pyqtgraph/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="github">pyqtgraph/pyqtgraph</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyqtgraph/pyqtgraph-0.9.10.ebuild b/dev-python/pyqtgraph/pyqtgraph-0.9.10.ebuild
new file mode 100644
index 000000000000..98a4de25c2bd
--- /dev/null
+++ b/dev-python/pyqtgraph/pyqtgraph-0.9.10.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+inherit distutils-r1
+
+DESCRIPTION="a pure-python scientific graphics and GUI library built on PyQt4/PySide and numpy"
+HOMEPAGE="http://www.pyqtgraph.org/ https://github.com/pyqtgraph/pyqtgraph"
+SRC_URI="http://www.pyqtgraph.org/downloads/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples opengl"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ || (
+ dev-python/PyQt4[${PYTHON_USEDEP}]
+ dev-python/pyside[${PYTHON_USEDEP}]
+ )
+ opengl? ( dev-python/pyopengl[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ # fix distutils warning
+ sed -i 's/install_requires/requires/' setup.py || die
+
+ if ! use opengl; then
+ rm -r pyqtgraph/opengl || die
+ fi
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pyqtgraph/pyqtgraph-0.9.9.ebuild b/dev-python/pyqtgraph/pyqtgraph-0.9.9.ebuild
new file mode 100644
index 000000000000..ac30be6cd9d1
--- /dev/null
+++ b/dev-python/pyqtgraph/pyqtgraph-0.9.9.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+inherit distutils-r1
+
+DESCRIPTION="a pure-python scientific graphics and GUI library built on PyQt4/PySide and numpy"
+HOMEPAGE="http://www.pyqtgraph.org/ https://github.com/pyqtgraph/pyqtgraph"
+SRC_URI="http://www.pyqtgraph.org/downloads/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc opengl"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ || (
+ dev-python/PyQt4[${PYTHON_USEDEP}]
+ dev-python/pyside[${PYTHON_USEDEP}]
+ )
+ opengl? ( dev-python/pyopengl[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ # fix distutils warning
+ sed -i 's/install_requires/requires/' setup.py || die
+
+ if ! use opengl; then
+ rm -r pyqtgraph/opengl || die
+ fi
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ distutils-r1_python_install_all
+}