summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-11-27 11:37:07 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-11-27 13:19:25 -0800
commit6bffbaa88d34c8a195854b5084ddb86a1f7a0cd6 (patch)
treea19c49fa0ef43e4e772771496c65aa503f65c6d1 /dev-python/pyquery/pyquery-1.4.1.ebuild
parentdev-python/wsgiproxy2-0.4.6: bump, add py38 and pypy{,3} (diff)
downloadgentoo-6bffbaa88d34c8a195854b5084ddb86a1f7a0cd6.tar.gz
gentoo-6bffbaa88d34c8a195854b5084ddb86a1f7a0cd6.tar.bz2
gentoo-6bffbaa88d34c8a195854b5084ddb86a1f7a0cd6.zip
dev-python/pyquery-1.4.1: bump, add py38 and pypy{,3}
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/pyquery/pyquery-1.4.1.ebuild')
-rw-r--r--dev-python/pyquery/pyquery-1.4.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/pyquery/pyquery-1.4.1.ebuild b/dev-python/pyquery/pyquery-1.4.1.ebuild
new file mode 100644
index 000000000000..ddcfe184a05d
--- /dev/null
+++ b/dev-python/pyquery/pyquery-1.4.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A jQuery-like library for python"
+HOMEPAGE="https://github.com/gawel/pyquery"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/lxml-2.1[${PYTHON_USEDEP}]
+ >dev-python/cssselect-0.7.9[${PYTHON_USEDEP}]
+ >=dev-python/webob-1.1.9[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/beautifulsoup[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/webtest[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/restkit[${PYTHON_USEDEP}]' 'python2_7')
+ )"
+
+RESTRICT+=" !test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}/pyquery-1.4.1-network-tests.patch"
+ "${FILESDIR}/pyquery-1.4.1-tests-pypy.patch"
+)
+
+python_test() {
+ # The suite, it appears, requires this hard setting of PYTHONPATH!
+ PYTHONPATH=. nosetests || die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "Support for BeautifulSoup3 as a parser backend" dev-python/beautifulsoup
+}